• Supertuxkart: Old OpenGL on Antergos Mate


    Guys:

    0_1452183323596_antiguaopengl.png

    I´m having troubles with the OpenGL (appears to be too old) on Supertuxkart in my Antergos Mate (on my Antergos Gnome there is no problem at all). Im running the kernel 4.1.15-1-LTS

    How can i solve this?

    Thank you :)

    Antergos Gnome - Lenovo G4070
    Antergos XFCE (Ex-Mate) - Dell D630
    Antergos Cinnamon - Asus E-11
    Puppy Linux Precise 5.7.1 - Asus 701 EEEpc
    Puppy Linux Lxpuptahr USB live - All machines

  • @Caiosama205 sometimes LTS version holds back packages until they are considered “stable” for usage. Not sure if this is the case but based on the error you need to upgrade to OpenGL 3.1.

    What cpu are you running? If you don’t know run this in terminal:
    lscpu
    Also which OpenGL are you running? To find out run this in terminal:
    glxinfo | grep OpenGL

    Post back the output of both of these please.

  • thank you for your response @linuxhelmet :)

    here is my lscpu:

    Arquitectura: i686
    modo(s) de operación de las CPUs:32-bit, 64-bit
    Orden de los bytes: Little Endian
    CPU(s): 2
    Lista de la(s) CPU(s) en línea:0,1
    Hilo(s) de procesamiento por núcleo:1
    Núcleo(s) por «socket»:2
    «Socket(s)» 1
    ID de fabricante: GenuineIntel
    Familia de CPU: 6
    Modelo: 15
    Nombre del modelo: Intel® Core™2 Duo CPU T7300 @ 2.00GHz
    Revisión: 10
    CPU MHz: 800.000
    CPU MHz máx.: 2001,0000
    CPU MHz mín.: 800,0000
    BogoMIPS: 3988.86
    Virtualización: VT-x
    Indicadores: fpu vme de pse tsc msr pae mce cx8 apic sep mtrr pge mca cmov pat pse36 clflush dts acpi mmx fxsr sse sse2 ss ht tm pbe nx lm constant_tsc arch_perfmon pebs bts aperfmperf pni dtes64 monitor ds_cpl vmx est tm2 ssse3 cx16 xtpr pdcm lahf_lm ida dtherm tpr_shadow vnmi flexpriority

    and here the OpenGL:

    OpenGL vendor string: Intel Open Source Technology Center
    OpenGL renderer string: Mesa DRI Intel® 965GM x86/MMX/SSE2
    OpenGL version string: 2.1 Mesa 11.1.1
    OpenGL shading language version string: 1.20
    OpenGL extensions:
    OpenGL ES profile version string: OpenGL ES 2.0 Mesa 11.1.1
    OpenGL ES profile shading language version string: OpenGL ES GLSL ES 1.0.16
    OpenGL ES profile extensions:

    Antergos Gnome - Lenovo G4070
    Antergos XFCE (Ex-Mate) - Dell D630
    Antergos Cinnamon - Asus E-11
    Puppy Linux Precise 5.7.1 - Asus 701 EEEpc
    Puppy Linux Lxpuptahr USB live - All machines

  • Did you upgrade your gpu drivers and mesa drivers? Are using optirun command?

  • @alaguna sorry, but how can i do that?

    Antergos Gnome - Lenovo G4070
    Antergos XFCE (Ex-Mate) - Dell D630
    Antergos Cinnamon - Asus E-11
    Puppy Linux Precise 5.7.1 - Asus 701 EEEpc
    Puppy Linux Lxpuptahr USB live - All machines

  • Details on optirun (I posted this only for knowlege sake due to not having a clue what optirun was lol):
    https://wiki.archlinux.org/index.php/Bumblebee
    I believe that only applies to dual graphics with Intel and Nvidia.

    As for your issue @Caiosama205 which graphics card are you running?
    You should be able to find that info under “Device Info” in “Settings” under Mate or using terminal:
    lspci | grep VGA

    I’m ASSUMING your running intel graphics, in which case you can check which version you are running this in terminal:
    yaourt -ss xf86-video-intel

    Check the version you have with the version listed on this page:
    https://www.archlinux.org/packages/?name=xf86-video-intel

    IF your version is older then try re-installing xf86-video-intel. If NOT you have the most current version of both mesa and intel graphics…in which case unfortunately I believe you are running too old hardware to support OpenGL 3.1 :(

  • @linuxhelmet this is my card:

    Intel Corporation Mobile GM965/GL960 Integrated Graphics Controller (primary) (rev 0c)

    The drivers:

    1 extra/xf86-video-intel 1:2.99.917+519+g8229390-1 (xorg-drivers xorg)
    X.org Intel i810/i830/i915/945G/G965+ video drivers
    2 aur/xf86-video-intel-git 2.99.917.392.g8090a65-1 (108)
    X.org Intel i810/i830/i915/945G/G965+ video drivers

    This is a very old computer, so i guess you are right, hardware is too old for that OpenGL :( , thank you linuxhelmet!!!

    Antergos Gnome - Lenovo G4070
    Antergos XFCE (Ex-Mate) - Dell D630
    Antergos Cinnamon - Asus E-11
    Puppy Linux Precise 5.7.1 - Asus 701 EEEpc
    Puppy Linux Lxpuptahr USB live - All machines

  • You’re welcome!

supertuxkart1 opengl7 Posts 8Views 1191
Log in to reply