• After install, Antergos boots to black screen & blinking cursor

    After a fresh install (Jan 6, 2016), Antergos boots to a black screen with a blinking cursor. Does not proceed to login screen or even splash screen.

    I’ve tried installing Legacy with GRUB on MBR of 2nd hard drive (which normally works perfectly with Ubuntu, Fedora, openSUSE, etc.). 1st SSD is some new RAID set-up that I’m not familiar with, so I booted the live USB with “nodmraid” and “nomodeset” (because of the Nvidia graphics on my laptop).

    Any suggestions on how to get this working?

  • Jesse, I think we’re experiencing the same problem. It’s not your fault but a problem with the latest, default theme produced by numix called numix frost. It’s being discussed in several places.


  • Thanks linux_mark. Yeah, I installed the GNOME desktop, and am not even getting to the login screen or any point where I can do ctrl+alt+f2 to change into a different non-X session. Any updated, suggestions, or fixes would be appreciated on this thread as well (or at least a link pointing to any of the forementioned). :)

  • Jesse, join the club. I have tried installing Gnome, XFCE, KDE, etc. They all have the default theme set at the numix frost theme and it’s screwing a lot of us up. In fact, a lot of arch linux folks are also screwed up because of this same theme but they’re in a slightly better situation. Let’s keep checking back with each other because I think the only work around would be to change the default numix theme from the terminal.

    Did you say you can’t do a ctrl alt f2 at the blinking cursor? I do get a login screen but a black and then gray desktop that goes nowhere. Did you set your system up to auto login when you configured the install?

  • @jesse.dubord GNOME requires KMS so you cannot use nomodeset to boot. Try removing any extra boot flags that you added and then grab the system logs and post a paste2 link here. Thanks.

  • Installing UEFI and rebooting after install brings the screen to a black screen with white text: it shows the GNU GRUB version, then follows with the text “Minimal BASH-like line editing is supported…” then goes to a grub prompt like so “grub>”. It won’t actually boot into Antergos.

  • @lots-0-logs , thanks for the info’. I’ll try to re-install without the boot flags.

    I’ll also try and get the system logs and send them your way asap. Thanks!

  • lots.0.logs, have you looked at my thread? This issue sounds identical to mine. I guess we’ll wait for the logs but, in all honestly, this sounds like a problem for numix, since their frost theme is causing this very problem and it appears that everyone it’s happening to is a nvidia user.

  • UPDATE #1 - While the black screen and blinking cursor is on the screen, if I press any keyboard key, the words appear:

    Reboot and Select proper Boot device
    or Insert Boot Media in selected Boot device and press a key

  • @jesse.dubord WHich options did you select during install? Did you use the advanced mode to choose your own partitioning? If so, what partition layout did you create?

  • @lots.0.logs , yes, I did legacy and advanced partitioning. Have two hard drives (technically, I’ve never seen a set-up like on this laptop. One hard drive is actually two ram-looking SSD’s RAID’ed together, and the other one is a 1TB 7200rpm normal hard drive). I install Antergos on the 1TB (which is sdc1), formatting it to ext4 format, installing Grub2 to the 1TB MBR (sdc), and then 10GB of swap space on 1TB as well (I know it seems ridiculous, but believe me I need it for Blender 3D modeling, haha).

    That’s the plan I’ve been going with.

  • @jesse.dubord Okay…you just need to do it again the same way except for one thing… you should set your existing EFI boot partition to be mounted as /boot/efi (don’t format it though!) and choose the device that has your EFI partition on it as the GRUB device. Let me know the result. Cheers!

  • @lots-0-logs , I reformatted the entire 1TB drive, then partitioned it like you said: first partition was /boot/efi, then /, then swap, and it worked! installed and booted into the login screen. Issues arose after installing the nvidia-352 driver, but that’s a different thread, I’m sure. So, consider this issue solved! Thanks so much for your help!

  • Glad to see you were able to get it working :)

booting problem19 Posts 14Views 9627
Log in to reply
Bloom Email Optin Plugin

Looks like your connection to Antergos Community Forum was lost, please wait while we try to reconnect.