• [Bug] [Steam client] Steam unable to start any game after suspending and waking up system

    Arch 64bit (Antergos), native steam, Asus n56vb laptop

    Steam works just fine after a normal boot or reboot. But if I suspend and wake up the system, steam becomes unable to start any game - a reboot is needed each time.

    The following is the output of the command while trying to launch a game in steam: “steam > steam.log”


    @Modisc : thanks for the advice, I was struggeling a bit with that, I hope that is somewhat better, did not figure out how to include the complete log as code in here (the code stuff is displayed correctly in the preview but not in the post)…

  • hi.
    Could you tag all that output? there is a sticky in the forums on which key on your keyboard to use to ensure that your output is properly coded.
    It’s difficult to read the way you have output it.
    Properly coding it reduces the large output to a more compressed version. Easier to read too.

  • Have you a Nvidia card with proprietary Drivers ?

    Just asking in the last update of the driver their was a little problem making softwares like steam to no behave properly. (This will be patched in the nex driver update)

  • @amo
    ok. So some questions from your log. And I am just throwing this out there, but did you install the fonts as per the Arch Wiki for Steam?
    Also, are you aware that on the Arch Wiki for Portal2 there is a trouble shooting section. I’ve read it but there does not seem anything relevant there for your errors.
    Also, the errors
    Ignoring invalid property 'route-data and Ignoring invalid property 'address-data' might suggest a network managing issue.
    Also, and this is just something to consider but read this at link given. Steam Segfaults
    I don’t think I quite understand by what they mean by moving the binary file for Network Manger away.
    Moving it temporarily out of the way? Hmmm…
    Just something to ponder on.

    EDIT: About the code tags, the key you use is this key (`)
    If you are using an English keyboard, it’s the key below the ESC key.

  • Hi @amo
    Could you check your file from
    and see if changing this
    export LD_LIBRARY_PATH="$LD_LIBRARY_PATH:/usr/lib32"
    to this
    export LD_LIBRARY_PATH="${LD_LIBRARY_PATH:+LD_LIBRARY_PATH:}/usr/lib32" works instead.

  • Oh now that is odd, because it works if I remove the launch option using primusrun, so @nekosan might be right with the hint concerning the drivers. Yes I have a Nvidia card with proprietary drivers and bumblebee to run them (my laptop also has an onboard card). So hopefully it will be fixed with the next update, but maybe it is an issue with the bumblebee or primusrun stuff?

    The issue with the Network Managing sounds odd, since the steam clients connects perfectly to the server and all the connections work just fine, even the steam browser. But thanks for the tip, it’s still a good page to keep in mind and observe.

    @Modisc: changing the export line gave an error on client startup. The client still started but had the same behavior afterwards.

    (The code tag does work, but not with a line break inside the `, therefore I could not put the whole log in here like that)

  • https://bbs.archlinux.org/viewtopic.php?id=205382

    Links for actual bug in nvidia drivers.

    for multiline use ```` (I would love to go in another rant against markdown but that’s not the place)

  • @amo
    The only reason why I mentioned Network Mgr is because you mentioned “steam becomes unable to start any game” and the first thought occurred to me is that your Steam Client was not able to communicate with the Steam Server, but I don’t think that is an issue as you can go offline with Steam. So, no. Network Mgr prob would not be an issue. Therefore, just ignore that part.

steam67 suspend47 game12 wake9 start3 Posts 8Views 2100
Log in to reply
Bloom Email Optin Plugin

Looks like your connection to Antergos Community Forum was lost, please wait while we try to reconnect.