• Locker Locks Me Out


    I have a problem with my locker, but I don’t think the problem is my locker; that’s why I decided to open up a new topic, because I’m really unsure what to search the forums for. I’ve tried searching, to no avail.

    I believe the problems I’m having are all symptoms of the same problem, so I’ll list them all here:

    Locking:
    Whenever I lock my screen, the resolution drops down to something ghastly, making my mouse cursor take up an exorbitant amount of space on what is otherwise a black background. There’s nothing else there and nothing is happening

    startx results in some mangled kind of terminal instance, where I have two terminal windows which I can move around with a working cursor, but it’s weird, the resolution (I’m guessing) looks like it’s somewhere around 640x320, possibly 800x600. I’m not sure and I don’t yet know how to tell.

    The only way I know how to get my desktop back is by rebooting.

    TTYs:
    Whenever I switch to a TTY, the resolution becomes awful again, but everything is in order. When I switch back to Gnome however, my wallpaper is a complete mess. Simply reloading the image will restore it, but it’s still quite annoying.

    Sudden segfaults:
    Sometimes, I can’t predict accurately when this happens, software will segfault. I think this might have to do with software which uses the GPU, for instance Steam likes segfaulting (even when I’m not touching anything) as well as some other programs. Firefox has as well.

    I’m at a loss, so I’ve some outputs which might be helpful here.
    If you need something else, please let me know!

    dmesg:

    [   24.235686] NVRM: Your system is not currently configured to drive a VGA console
    [   24.235689] NVRM: on the primary VGA device. The NVIDIA Linux graphics driver
    [   24.235690] NVRM: requires the use of a text-mode VGA console. Use of other console
    [   24.235692] NVRM: drivers including, but not limited to, vesafb, may result in
    [   24.235693] NVRM: corruption and stability problems, and is not supported.
    [   24.370428] nvidia-modeset: Loading NVIDIA Kernel Mode Setting Driver for UNIX platforms  358.16  Mon Nov 16 18:58:09 PST 2015
    [   24.371128] nvidia-modeset: Allocated GPU:0 (GPU-48b4bd13-9346-66b4-4488-2d45381694e7) @ PCI:0000:01:00.0
    

    uname -a

    Linux nixbox 4.3.3-2-ARCH #1 SMP PREEMPT Wed Dec 23 20:09:18 CET 2015 x86_64 GNU/Linux
    

    System Information

    MoBo: ASUSTeK M5A97 LE R2.0 (UEFI)
    CPU:  AMD FX-6350 Black Edition Six-Core Processor
    GPU:  Nvidia GeForce GTX 960
    RAM:  8GB
    
  • HI.
    I’m just throwing this out there but does your computer support Optimus? You have nVidia.

    Check also that you have the nouveau drivers blacklisted. Those will conflict with nVidia binaries. I would believe they would be as it would make sense that it would have been blacklisted while on your prior kernel use. But it doesn’t hurt to check as kernel installs can/may change settings.
    Have you thought about using the LTS kernel, instead? More stable.

    As for graphics, I think this may be also a different issue. I’m not 100 percent sure, again, just throwing it out there.

    Download " antergos-wallpapers-extra " and enjoy community sponsored wallpapers.

    Use the "Linux Beginner Search Engine"

    https://cse.google.com/cse/home?cx=017607476515012185699:b_owgx6xyi0

  • Hello!
    What’s Optimus?
    And I’d love to check, but I must fail at Google, because I can’t figure out how to blacklist things. And I thought I was using the LTS kernel!
    It’s really confusing if I’m not, I could’ve sword I’ve looked for the LTS image specifically.

  • Hello :

    What is optimus ? https://wiki.archlinux.org/index.php/NVIDIA_Optimus

    If you installed nvidia drivers via pacman it should blacklist nouveau by itself.

    cant you give us outputs for :

    lsmod | grep -E "(nv|nouveau)"

    pacman -Qsq 'nvidia|nouveau|mesa|libgl'

    This will give us better picture of what is on your system.

    Kernel Linux-LTS is 4.1.15-1 https://www.archlinux.org/packages/?name=linux-lts
    Kernel Linux is 4.3.3-2 https://www.archlinux.org/packages/?name=linux

    So you are not using the LTS kernel .

    Also while I think of sometime doing nvidia-xconfig will fix some issue.

    Long Live Antergos
    [Major Linux Problems on the Desktop or Why Linux is not (yet) Ready for the Desktop, 2016 edition] (http://linuxfonts.narod.ru/why.linux.is.not.ready.for.the.desktop.current.html)

  • Ahh I see~
    I have an AMD CPU; Optimus seems to be a thing for Intel chipsets, though :)
    Thanks so much for being kind like this, btw. I really appreciate it!

    I’ve not manually installed the drivers, the default non-free graphics installer took care of that for me.

    Output from lsmod:

    nvidia_uvm             81920  0
    nvidia_modeset        708608  4
    nvidia               8704000  77 nvidia_modeset,nvidia_uvm
    drm                   286720  3 nvidia
    

    Output from pacman:

    glu
    lib32-glu
    lib32-libtxc_dxtn
    lib32-mesa
    lib32-nvidia-libgl
    lib32-nvidia-utils
    libglade
    libtxc_dxtn
    libvdpau
    mesa
    mesa-demos
    mesa-vdpau
    nvidia
    nvidia-libgl
    nvidia-utils
    opencl-nvidia
    xf86-video-nouveau
    

    And I don’t know if it’s relevant, but sudo nvidia-xconfig outputs:

    WARNING: Unable to locate/open X configuration file.
    
    Package xorg-server was not found in the pkg-config search path.
    Perhaps you should add the directory containing `xorg-server.pc'
    to the PKG_CONFIG_PATH environment variable
    No package 'xorg-server' found
    New X configuration file written to '/etc/X11/xorg.conf'
    

    Should I change my kernel to the LTS one or should I just leave it for now?

  • @lumiette said:

    I’ve not manually installed the drivers, the default non-free graphics installer took care of that for me.

    What do you mean ? That you downloaded the driver binary from nvidia website ? or did you used pacman -S nvidia nvidia-utils nvidia-libgl opencl-nvidia ?

    For the rest it look like nouveau is not loaded while the package is present on your system, I’m not really sure if removing it can do something or not.

    Long Live Antergos
    [Major Linux Problems on the Desktop or Why Linux is not (yet) Ready for the Desktop, 2016 edition] (http://linuxfonts.narod.ru/why.linux.is.not.ready.for.the.desktop.current.html)

  • I mean I installed the whole system ( including non-free drivers ) from a LiveUSB. I never installed any drivers manually.
    I could try and execute that pacman command, see if that does anything?
    Also, I had a segfault:
    Chrome_ChildThr[3918]: segfault at 0 ip 00005648b9f3d38a sp 00007f14c65fe480 error 6 in plugin-container[5648b9f35000+6b000]

  • Après une petite recherche de cette erreur il se pourrai que ce soit lié à une mauvais installation de X.org (j’ai trouvé un vieux sujet sur le forum Archlinux datant de 2007)

    Please do pacman -Sy xorg-server and after try agains pacman -Sy nvidia nvidia-utils nvidia-libgl opencl-nvidia and in case of “something” and free some disk space pacman -Rs xf86-video-nouveau some sudo nvidia-xconfigto be sure X.org got the good conf for your card an drivers then reboot your system.

    Long Live Antergos
    [Major Linux Problems on the Desktop or Why Linux is not (yet) Ready for the Desktop, 2016 edition] (http://linuxfonts.narod.ru/why.linux.is.not.ready.for.the.desktop.current.html)

  • @nekosan said:

    Après une petite recherche de cette erreur il se pourrai que ce soit lié à une mauvais installation de X.org (j’ai trouvé un vieux sujet sur le forum Archlinux datant de 2007)

    Please do pacman -Sy xorg-server and after try agains pacman -Sy nvidia nvidia-utils nvidia-libgl opencl-nvidia and in case of “something” and free some disk space pacman -Rs xf86-video-nouveau some sudo nvidia-xconfigto be sure X.org got the good conf for your card an drivers then reboot your system.

    First of all, thank you so much for the effort you’re putting in. I really appreciate it!!
    That said, I’ve done all the steps you’ve suggested and got no errors, but the problem persists.
    dmesg still tells me nvidia: module license 'NVIDIA' taints kernel. and NVRM: Your system is not currently configured to drive a VGA console on the primary VGA device.

  • Did I wrote in french ? yesterday yes … yes I did sorry I was tired, I need more sleep (also wrote a mail to a friend in english >< ) Sorry for that.

    I did some search again something this time with UEFI.

    Did you set up your mobo to “fast boot : Off”, “CSM : AUTO” and “Secure Boot : Other OS” ? better be sure, as far as I can see Nvidia drivers still not support UEFI (or not fully).

    And could you do a fresh install of Antergos after that to be sure ?

    For the line nvidia: module license 'NVIDIA' taints kernel.its not a problem that mean you are running a non GPL module with the Kernel here Nvidia module that are indeed not GPL.

    Long Live Antergos
    [Major Linux Problems on the Desktop or Why Linux is not (yet) Ready for the Desktop, 2016 edition] (http://linuxfonts.narod.ru/why.linux.is.not.ready.for.the.desktop.current.html)

  • @nekosan said:

    Did I wrote in french ? yesterday yes … yes I did sorry I was tired, I need more sleep (also wrote a mail to a friend in english >< ) Sorry for that.

    Haha, no problem at all, Google did a great job of translating it!
    Sleep deprivation and language don’t mix, I always end up spelling things phonetically, or using Dutch grammar. :)

    Did you set up your mobo to “fast boot : Off”, “CSM : AUTO” and “Secure Boot : Other OS” ? better be sure, as far as I can see Nvidia drivers still not support UEFI (or not fully).

    Is it me or does UEFI seem like DRM for OSes?
    I did turn fast boot off, and I have either set it to Other OS or disabled it entirely (if that’s possible, I’ll reboot in a moment and check, I’ll see if CSM is in there while I’m at it.)

    And could you do a fresh install of Antergos after that to be sure ?

    I … could!
    But it’s a bit of a last resort, since pretty much all else is set up the way I like it already – also, it’s a bit scary because I had a lot of trouble getting this installation to work to begin with.

    For the line nvidia: module license 'NVIDIA' taints kernel.its not a problem that mean you are running a non GPL module with the Kernel here Nvidia module that are indeed not GPL.

    Ah, good then, no troubles there.
    I’ll reboot now :)

  • @nekosan Rebooted, checked my settings!
    Fast Boot was off already, so I left it that way.
    CSM was set to Enabled (now to Auto, though judging by what Disabled does, I’m guessing it doesn’t make a difference in my situation), and
    Secure Boot was indeed set to Other OS

    I tried switching to my TTY and back the first boot, and lo and behold, my wallpaper wasn’t garbled!
    Tried it again just now, but it does the garbling thing again, so I guess last boot was just lucky. :<

    If reinstalling is what it takes, I’ll have to submit to it, but you know. If at all possible, I’d like to avoid it! I wonder if updating my kernel could solve anything or effectively do the same thing a reinstall would within my subset of parameters. Since I’m not running LTS, is it possible that might not help things?

  • I don’t know what to do their all the result with your error seem to come from UEFI not supported by nvidia and and CSM to be used (auto or enabled).

    I think you can try using the lts kernel and lts nvidia driver branch to see if something changes. linux-lts and nvidia-lts

    If nothing change I am not skiloled enough to see further than this.

    Long Live Antergos
    [Major Linux Problems on the Desktop or Why Linux is not (yet) Ready for the Desktop, 2016 edition] (http://linuxfonts.narod.ru/why.linux.is.not.ready.for.the.desktop.current.html)

  • @nekosan Well, thanks for trying at least! I’ve learned a few things, so that was interesting :)

    As an aside, I don’t know why I didn’t do this sooner, screen before accessing TTY2 (it’s the same across the board):
    http://i.imgur.com/sZAPZqN.png

    After coming back to Gnome:
    http://i.imgur.com/4QFn7BA.png

    Just as a point of interest, I suppose.

amd24 nvidia111 locker2 tty6 uefi37 Posts 14Views 2300
Log in to reply