• Motherboard Led And Fans On after SHutdown


    Fans and motherboard LEDs don’t switch off after shutdown. Restart works properly, the problem is just with shutdown. I have also tried poweroff from the terminal but it gives the same result

  • Sounds like you are in stand by, not shutdown.
    what happens when you do sudo shutdown -h now
    What are the power mgt settings? Check.
    And if it isn’t any of those, then most likely it is because you are running pretty hot. Graphic chip delamination. Shorts and dropouts. The fan is active because something is hot. This is not an OS/software concern but a Hardware issue.

    Download " antergos-wallpapers-extra " and enjoy community sponsored wallpapers.

    Use the "Linux Beginner Search Engine"

    https://cse.google.com/cse/home?cx=017607476515012185699:b_owgx6xyi0

  • This is not a heating problem. I have a dual boot with windows and windows shuts down properly. Also i had checked the temperatures from windows, the temp doesn’t exceed 60-62.(Load test). shutdown -h yields the same result.

    1. motherboard information
      dmidecode -t1

    2. what is temp reading from with the Linux OS?
      2A. Do you have laptop-mode-tools or lm-sensors or hddtemp installed?

    3. check BIOS for return to default settings.
      What happens when you long press to boot down?

    4. Have you cleaned out the inside with canned air of any dust or other blockages. Just because you are not experiencing symptoms in one OS and not the other doesn’t mean all is good internally. It is a known fact that Linux in general generates more heat and give you less battery life as compared to a Windows OS due to the fact open source drivers doen’t do power management well and is by default set to run on full power all the time.

    5. What graphics do you have?

    6. What DE are you using? A heavy one like KDE or Gnome? Heavier DEs will generate more power consumption than let’s say, one like Openbox or XFCE. More power, more heat. That is a fundamental power generation concept.
      6A. Have you checked the Arch Wiki on Powersaving?

    7. What happens when you add acpi=force to your Grub?

    GRUB_CMDLINE_LINUX_DEFAULT="acpi=force"
    Make sure you add a SPACE immediately after preceding instructions .
    For example GRUB_CMDLINE_LINUX_DEFAULT="ABCDEFG acpi=force"
    Then update your Grub config.

    Download " antergos-wallpapers-extra " and enjoy community sponsored wallpapers.

    Use the "Linux Beginner Search Engine"

    https://cse.google.com/cse/home?cx=017607476515012185699:b_owgx6xyi0

  • Sorry for the delay and thanks for your patience.
    1)The motherboard is a H170 gigabyte :-

    # dmidecode 3.0
    # SMBIOS entry point at 0x000f05e0
    Found SMBIOS entry point in EFI, reading table from /dev/mem.
    SMBIOS 2.8 present.
    
    Handle 0x0001, DMI type 1, 27 bytes
    System Information
            Manufacturer: Gigabyte Technology Co., Ltd.
            Product Name: H170-D3H
            Version: To be filled by O.E.M.
            Serial Number: To be filled by O.E.M.
            UUID: 03000200-0400-0500-0006-000700080009
            Wake-up Type: Power Switch
            SKU Number: To be filled by O.E.M.
            Family: To be filled by O.E.M.
    
    
    
    

    2)temperature using lm_sensors:

    acpitz-virtual-0
    Adapter: Virtual device
    temp1:        +27.8°C  (crit = +119.0°C)
    temp2:        +29.8°C  (crit = +119.0°C)
    
    coretemp-isa-0000
    Adapter: ISA adapter
    Physical id 0:  +31.0°C  (high = +84.0°C, crit = +100.0°C)
    Core 0:         +27.0°C  (high = +84.0°C, crit = +100.0°C)
    Core 1:         +28.0°C  (high = +84.0°C, crit = +100.0°C)
    Core 2:         +26.0°C  (high = +84.0°C, crit = +100.0°C)
    Core 3:         +28.0°C  (high = +84.0°C, crit = +100.0°C)
    
    1. long press of the power button leads to a shutdown but doesn’t switch off the led &fans.
    2. the whole system is cleaned regularly and was assembled a few months ago.
    3. I am using the integrated intel graphics, no dsicrete GPU.
    4. I am using KDE. I will check the ARchWiki on powersaving.
    5. i added acpi=force to /etc/default/grub :
      GRUB_CMDLINE_LINUX_DEFAULT="resume=UUID=32944407-76bf-404e-9311-d1139221545e quiet acpi=force"
      is this right? because i updated grub and the problem is still the same.
  • Yes, that was correct. Since it did no good, please reverse the changes since they had no positive effect.
    Am wondering if adding apm=power_off would instead be workable.

    Don’t input that into that grub.cfg just yet because I am none too sure if that would also have to be added to modules as well.

    Let me research this first.
    Will return and post with further info and some other ideas.

    Also, your heat/temp stats are fine. No issue there. I had to guess/assume it was a heating issue because one has to deduce the obvious and more notable one’s first.
    Hence my earlier assumption. However, that is obviously not the case.

    Download " antergos-wallpapers-extra " and enjoy community sponsored wallpapers.

    Use the "Linux Beginner Search Engine"

    https://cse.google.com/cse/home?cx=017607476515012185699:b_owgx6xyi0

  • I’m sorry. I have had a look around and I don’t believe that the apmd (for advanced power mgmt daemon) would do anything for you.
    There is one last thing and that is to add it to the line
    GRUB_CMDLINE_LINUX="" instead.
    Not GRUB_CMDLINE_LINUX_DEFAULT=
    There are two (2) different lines. Look carefully for them.
    So your grub config would look like this
    GRUB_CMDLINE_LINUX="acpi=force"
    If you want to find out a bit more on acpi, you can read about it here on the Arch Wiki. acpi

    Download " antergos-wallpapers-extra " and enjoy community sponsored wallpapers.

    Use the "Linux Beginner Search Engine"

    https://cse.google.com/cse/home?cx=017607476515012185699:b_owgx6xyi0

  • I added it to the grub. Still the same result.
    Also every time i shutdown this is displayed on the screen

    [some number] cgroup : option or name mismatch, new : 0x0 "",old 0x4 "systemd"
    [number] reboot: Power down
    

    This is right from the beginning not after adding acpi=force

  • hi.
    That message that you are given is a message from the kernel.
    To begin with for what a cgroup is:

    A cgroup is short for Control Group It is a feature within the Linux kernel.
    From Wikipedia:

    cgroups (abbreviated from control groups) is a Linux kernel feature that limits, accounts for, and isolates the resource usage (CPU, memory, disk I/O, network, etc.) of a collection of processes.
    

    It is nothing to worry about.
    Explained below:
    Basically what is happening is that some file system is (or was) remounted and there are some options that are (or were) changed that should not have been changed.
    You can ignore it. It don’t mean much.

    Additionally, there is a post that I found at the Arch forums.
    Read more about it here (solution to mask that is given at link provided):
    https://bbs.archlinux.org/viewtopic.php?pid=1362098

    Question: Is the shut-down slower than what would be perceived as normal?

    Back to the original problem, can you revert your settings to default before you made the 2 above mentioned changes. Most obviously they don’t do much.

    I thought that adding acpi=force would force a shutdown to your computer since it does not seem to want to shut off completely. Most obviously it has not worked.

    I honestly really don’t know.
    Your problem is unique I think.
    The last that I can think of is perhaps to

    1. reset to the factory defaults in the BIOS. You probably don’t want to do this since you mention that you run Win alongside your Linux OS. Some BIOS settings changes are necessary to amicably have both OS run on same computer. I am only mentioning this as a point of discussion. Not something to necessarily change unless there was a BIOS setting that was changed and that is not really needed for both OS to operate.
      BIOS update at some point in history, perhaps to affect current situation ?

    Am mentioning all of this stuff re: BIOS because all my online research for you has been leading to BIOS related considerations

    1. Something to consider. Do you have DVD drives? If so, can you eject these while the fan is still running after power down?
    2. Leaking PSU? Does it deliver the correct voltage to the motherboard? Am saying/asking this because if it is a hardware problem, then there is a hardware solution. Read this for related PSU:
      http://superuser.com/questions/775553/cpu-gpu-fans-spinning-at-full-speed-after-shutdown
    3. User setup problem? That is, it’s a localized problem to you Linux box.
      What, I don’t know.

    Am only throwing all these out there to broaden scope of consideration.

    Download " antergos-wallpapers-extra " and enjoy community sponsored wallpapers.

    Use the "Linux Beginner Search Engine"

    https://cse.google.com/cse/home?cx=017607476515012185699:b_owgx6xyi0

  • I will research about the BIOS related stuff. I am thinking of re-installing Antergos. I don’t have much data on it.

  • ok, that’s fine.
    I would still be really be interested in knowing if it continues with the newer install. Because if it is, then maybe it is an OS related configuration that just needs tweaking. Do you recall if you tweaked anything post install of the current (not newer) install that may have contributed to these LED lights and fan not turning off after shutdown?

    Something that just occurred to me in thought. How much RAM does your machine have?
    free -mt
    Am asking because sometimes (and the key word is " sometimes" , because not always" ) is that hibernation and / or a hybrid shutdown may take particularly long if you have lots of RAM. Let’s say some number that would be ridiculously high.
    16 Gigs would be fine and should not contribute to problem.

    I have to retract something that I mentioned earlier and it is about the PSU. You mentioned that the system was assembled quite recently so a broken PSU would not be the culprit. Nor would any bad sectors on hard - drive because again, your system is recent.

    Another thing that comes to mind is the boot order within in the BIOS. Ensure that it is the default setting. Am mentioning this because wrong boot orders, as set within the BIOS, can/ could contribute to the fans running longer. Not exactly sure how, but I have read that it is possible.

    Lastly, because you mention that you want to re-install your system again. If problem re-asserts itself on new install, you may wish to consider this: After the OS has shut down, you know that all of it’s process’s have also shutdown. It makes no sense to think that a system is still working in background somehow if you shut it down completely. It would be something hardware related. And that is even considered if you have properly checked the sleep, shutdown, and hibernate settings.

    And by-the-way, if you ever want to find out about your BIOS, man dmidecode is what I would refer to.
    For example, you want to find out how many megahertz your system has? sudo dmidecode --type 17
    Or specifically and only your BIOS sudo dmidecode --type 0

    Download " antergos-wallpapers-extra " and enjoy community sponsored wallpapers.

    Use the "Linux Beginner Search Engine"

    https://cse.google.com/cse/home?cx=017607476515012185699:b_owgx6xyi0

cpu fans runnin1 shutdown18 Posts 11Views 1809
Log in to reply