• Desktop Login

    to downgrade cd /var/cache/pacman/pkg/ and then pacman - U name-of-package-file
    then add it to your pacman.conf in the IgnorePkg section
    man pacman

  • @Modisc Modisc, thanks for your comments but guess what? I’m screwed and so is everyone else who is having this problem. Why, you ask? Because this is a brand new theme so it can’t be downgraded because it replaced several other themes. This means anyone experiencing the same problem as me is going to have to wait until numix creates a newer theme that corrects this problem. Hopefully someone from antergos or arch has been in communication with the numix folks to sort this all out. I don’t see another solution. If I could boot up I could easily change to another theme but this is not possible right now because of this issue.

    Oh, and one more thing. I don’t have access to any kind of an editor so it’s virtually impossible to edit pacman.conf from pure terminal, right? This is the only way I can access any files via the ctrl alt f2 command.

  • @linux_mark
    sorry, I should have been more explicit.
    I know that you don’t have GUI access. I am aware of that. I guess what I meant to say is that when you get to the actual Grub menu (hopefully you at least have that. If not, ignore everything from here on), that menu where you select Antergos. It’s the one where you probably have a listing of OS to select to boot into. Instead of selecting Antergos with ENTER, you selecct e , for EDIT. You select e with your keyboard.

    Once you have selected e with your keyboard, you use your arrow keys to navigate to the line that says " linux "
    Use your arrow keys to go to the end of that line. Then SPACE, then input systemd.unit=mulit-user.target.

    Then, I believe you select from your keyboard, F10 (there should be a navigational and instructional menu at/near bottom of said kernel command line. You are editing your kernel this way. It is easy and simple.

    After you select F10 , your computer automagically boots from kernel command line to a non-Gui mode.

    Log in with your credentials. Again, you are not in any GUI like you might think you are. You are in command line mode. Sorry, but this is what I meant earlier when I said a basic command line. I should have been more explicit. I though that perhaps you understood.

    Regardless, after you log in with your credentials, do sudo su to remain as root. Follow instructions posted earlier.

    If you are not interested in using this route then there is not really much of another option left since you can not log in via a GUI avenue. In order to fix any GUI options/problems/etc… when you don’t have GUI available, then Linux gives it’s users, (unlike Windows which does not and probably never will when you are faced with the beloved Windows blue screen of death, for instance) an effective means to resolve your issue.


    Since you don’t have a GUI editor, you instead use the vi editor with the instructions I made in earlier post.
    vi editor is simple and requires only some knowledge.

    After you have followed earlier instructions posted, you start of with vi then the name of the file or instruction. In this case you would do vi name-of-file after you have cd into the respective directory

    To navigate within vi editor, you use your arrow keys. Suffice it to say, that for me to teach you how to use the vi editor would have me write a longer than normal post. Further suffice it to say, that you really only need to be familiar with about 6-7 keys on your keyboard to effectively use it.

    To save your edit from within vi editor, you first do : then w then q

    Here is some info on how to use it how to use vi editor

    Hope this helps! :)

  • Modisc, got it. I’m not really sure what this suggestion will fix. Numix Frost is a new theme and, as such, there is nothing before it. The only way to solve the problem I’m having is with a new theme or switching the default theme via the terminal. Does this make sense?

    I know this sounds weird but remember, this is a brand spanking new issue. Numix has to fix this. I’m sure Arch has been in touch with Numix as have a few other distros that may be having issues with this theme. I think the work-around is to switch themes. Can I do that via the terminal? I suspect I can since arch folks do everything via the terminal. :)

  • See,

    Al_Sever figured it out before all of us.

    First of all sorry for my english…
    The problem is caused by the ‘numix-frost-themes’ package in up to 3 versions. Downgrading to versions 2.5 problem doesn’t exist. Alternatively, select another GTK+ theme (for example ‘Adwaita’).
    I’m waiting for a ‘numix-frost-themes’ upgrade that solves this issue.

    Thanks for the information, yes you’re right, the problem is caused by the numix-frost-themes!

    But see, he, unlike me, managed to get to boot up to the desktop. If I hadn’t had the problems I did a few weeks back I might be ok. Part of that problem was my fault. I installed some of the driver components for my video card using yaourt. I discovered recently that this is a bad way of installing any drivers you want to ensure are updated and, when my machine crashed and wouldn’t boot up, it is because I had installed some of the driver components for nvidia through yaourt. I know, a different problem all together. I’m just mentioning that it was here that my problems started.

  • Hi everyone, I apologize for not noticing this thread before now. First let me clear up some of the misinformation that has been exchanged thus far (which is no one’s fault, btw, it’s just what happens when there no one around that is familiar with the issue being discussed.).

    1. While I have not looked into the specifics of the claim that Numix Frost is causing the issue being discussed here, I cannot stress enough how VERY unlikely that is to be the case–and even if it were causing this (which I doubt), you would still have access to the login screen without any problems because the login screen does not use any Gtk theming. It wouldn’t be until after you log in that the problem would occur.
    2. There are three major players for graphics: Intel, NVIDIA, & AMD. The order I listed them is how they rank in regards to support for linux hardware. NVIDIA has far better support for linux than AMD (that is a fact, not FUD…I am no fanboy–I honestly don’t care about graphics or who makes my graphics card )
    3. Vi/Vim is NOT a good recommendation for less-experienced users 😉 hehe IJS!

    @linux_mark I am going to review your logs and let you know what I recommend your next course of action should be. (Going to eat dinner first though!)


  • I do have access to the login screen if I don’t choose auto login. So that’s why I’m 95% sure this is numix. Did you read the comments about this issue on the arch linux link? I think I posted that one as well.

  • @lots.0.logs whats for dinner? 😆

  • @linux_mark Like I said, I havent reviewed everything yet but I can tell you that I am 99% sure its not Numix Frost. I am an NVIDIA user. If there were an issue, I would surely have experienced it myself.

    I do have access to the login screen if I don’t choose auto login.

    Sorry, could you confirm whether or not you can access a fully functional login screen with our lightdm greeter? It is not clear to me if thats what you are saying. Also please post the output of the following command: pacman -Qi lightdm-webkit2-greeter

  • Lots of Logs, there is nothing wrong with my greeter. However, this past install i chose auto login. If I were to reinstall tomorrow I would get a login screen and, in fact I did with the last install for kde.

    Last Login: Wednesday Jan 6, 20:49:14 on tty2
    Name: lightdm-webkit2-greeter
    Version: 0.2.3-3
    Description: A webkit2 greeter for lightdm
    Architecture: x86-64
    Conflicts with: light-dm-webkit-greeter light-dm-webkit-theme-antergos
    Replaces: light-dm-webkit-greeter light-dm-webkit-theme-antergos </2.2.4>
    Build date: Wed Dec 16, 2015 7:15:22 AM EST
    Install date: Wed Jan 06, 2016 08:04:29 PM EST
    Install reason: Explicitly Installed
    Install Script: Yes

  • @linux_mark Okay, try installing the lts kernel and see if you have the same issue when you boot with it:

    pacman -S nvidia-304xx-lts  nvidia-304xx-libgl linux-lts
    # in case pacman installed the kernel BEFORE the drivers
    mkinitcpio -p linux-lts
    # blackist nouveau
    echo "nouveau /dev/null" > /etc/modules.load.d/blacklist.conf

    Let me know the result. Cheers!

  • Hey @linux_mark , I came across a solution on stackexchange that worked for me. I believe you said you had access to a terminal. If so, try this:

    I didn’t need to do the first step with the systemd command; I simply ran the terminal commands under the first solution and it worked like a charm. :) Hope this helps.

  • This was on a fresh Antergos install on a laptop that has two Nvidia GTX 970’s in it. I didn’t have to tweak the themes at all.

  • Please forgive me if this is a stupid intrusion. It happened to get a call from a friend I had installed Antergos/gnome, less than a week ago. After updating his system before bed, he could not reach the loggin screen the next morning. All he got was a black screen with a cursor.
    After spending some time to sort it out, I came up with the idea (out of desperation) to install and run gdm instead of lightdm. And…it worked!!!
    Unfortunately, I dont know his hardware and I cannot tell (at the moment) if it was an NVidia issue…

  • I currently have a workaround but am not in love with it. I managed to get mate installed last night but guess what? The frost theme is not the default. And I suspect this is why it installed and booted up. However, there is another glitch with nvidia and this goes back to my problem from a few weeks ago. If I install any of the 304xx nvidia drivers and reboot I blow up my machine. I will probably search for another thread with specifics to that issue and rename this issue because I really do believe this is a numix problem. I’ll bet you I could also install xfce and login but I still won’t be able to install gnome or kde.

    And anarch, what you’re speaking of is different from my issue. I can change greeters and stil have the same problem.

  • @linux_mark I don’t know how many times I have to say it so I will say it once more, THIS IS NOT A NUMIX THEME ISSUE. I would appreciate it if you would stop telling everyone that it is the theme as doing so only serves to cause confusion and spread misinformation. Have you tried installing the LTS kernel like I advised? What was the result?

    Best Regards,

  • Dustin, have you read any of the links I have shared? I was able to install KDE three weeks ago and something changed. I cannot install KDE or GNOME. Both are running the numix frost theme.

    Oh, and since you aren’t reading my thread I’m mention this again. I have no trouble logging on. I just don’t get a desktop, which I did before this issue popped up. Now since I can install mate but can’t install gnome or kde, how can you claim it’s something else? Have you attempted to install antergos on a machine that has older nvidia drivers?

  • Dustin, thanks for blowing up my system. I mentioned i had downloaded mate and hadn’t configured the xserver for nouveau because I knew that it would blow up my system and give me a black screen of death. I downloaded the lts drivers, followed your instructions to the letter and three hours of customizing just flew out the window. I have officially experienced the BSOD of Antergos for the last time, or until you fix the problem with the drivers. I wasn’t even trying to install gnome or kde because I knew I would have problems. If you had read any of the other threads about updating the drivers then you might know there is a problem. Even with the lts drivers because they are mirroring the nvidia drivers. I can’t go through the heartache of installing antergos again. This is a shame because antergos had become my distro of choice. It was highly customizable and fun to work with. And, it almost never broke. That is, until the month of December. Now my BSOD can’t be blamed on numix frost because i’m not running it right now. I can blame it on the drivers.

  • @linux_mark hey man take it down a notch. dustin is taking time to figure this out for you. sometimes these problems are not easily solved. i dont see how installing video drivers would blow up your system? its nothing that cant be fix.

  • @linux_mark said:

    Dustin, have you read any of the links I have shared?

    Yes, I have actually. The forum thread that you referenced which you claim proves its a theme issue is actually proof that it is not a theme issue. The issue on that thread is talking about themes which have not been updated to the new Gtk CSS structure and SASS preprocessor. Numix Frost was completely rewritten in SCSS with SASS over a year ago. Therefore, the issue in that thread has nothing to do with the issue you are experiencing. The reason I didn’t explain all of this before now is because I honestly did not have the time to explain it, and quite frankly, my word should be enough considering my position here and overall linux experience level.

    Installing the LTS kernel and drivers would have ZERO affect on the regular kernel and drivers. If you get a black screen then simply reboot and choose the regular kernel when grub appears. You have been all over the place in your explanation of the issue. Unless you provide clear description of the issue’s current status and DO NOT MAKE ANY CHANGES until one of our developers gets back to you with instructions, then I’m afraid we cannot help you. Sorry.

nvidia163 gnome310 Posts 40Views 13016
Log in to reply
Bloom Email Optin Plugin

Looks like your connection to Antergos Community Forum was lost, please wait while we try to reconnect.