• Desktop Login


    Ok, so here’s my issue. Re-installed Antergos the other day after and update screwed up my system a week ago. Initially, I had reinstalled KDE but, after last night, became frustrated when an update once again screwed me up. I struggled with that update to get my pc working again and then decided to reinstall. Of course the update that screwed me up with an nvidia driver. I have been screaming at this pc all day. I swear, the next pc I build or buy will not have an nvidia card of any kind in it.

    Anyway, a few hours back I reinstalled kde but that resulted in a grey screen after login. I searched all around here for a solution but found the same one I had tried earlier. Then I installed Gnome. This one is even worse. I don’t even get a login screen.

    Let me tell you what I did so that you understand.

    When antergos finished installing and I got to a blank bootup screen I did ctrl alt f2 and installed the correct drivers for my system.

    I have a GeForce 6500 card so my drivers are 304xx.

    I installed, via pacman, the following.

    nvidia-304xx
    nvidia-304xx-libgl

    Then I ran mkinitcpio -P linux

    Now when I boot up I do not get a login screen for gnome. Instead I get a black desktop with a blue square in the upper right hand corner of my screen. I do not know what else to do. I cannot run nvidia-config. I have already tried this. Any suggestions?

  • “When antergos finished installing and I got to a blank bootup screen I did ctrl alt f2 and installed the correct drivers for my system.”

    First time you have nouveau (which means that you have install proprietary drivers) or wrong nvidia binaries (yes, that means that you try to install correct drivers)?

    Regarding nvidia binary install, case you have nouveau drivers, for your card :

    1. open a terminal from KDE, Gnome or whatever DE you have
    2. sudo pacman -S nvidia-304xx nvidia-304xx-libgl
    3. confirm mesa-libgl rewrite (Yes, enter - case you have nouveau installed)
    4. at first convenient time, restart your system
    5. nothing else. you will see a shortcut in your menu for additional Nvidia Server Settings

    New initram? Ctrl+alt+f2 - why you have to leave X server?

    a warm place with no memory

  • HI @linux_mark
    To best determine what is going on or wrong with your boot up, could you please post some boot files. These are fundamental to resolving issues. Boot files is what you look at to see what is going wrong with the boot up/system.

    1. Please could you use the correct coding tags for these.

    A couple of things to answer for while you are getting your boot logs

    1. Could you confirm (either with or without the output) that you have a login manager installed. You need to evidence this yourself since you state that you don’t have a login screen with Gnome.
      sudo pacman -Qi the-name-of-the-login-mgr-you-have

    2. Just as a side note, nVidia and Linux are not the greatest bed mates. nVidia has not really made a tonne of strides in being compatible with Linux like AMD and Intel have. Just so you know… But things are improving. But that doesn’t help you much right now.

    3. Also, what @roberto says is correct that the first time you install Antergos, you have nouveau drivers installed. This is default. Best to probably install all the nVidia stuff after full install is complete.

    4. Also, what @roberto said is also correct to confirm that you have mesa-libgl installed.

    Download " antergos-wallpapers-extra " and enjoy community sponsored wallpapers.

    Use the "Linux Beginner Search Engine"

    https://cse.google.com/cse/home?cx=017607476515012185699:b_owgx6xyi0

  • Modisc, you have me thoroughly confused now. When I install the nvidia drivers and the nvidia-libgl I am prompted to overwrite the mesa-libgl because the two conflict. I was always taught to say yet to the overwrite.

    I will reboot and get the other information but I feel this is a moot point because this is a brand new install for the sixth time in two days in an attempt to get a working antergos pc.

    Also, one other thing folks. I have been using antergos for about eight months and loving it. I’m not new to antergos or these nvidia problems. I understand them too well and have even seen Linus give the finger to Nvidia in a hilarious youtube video. lol.

    Lastly, when I reboot after the install I see a blank desktop with a huge mouse arrow. Looks like an 800x600 mouse desktop but I’m just guessing.

  • @linux_mark ive gotta say this sounds very odd :confused: are you getting any errors or issues on install? the fact that you are needing to reinstall over and over says something else is going on here to me. Nvidia has great linux support from my experience. amd is slow as heck with updates.

  • megaman, it’s very weird indeed. I suspect, and this is just my suspicious, that something has changed with the nouveau drivers.

    Here are the steps I go through to install the drivers after antergos installation.

    I reboot my machine after antergos. When my machine boots up I don’t see a desktop. Through reading I have determined that this may have something to do with the default theme. So I boot up to a desktop that has a black screen with a teaser of color in the upper right of my desktop. This is gnome so the lightdm is the choice for greeter and is installed but I never see it. I attempt to install the driver for my system with ctrl alt f2. I install the 304xx drivers, which are supposed to be appropriate for my machine. These are the same drivers that I’ve installed for the past six to eight months. Every time there was an update it was an update to these drivers. I install them, reboot and still cannot see my desktop.

    As I suspect, it’s possibly the theme interfering with my login. My cursor changes size but this has happened before. Usually going into the nvidia control panel and selecting the right dimensions and refresh rate corrects this.

    Lastly, I decided to install cinnamon. I’ve used cinnamon before and liked it. I got a desktop. It was frozen but it was a desktop. My mouse worked but I couldn’t interact. I rebooted and then received a nasty message informing me that cinnamon didn’t start correctly and would I like to reboot? That message is difficult to interact with and takes me about two minutes of clicking to get a response.

    So, what do I do now? Should I post logs?

    I know my card is a GeForce 6150SE card. And I know I’m not doing anything wrong with the install. Could it be the theme?

  • And I can also say that when I install the first time I do get a login screen if I don’t choose auto login but this disappears as soon as I install the drivers. So, as I’ve mentioned, it appears that it is the default theme interfering with the login and de for nvidia users. Now I’m rebooting to try and grab the logs.

    [0_1451943274265_Journal.tar.gz](Uploading 100%)

    Please let me know if I did this correctly of if I need to choose a different button to upload?

    Thanks,

    Mark

  • hi @linux_mark
    Trying to upload boot files here will fail as you can see from your own post where the attempt to upload occurred.
    Pastebin?
    Also, with Cinnamon DE, should not need to reboot. cinnamon -replace is effective.

    Download " antergos-wallpapers-extra " and enjoy community sponsored wallpapers.

    Use the "Linux Beginner Search Engine"

    https://cse.google.com/cse/home?cx=017607476515012185699:b_owgx6xyi0

  • Modisc, I installed Cinnamon twice and both times the desktop froze. Also, as soon as I installed the nvidia drivers I was no longer able to login properly.

    Are you sure my upload failed? I was told that when you upload an archive file it is only available to administrators.

  • There is one of your problems.

    lightdm.service: Unit entered failed state.
    lightdm.service: Failed with result 'exit-code'

    If you go to your browser, select EDIT > FIND .
    Then look for clue words like “error” . You will come up with other words next to the highlighted portion pointing to “lightdm”

    Addendum:

    When you see this in your boot files: segfault at 0 it means a request was sent out but that the process does not have anything listed in its descriptor table.
    From Stackoverflow . com

    A segmentation fault occurs when a program attempts to access a memory location that it is not allowed to access, or attempts to access a memory location in a way that is not allowed (for example, attempting to write to a read-only location, or to overwrite part of the operating system).```

    Download " antergos-wallpapers-extra " and enjoy community sponsored wallpapers.

    Use the "Linux Beginner Search Engine"

    https://cse.google.com/cse/home?cx=017607476515012185699:b_owgx6xyi0

  • Modisc, the greeter is irrelevent. It doesn’t matter what greeter I install, they fail.

    Also, on one of my many re-installs I removed lightdm and installed another greeter and guess what? It failed too! No surprise there. What I need is a solution. Remember, even with cinnamon, I was able to see a login screen, which is lightdm but the second I attempt to login it fails. After I install the nvidia drivers I don’t see the login screen at all.

  • Hmm. OK, well give me some time to research this a bit then.
    It’s really odd problem . That’s for sure.

    PS. I know you need a solution. Trying to help you with one.

    Download " antergos-wallpapers-extra " and enjoy community sponsored wallpapers.

    Use the "Linux Beginner Search Engine"

    https://cse.google.com/cse/home?cx=017607476515012185699:b_owgx6xyi0

  • @Modisc Thanks Friend. I do appreciate the kind help that you have all offered to me. It is very much appreciated.

  • The only thing I can do at this point is search through my old iso discs of antergos and see if I can find one that allows me to boot to a desktop so that I can install my drivers properly. I’ve been without a desktop for about a week now and I have a lot of work to do. If I can’t find a disc that will work then I am going to have to install another OS that isn’t having this problem. Whatever this is, it’s a problem that wasn’t happening before and needs to be addressed by the Antergos team. I’m sure I cannot be the only one having this problem.

  • hi @linux_mark
    I’ve had a look at your boot files again. I don’t understand it. Everything is going good. Services are being started. Your config files and Managers are all getting started and enabled. File systems (including your swap), and directories are all getting mounted. Sound card is being sought out and found, too. Everything is being established and then right at line 1064 , 1273 and some other related ones to that are showing error.

    I can’t really say where and what is wrong with your nVidia drivers as I am most certain it is the fault of that graphics.

    EDIT: As for installing another OS, you know, all I can say is that you got to do what you got to do. If I was doing work from home/work on my own laptop, I would need something that proved to me alone it was reliable, and if it meant that I had to switch, then so be it.
    Work is more important than the preference of one’s OS.

    Download " antergos-wallpapers-extra " and enjoy community sponsored wallpapers.

    Use the "Linux Beginner Search Engine"

    https://cse.google.com/cse/home?cx=017607476515012185699:b_owgx6xyi0

  • @linux_mark not even the opensource drivers are working? you think its possible the card is failing itself? have you tried another card?

  • @megaman Well if it was the card then I would probably have the same issue with another os, don’t you think? I can install manjaro with no problem and login to a desktop. I’ve also installed neptune and logged into a desktop.

    As I have said, and I really do think this is the problem. Whatever the default desktop theme is for KDE, Gnome, Cinnamon and XFCE are creating a conflict with my video card. There is even a discussion on this forum about the desktop theme causing problems with login. And, since I can install other linux distros and boot up then it tells me that the theme is probably the root of the problem. Don’t you think?

    And lastly, no, the opensource drivers aren’t working. Remember, this problem starts right out of the box before I even attempt to install nvidia drivers. If I can find the discussion I read about the theme causing login issues I’ll link it to this discussion. Nothing else makes sense to me beyond this.

  • Check out this thread. I believe this problem is the same problem I am experiencing.

    https://forum.antergos.com/topic/3294/desktop-wallpaper-goes-gray-but-it-configured-for-an-image/7

  • And here’s a link describing the same problem I had with cinnamon when I installed it the other day. So, how do I downgrade this numix theme? I don’t have access to pacmanxg or I’d do it from there.

    https://bbs.archlinux.org/viewtopic.php?id=206197

nvidia94 gnome37 Posts 40Views 6547
Log in to reply