• Add additional DE's


    I just reinstalled antergos and am running the 64 bit. It seems a bit buggy to me so I’d like to add xfce to my system. Can anyone tell me how to add an additional DE to my system? I searched through the repository but am not sure what to install as I can’t see a specific file.

  • Suppose you have GNOME 3.
    For xfce you have to install metapackage like sudo pacman -S xfce4.
    Because you already have GNOME and LightDM properly configured, after restart you will see an option on login screen to choose between Gnome and XFCE.
    More info about XFCE here.

    a warm place with no memory

  • $ sudo pacman -S xfce4-goodies

    Autodidacta en la VIDA …y en Linux, también.

  • Ok you folks have seriously spoiled me. One final question because it’s tied to using xfce. How do I disable auto login?

    I only ask because if I log out, there is no option to select another de at the login screen. I have the standard clock that comes up that you click on and in the bottom left hand corner there is a drop down allowing me to select plasma. This is my login screen on antergos 64 bit kde. Thoughts or suggestions?

    I’m reading this page on xfce. Should I change display managers? I think the problem is that the current display manager for kde doesn’t provide any options to select a different de.

  • You have to edit as superuser /etc/lightdm/lightdm.conf file with kate or mousepad.
    Look around from line 86, at the following code lines:

    [Seat:*]
    #type=xlocal
    #pam-service=lightdm
    #pam-autologin-service=lightdm-autologin
    #pam-greeter-service=lightdm-greeter
    #xserver-command=X
    #xmir-command=Xmir
    #xserver-layout=
    #xserver-config=
    #xserver-allow-tcp=false
    #xserver-share=true
    #xserver-hostname=
    #xserver-display-number=
    #xdmcp-manager=
    #xdmcp-port=177
    #xdmcp-key=
    #unity-compositor-command=unity-system-compositor
    #unity-compositor-timeout=60
    greeter-session=lightdm-webkit2-greeter
    #greeter-hide-users=false
    #greeter-allow-guest=true
    #greeter-show-manual-login=false
    #greeter-show-remote-login=true
    user-session=gnome
    #allow-user-switching=true
    #allow-guest=true
    #guest-session=
    session-wrapper=/etc/lightdm/Xsession
    #greeter-wrapper=
    #guest-wrapper=
    #display-setup-script=
    #display-stopped-script=
    #greeter-setup-script=
    #session-setup-script=
    #session-cleanup-script=
    #autologin-guest=false
    autologin-user=**your_username**
    autologin-user-timeout=0
    #autologin-in-background=false
    #autologin-session=
    #exit-on-failure=false
    

    Put a # at the start of your_username line (comment line).
    Of course, save and reboot.

    a warm place with no memory

  • This post is deleted!
  • Roberto, actually I think I need to first install a new greeter before doing anything else. Your suggestion had me stuck and not able to boot up. Luckily I had written down how to launch lightdm or else I would have been waiting and searching to find out how to boot up.

  • I’m sorry for your problems, but your messages are mixed.
    You are not able to boot up? That’s a different issue and has nothing to do with lightdm.

    Regarding enable/disabling autologin, it can be done by commenting or de-commenting that lightdm.conf line as long you haven’t install another greeter, change boot services or anything else i can’t think of it.

    Suppose you didn’t copy/paste all lines, including my DE-specific ‘user-session=gnome’ line!

    Install a fresh Antergos, choose a username and autologin, then comment that single line. It works.

    a warm place with no memory

  • I have the 64bit Mate installed and cannot seem to enable autologin and it was not an option shown (as usual during install just after password). Have verified my lightdm config is as shown above with# but this has had no effect. Any further assistance would be appreciated.

  • @allan, find below a screenshot of Antergos install procedure that came with June iso. Believe me, was there then as is there now. Nothing has changed on that particular step of install procedure.

    0_1451566842790_autologin.png

    Check ‘log in automatically’ and you bypass lightdm-greeter (and also enter default on Mate or whatever desktop you choose).
    Leave it default and you have to enter an username and password at login screen.

    Try this in console as superuser:

    # groupadd -r autologin
    # gpasswd -a your_username autologin
    

    a warm place with no memory

  • Thanks for the prompt reply so i have rechecked the 64 bit ISO download (Dec version) and MD5CHKSUM. Using cnchi 0.12.46 the how would you like to proceed screen is blank apart from dropdown pointer on it which does not show anything. The picture you show above for user details is what i would expect to see but this iso/cnchi only shows the blank entry boxes, no names of what each is for (having done so many i remembered) and not the three bottom check boxes one of which is the auto login. Sadly getting to this point was a step to far for my main desktop and deleted the existing installation so did not get the chance to try the terminal option you gave. I am now using the 32 bit version (June 15) on my old desktop.
    Could it be a fault in the new ISO/cnchi ?

  • @allan
    Two hours ago you have Mate installed. You made another install?
    And if you already made a Mate install, how is possible to not see first time those 3 boxes on username screen?

    What has changed between first installation and present one? Is the same iso? Is the same Cnchi?
    It is very possible to be issue related to last ISO+Cnchi combo.
    Try to use the same iso as were you’re able to get in Mate.

    It’s very hard for me to figure it.

    ps: regarding blank screen, most probably is a Cnchi issue.
    Unfortunately, i’m not able to provide a link with a different (older) iso.
    So you have to use a torrent .

    a warm place with no memory

  • Thanks for that i will try and explain better. I have 2 desktop computers 1 - 64bit and 1 -32 bit and a 32 bit laptop. Both 32 bit ISO (Mate) on 32 bit desktop and laptop installed fine a couple of weeks ago without issue. The problem occurred with the new ISO 64 bit downloaded yesterday. After your first response i rechecked the MD5sum to ensure no error in download and all was fine so i tried to reinstall after rewriting ISO to a new USB however it again had the same problem during installation - missing details/input boxes.
    I probably could have used the older 32 BIT ISO as its proven to work but that wont help people who are possibly now downloading a 64 bit ISO + Cnchi combo that does not/may not work as expected and are searching this site for answers or people with a common problem. I have since moved on and installed another distro so i am not looking for answers only trying to assist others who may give up and move on from what is normally a very good and one of the fastest distro’s i have ever tried. Thank you for your time.

  • @roberto Roberto, it still won’t work for me because I asked the wrong question. I need to be able to switch between my current desktop: kde, and xfce. The plasma greeter, which I have switched out to sddm, also doesn’t give me a choice. I assume I must make this choice somewhere in my system. This is the question I need answered and I don’t think your solution provides. I thank you for your help but I think I need to continue digging through the archives.

  • @allan said:

    I have the 64bit Mate installed and cannot seem to enable autologin and it was not an option shown (as usual during install just after password). Have verified my lightdm config is as shown above with# but this has had no effect. Any further assistance would be appreciated.

    i also couldnt find the autologin button installing kde. not just you.

  • I’m glad I’m not the only one having issues. Since I started this thread kde has crashed on me thanks to an nvidia update. I couldn’t fix that so I installed another de and, well that’s being discussed on another thread. LOL. For me, I had no problem with the auto login. I just wanted to turn it off. Anyway, I’ll leave this thread open in case anyone else wants to join this discussion.

  • Well, a start for new weird bugs.
    Made dozen installs with various Cnchi and iso versions (not December iso’s thou) and always, i mean always, that screen were there and looks the same.

    This kind of issues should make developers to change release strategy.
    It’s not ok to have available on main site and mirrors around the world just one iso (buggy) release, without proper testing and user feedback after installation.

    A solution, due to Cnchi rapid changes, is to have available last 2-3 iso’s, with a known issues list and Cnchi changelog. Also, a mechanism to start install procedure without Cnchi auto-update (and use a proven, tested Cnchi iso’s version) and avoid last-minute bugs.

    I’m sorry for problems caused by my posts. It’s a lesson for me, too.

    a warm place with no memory

  • I agree with you on the ISO’s availability however the update check on Cnchi on installation could also made optional.
    My current mission is to try and convert all my friends to Linux from Windozzzz and the overriding requirements are ease of use, compatibility and reliability as its not fair to take risks with other peoples systems. Each year i try and pick a new distro and this was going to be it until now. However the developers here are not alone as the one i used last year (i wont say which as i do not consider it appropriate to promote alternatives) has recently released a new final version and it too has problems (and they have considerably more resources). Back to distro hopping. All the best. Allan

  • @roberto I understand how frustrating issues with installation can be. Though I ask that you keep in mind that we have not been able to reproduce the issue with the summary screen in our testing. Because the issue seems to only occur under certain conditions, the only way we will be able to resolve it is by reviewing Cnchi’s log (in its entirety). I’m afraid the reports and log snippets that have been provided to us thus far didn’t include any clues as to what is causing the issue.

    If anyone is able to reproduce the summary screen issue, please post your findings along with a paste2 link for the installer log output over on the Github Issue. Thanks.

  • @lots.0.logs ya i should have grabbed the log but it didnt really affect anything else really. the install went fine. just seem to be some graphical stuff going on. the iso just before that didnt have that problem doing the same kde install.

lxde5 kde102 Posts 20Views 2853
Log in to reply