• GRUB2 not seeing Windows 10 (New Antergos Install)


    Hi guys, I just got done installing Antergos on my laptop but the grub that it installed does not detect my Windows 10 install. My setup is as follows:

    MSI px60 2qd-034us
    SDA = Samsung Evo SSD - Antergos & Grub Install (Fresh)
    SDB = Samsung Evo SSD - Windows 10

    I tried some help tips I found online but to no avail as the tips I was able to find wasnt necessarily for the same setup as mine (Dual booting across multiple hard drives). I’d appreciate any help with this as I need to be able to access windows sooner than later. Please let me know if you require any further information to troubleshoot my scenario. I’ll keep searching on this forum for some ideas but I’d greatly appreciate direct help for my situation.

  • update-grub

  • @Green

    Tried update-grub and i get:
    bash: update-grub: command not found

    This was the first thing I tried as it is what I had to do with previous linux installs.

  • their is a good gui called grub-customizer on the AUR use it carefully but easier than terminal

    Long Live Antergos
    [Major Linux Problems on the Desktop or Why Linux is not (yet) Ready for the Desktop, 2016 edition] (http://linuxfonts.narod.ru/why.linux.is.not.ready.for.the.desktop.current.html)

  • I’m liking the grub-customizer, seems like it’ll be nice to dress grub up once I’ve gotten things squared away but I dont see how to have grub identify windows 10 on my 2nd hard drive using the cusomizer. I see that you can add custom entries but I dont know what to put into those to have it identify windows 10 correctly. Any help would be appreciated.

    Some other hints, it appears as though when i installed antergos it messed up the windows boot files. Previously while testing various flavors of linux i would just do update-grub and it would identify windows. Thinking I could just have another linux build the grub.cfg file for me I reinstalled linux mint and did update-grub on it but now even its not finding windows 10. Are there any steps on how to recover the windows boot files? I tried using my windows 8.1 live usb but it cant repair the boot for some reason. (I upgraded from 8.1 to 10) I dl’ed the windows 10 iso and I’ll try burning it to a usb and having it recover but I’m guessing it’ll be no different than the windows 8.1 usb.

  • Got it resolved. Unfortunately I didnt see a good way to keep my windows install since no method I tried would detect/repair the boot files that got messed up after installing antergos so I reinstalled windows and then was able to use grub-customizer to add a new entry to forcefully include windows in the boot menu options.

    One thing that I would like to know is how can I add an icon to the grub menu for windows? Antergos has its logo in the menu, and using grub-customizer it looks like there’s an icon i can use for windows but I dont see where in the properties for Antergos does it specify what file to use as an icon. Any help would be appreciated.

  • update-grub is a debian/Ubuntu command.
    If you read the Arch Wiki, it will tell you that the correct command for updating grub is
    sudo grub-mkconfig -o /boot/grub/grub.cfg.
    Best to bookmark that Wiki. It is an indelible rescource.

    Download " antergos-wallpapers-extra " and enjoy community sponsored wallpapers.

    Use the "Linux Beginner Search Engine"

    https://cse.google.com/cse/home?cx=017607476515012185699:b_owgx6xyi0

  • Thanks. Yea I’m going through the arch site and very much still learning my way through it. I tried the command you stated after attempting the grub update through the Ubuntu command and it didn’t result in the addition of windows at the time either. I feel that the antergos install corrupted the windows boot files\partition. My windows install media couldn’t even recover windows. The reinstall led to a detectable windows though. Luckily it was a relatively new install to begin with so no real loss other than a day of getting a couple programs reinstalled.

    Now that I have grub entries for both how do I get an icon next to the windows entry as antergos has for its entry? Not a huge issue but the OCD in me is driving me to fix that.

  • Antergos also has it’ own wiki. A small one.
    Your answer is in it here: How to add icons
    For wind0ze? That I don’t know.

    Download " antergos-wallpapers-extra " and enjoy community sponsored wallpapers.

    Use the "Linux Beginner Search Engine"

    https://cse.google.com/cse/home?cx=017607476515012185699:b_owgx6xyi0

Posts 9Views 3745
Log in to reply