• How to enable Wayland


    I see the option to use Gnome on Wayland when I log in but it does not work. Is Wayland installed by default, and if so, how do I enable it? Any help would be appreciated.

  • When you say “it does not work” what do you mean? Do you choose it before login? If so, it stays there as default till the next time you decide to tick a different option.

    • I have been using it for over a month now. However, bear in mind that not everything works, yet. Namely, some gnome extentions and pamac.
      According to Gnome s roadmap, Wayland is becoming default, in 3.20, should you decide to wait till March…

    1.Antergos Linux KDE plasma / Gnome 2.Ubuntu 17.10 64bit Unity
    Intel Core2 Duo CPU P8400 2.26GHz‖ RAM 3908 MiB ‖ Dell Inc. 0F328M - Dell Inc. Latitude E6500
    Intel Mobile 4 Series Chipset Integrated Graphics [8086:2a42] {i915

  • I choose Wayland and log in. Then the login screen comes back up.

  • Of course I am pretty patient. March isn’t that far away.

  • @ubunturefugee , maybe this is your problem?
    “The driver situation for Wayland is as follows:
    Open-source drivers work fine (Intel, AMD, Nouveau)
    Gallium drivers work ok
    Android drivers can be made to work with an NDIS-like wrapper (libhybris)
    Nvidia binary drivers do not work currently”.
    https://wiki.gnome.org/Initiatives/Wayland

    1.Antergos Linux KDE plasma / Gnome 2.Ubuntu 17.10 64bit Unity
    Intel Core2 Duo CPU P8400 2.26GHz‖ RAM 3908 MiB ‖ Dell Inc. 0F328M - Dell Inc. Latitude E6500
    Intel Mobile 4 Series Chipset Integrated Graphics [8086:2a42] {i915

  • @anarch Yes, I had read that article this morning while looking for a solution. I’m using an open source driver so figured it was ok. Also found info on setting Wayland up on a “ground up” install. I may look into that a bit more to see if something is not as it should be.

  • This post is deleted!
  • Well, Wayland was working for me until now, after an update i can’t get in in Gnome with Wayland, and the worst is that no ever show me login with Gnome with Wayland, i have to change this for get session.

wayland35 gnome215 Posts 8Views 2183
Log in to reply