• How to startup terminal commands in systemd


    THE SOLUTION CAN BE FOUND IN THE COMMENTS BELOW
    Hi community,

    I would like to run these two commands everytime i boot my antergos linux.

    xinput set-prop ‘ELAN Touchscreen’ “Device Enabled” 0
    xinput set-prop ‘SynPS/2 Synaptics TouchPad’ “Device Enabled” 0

    Please help me.

  • https://wiki.archlinux.org/index.php/Autostarting

    Cheers! I don't know what I'm talking about!

  • @Fedorai-Zomakaja said:

    https://wiki.archlinux.org/index.php/Autostarting

    Since antergos uses systemd, at least for me, i can’t find anything simple to help me :(

    Please help , pleaseee!

  • just a little bump

  • How early in the start process do you need that ?

    if its after login you can use you DE function to start something just after its started, create a bash file and say to you DE to lunch it. KDE had an option to start some script at the sytem strat up but I don’t know if its still there or if other DE do this.

    Long Live Antergos
    [Major Linux Problems on the Desktop or Why Linux is not (yet) Ready for the Desktop, 2016 edition] (http://linuxfonts.narod.ru/why.linux.is.not.ready.for.the.desktop.current.html)

  • @nekosan said:

    How early in the start process do you need that ?

    if its after login you can use you DE function to start something just after its started, create a bash file and say to you DE to lunch it. KDE had an option to start some script at the sytem strat up but I don’t know if its still there or if other DE do this.

    Well, the earlier the better since touchscreen in my lenovo 14" yoga causes the cursor jumping and clicking in things it shouldn’t (it happens on every linux distro).

    But anyway, i don’t mind the touchscreen that much…

    The thing is that i don’t know where is the Desktop enviroment function that tells that my bash file should be run on startup.

    I’m using GNOME by default and i intend to keep using it.

  • SOLVED

    Basically, i created an bash file with the name disabletouchscreen.sh and which had inside:
    xinput set-prop ‘ELAN Touchscreen’ “Device Enabled” 0
    xinput set-prop ‘SynPS/2 Synaptics TouchPad’ “Device Enabled” 0

    The first one disable my touchscreen and the second my touchpad which i discovered the name with the command:

    xinput list

    Info: The 0 means it will be disabled by default. The 1 if you want to enable it.

    I used the command: sudo nautilus to get to my file manager in ROOT so that i could copy the disabletouchscreen.sh to the folder /etc/profile.d

    or you could just use terminal text editor nano to create this file. As you want.

startup command1 Posts 7Views 1790
Log in to reply