• Problem with locking user when laptop lid is closed


    Hello Antergos Community,

    I just switched from Ubuntu 12.02 to Arch Linux withGnome desktop (briefly) and then to Antergos with Gnome desktop since I think it is a little bit more user friendly than Arch but still more advanced than Ubuntu.
    The same problem seems to haunt me both in Arch and Antergos when i close the lid and the computer is suspended (fans go off) and the lid is opened again the operating system opens up for few second before it locks the user. If I was quick enough I could start from where I left off without reloging back on to the system which is a huge security loophole (this applied at least for Arch).
    I have googled this and only found users seeking for turning the suspension off on lid close has anyone had this problem and there fore found a solution to it?

    Best regards
    -Sveinn

  • Settings > Privacy>Screen Lock ( May it be that you looking for)

  • @mr.dmrbg
    No, when I close the lid of the computer and open it again moments later the OS reboots from where I left it and then opens up again before it locks the user, so the OS reveals everything I was doing and leaves the computer open to pranksters for example.

  • @sveinntor Are you sure that the system is unlocked for a long enough time for someone to do something before it locks?

    Cheers! I don't know what I'm talking about!

  • @Fedorai-Zomakaja
    Antergos seems to be more tight than my Arch setup was if I would click on the mouse pad, keyboard or both I could keep the session going when opening the lid again that does not happen now but it freezes the computer, had force shut down :/ So no one can do nothing exept crash the session if trying to enter the session.
    So when I open the lid it only reveal my session for a short time which comes down to “user experience”, this is something I would like to fix if possible.

  • I could be way off base here, but I think this has to do with the system suspending your session after the lid opens and the system starts back up.

    I dont think it is a security issue (unless you have sensitive data that you dont want people to see for that sec or two wile it locks), because it will suspend your session, its just getting hung up in the process.
    If it bothers you, you can try suspending the session manually before the lid closes. Thats all I can think of.

    I could be wrong here, I’m just guessing.

    Cheers! I don't know what I'm talking about!

  • @Fedorai-Zomakaja
    You are right, It’s not a security loophole except if I’m working on something top secret which usually not/never doing, but this is and will be a thorn in my eye.
    I will keep this unsolved for few hours in hope of someone that is as picky as I and more resourceful might see this and guide me in fixing it. If that does not happen I will mark this as Solved,

    Thank you :)

  • İ tried what you described, but session was locked everytime… or I was not quick enough to catch …!?

  • 0_1451106254658_DisappearingButtons.pdf
    0_1451106279094_FlashesAfterLogin.pdf
    0_1451106342430_loginscreen.pdf
    https://youtu.be/PfI-j3DQIN0

    Here is a video I took on my phone and few pictures, computer is suspended/closed, when i open the computer the desktop is shown before the locking screen loads.
    As I mentioned before, I had Arch with Gnome before and the log in window is not the same as the one i get when using Antergos, also it seems like there is a bug with the settings/lock/suspend/shut down buttons that appear when I toggle the right corner menu where I can see battery life and internet connectivity.
    After first log in I could only see the settings button and lock computer button, but the suspend button and shut down button were nowhere to be found (see Disappearing Buttons.pdf for a picture) the only way to shutdown/restart was by logging out which brought up the log in screen.
    If I use any of the buttons in the lower right corner of the login screen (restart/suspend/hibernate buttons) the laptop freezes, the only button that works as it should is the shut down button (see loginscreen.pdf for a picture). If I lock the computer and log in again i can see the message “This session is locked you’ll be redirected to the unlock dialog automatically in few seconds” (see flashesafterlogin.pdf for a picture of the message).

    I have reinstalled the system trying cinnamon (did not like the UI very much, the lid bug was also there so I installed Gnome again to see if that would change anything everything mentioned has been the same in both of the installations)

  • @mr.dmrbg
    Might something derived from the hinges on the Lenovo Yoga 2 pro you can move the screen almost 358° so there might no indicator that tells the OS about the position of the lid.

  • @sveinntor your logic seems right…

close lid3 lock user2 lenovo12 yoga 2 pro1 antergos gnome4 Posts 11Views 2822
Log in to reply