• [RESOLVED]Konsole is blank


    I swear, I didn’t do anything. Or at least I don’t recall doing anything. The konsole screen is blank but there is a faint hint of a cursor peeking out from the top of the screen. Is there an easy fix? I have tried changing the number of rows but that didn’t help.

    This problem first started earlier when antergos pulled down a bunch of updates. If no one can help me then I’m stuck until antergos pushes a few more out and hopefully one of them will correct this.

  • Konsole loads and shows me a screen size of 627 x 576. I can see a cursor blinking above but I can’t get to it.

  • what do you mean you ’ cant’ get to it’ ?
    I think your bashrc is messed up.
    Could you just post the file contents of .bashrc file.
    It is in your /home folder.
    What about just doing cp /etc/skel/.bashrc ~/ source .bashrc

    You do this by doing/going into a basic shell.
    Do the following:

    CTRL +ALT + F1
    now put in your command (the one I gave you above),
    then to revert back to GUI
    CTRL +ALT+F7

    Download " antergos-wallpapers-extra " and enjoy community sponsored wallpapers.

    Use the "Linux Beginner Search Engine"

    https://cse.google.com/cse/home?cx=017607476515012185699:b_owgx6xyi0

  • have you try to do a new update in a an other TTY ? (alt+Fx) if updating don’t work you can still use an other terminal like terminator.

    Long Live Antergos
    [Major Linux Problems on the Desktop or Why Linux is not (yet) Ready for the Desktop, 2016 edition] (http://linuxfonts.narod.ru/why.linux.is.not.ready.for.the.desktop.current.html)

  • Ok, just figured out that my system got screwed up. Probably a corrupted download. I went into pacmanxg and tried to do some updates and kept seeing this error.

    error: database ‘core’ is not valid (invalid or corrupted database (PGP signature))

    So, I’m going to research this some more and try to fix it. This is probably the root of my problem.

  • Not really resolved but I’m going to close out this request and create a new one since I have two databases that seem to be corrupted. I think when I get those resolved then konsole will resolve itself. Thank you to everyone who chimed in. :)

  • @linux_mark
    There’s an easy solution for your corrupted PGP sigs. There is even a few threads of that same problem here on these forums
    If you still want to keep this thread open, just ask and solution is as easy as pie.
    For your Konsole problem, have you tried the first solution I supplied?
    You have a hidden file inside that directory I showed you. YOu should be able to resolve your blank konsole problem with that.
    I highly suspect that those two issues are NOT related.

    Download " antergos-wallpapers-extra " and enjoy community sponsored wallpapers.

    Use the "Linux Beginner Search Engine"

    https://cse.google.com/cse/home?cx=017607476515012185699:b_owgx6xyi0

  • Modisc, yes, I tried the solution but it didn’t resolve my problem. When I started to see errors with konsole having trouble updating the extra.db and the community.db I figured out that the most recent update must have corrupted these databases. Anyway, I deleted this thread and may be replying to open air. Cheers.

  • I restored this topic because I figured out this problem is not mine. After spending several days without antergos I reinstalled today and guess what? My Konsole is blank. This is a brand new install. Why now? I have Xterm but this issue must be happening to others, right? It has to be!

  • What do you mean ‘konsole is blank’? image?
    Since you mention ‘konsole’, is this KDE you are using? Which version of plasma? 4.X or 5.x?
    This is 2 seperate issues you are bringing up in this thread.
    Regardless, can you do this for gpg issues after you select e for “edit” and from within Grub and go to a basic terminal.
    You are NOT going into GUI ( i.e. Desktop Environment).

    Start with the script command. Read the man script
    First do script -a
    then do

    sudo  pacman-key --init
    sudo pacman-key --populate-archlinux
    

    then
    sudo pacman -Syyu

    or after re-doing the above first, 2 commands, do
    sudo pacman -Syyuv

    Or…
    back up your currrent mirror list. Get a new mirrorlist online or ask for a copy of mine and I can give you a copy of latest one.
    Also, can you do the following to check to see what you have in comparison?

    which pacman
    which gpgme-tool
    pacman --version
    gpgme-tools --version
    pacman -Qi pacman gpgme
    

    At any time to end the script command, do CTRL+D

    Can you try to remove signature files in pacman.conf
    rm /var/lib/pacman/sync/*.sig
    then do
    sudo pacman -Syyu or sudo pacman -Syyuv

    Can you go and see if there may be anything in this directory and then open either with VI editor or with your favourite text editor /var/lib/pacman/somedatabase.db and see or output it’s contents.
    Is the content binary or textual?

    Use different mirror within your mirrorlist?
    Also, can you go into DE and output the .bashrc file?
    Will also need to go into DE to retrieve the typescript file in your /home directory.

    Download " antergos-wallpapers-extra " and enjoy community sponsored wallpapers.

    Use the "Linux Beginner Search Engine"

    https://cse.google.com/cse/home?cx=017607476515012185699:b_owgx6xyi0

  • Modisc, I’m using the current build dated 12/21/15. The version of Plasma is 5. And yes, I’m on KDE. Konsole is the default terminal emulator for KDE.

    sudo pacman-key --populate-archlinux gives me an error message. pacman-key: invalid option ‘–populate-archlinux’

    And yes, you’re right. No problems with pacman. This is clearly an Antergos problem. I have the correct video drivers installed and configured. And the other two terminal emulators are working great.

  • Modisc, I think I should start a new thread so no one is confused. This is not a pacman or a mirrors issue. It’s an issue with Konsole for KDE. This is a fresh install so there is no way my last install should have influenced Konsole from acting in this manner. I’m reluctant to try any of your suggestions having to do with pacman since this is unrelated. Also, there isn’t an skel or ske1 folder in etc.

  • @linux_mark
    I would certainly agree with you 100 percent that there should be no way for new install to be affected by prior install. If you ever decide to make new install, start completely fresh with new file system drive (overwriting the first one you had).
    If this issue is repeated, then sorry I don’t know what to say other than maybe it’s an iso issue perhaps,?
    You would have to take it up with devs, then.

    EDIT: So I just want to confirm that when you do cd /etc/skel/ and then ls -a you have no files let alone a /skel folder?
    Maybe there is none for KDE?
    I guess what I was trying to say is that there is a file for .bashrc within that directory that you could use. But you say there is no /skel sub-directory. Confusing, to say the least.

    Download " antergos-wallpapers-extra " and enjoy community sponsored wallpapers.

    Use the "Linux Beginner Search Engine"

    https://cse.google.com/cse/home?cx=017607476515012185699:b_owgx6xyi0

  • If by blank you mean the same thing that happened to me, then try the following: in the terminal ẃindow go to settings > edit current profile > appearance and choose for example the Noto font.
    To me it happened after a new install - but only with antergos. Fedora KDE didn’t have that problem. Btw, any chance you are having another problem that is afflicting my setup as well - since the update from the 29th of December, my desktop turns black (own both displays) and I have to restart. Only that after the restart, the same things happens again after a couple of minutes. If you are having the same problem, than this is related to antergos too…in which case I’m done with it.

  • yes same with me. konsole was blank. but i did what u suggested. i changed the font in edit profile. now its ok.

  • I had the same problem with my konsole. I solved it creating a new profile in konsole.

  • i did both created a new profile and edited the font. all working now.

Posts 17Views 2114
Log in to reply