• "makepkg was unable to build"- /tmp memory is full.


    I was trying to install teamviewer using PacMan. After some building process it said “makepkg was unable to build” and something warning about /tmp memory, I couldn’t catch that.

    I am a very new to Arch/Antergos planet. So I searched throught web and didn’t understand nothing 😏 .

    After running this command I found my /tmp memory is full.
    df -h

    Filesystem Size Used Avail Use% Mounted on
    tmpfs | 376M | 376M | 0 | 100% | /tmp

    Q. How can I extend /tmp memory?
    Some forum refers to “build package on another directory”. That’s not easy I think.

    Thanks in advance 😄 .

  • @sadatdaniel /tmp is mapping in RAM memory, rather then on disk partition. This to accomplish more i/o performance. Unfortunately your PC use too few RAM GB. If tmpfs use 376M, your total memory is less than 1GB, that is too little (By default tmpfs allocate 50% of total RAM). Try:

    • install another memory card of the same type than the one installed, OR…

    • add following row on /etc/fstab (edit w/sudo privileges):
      tmpfs /tmp tmpfs nodev,nosuid,size=700M 0 0
      then reboot. Try different values for “size” parameter.

    Regards

makepkg was un1 tmp memory is1 extend tmp mem1 Posts 2Views 1396
Bloom Email Optin Plugin

Looks like your connection to Antergos Community Forum was lost, please wait while we try to reconnect.