• Boot to LiveUSB hangs


    Hello friends. I downloaded Antergos 64 bit this afternoon and DD’d it to a flash drive. I successfully installed it on 3 machines. On a 4th machine (Toshiba ultrabook) I am unable to boot. I get the graphical start screen where I can choose to boot to the live session, boot to hard drive, memtest, etc. I tried all of the boot parameters under the F4 menu and also adjusted my resolution to a few different settings. Everything yielded no results. Once I select boot to Antergos, I get a black (but backlit) screen with no text or anything. I let the laptop sit for an hour only to find it was still hanging there when I came back. I was hoping it would self correct itself but that doesn’t seem to be the case. Is there anything else I can do to fire up Antergos on this unit? Any boot parameters that I can manually type in that would be worth trying? I haven’t had any other boot issues on literally any other distro I’ve tried recently… openSUSE 12.3, openSUSE 13.1, Ubuntu 12.04/13.10, elementary OS Luna, Fedora 19, Mint 15, Mint 16…

    Thanks for any help!

  • Hello friends. I downloaded Antergos 64 bit this afternoon and DD’d it to a flash drive. I successfully installed it on 3 machines. On a 4th machine (Toshiba ultrabook) I am unable to boot. I get the graphical start screen where I can choose to boot to the live session, boot to hard drive, memtest, etc. I tried all of the boot parameters under the F4 menu and also adjusted my resolution to a few different settings. Everything yielded no results. Once I select boot to Antergos, I get a black (but backlit) screen with no text or anything. I let the laptop sit for an hour only to find it was still hanging there when I came back. I was hoping it would self correct itself but that doesn’t seem to be the case. Is there anything else I can do to fire up Antergos on this unit? Any boot parameters that I can manually type in that would be worth trying? I haven’t had any other boot issues on literally any other distro I’ve tried recently… openSUSE 12.3, openSUSE 13.1, Ubuntu 12.04/13.10, elementary OS Luna, Fedora 19, Mint 15, Mint 16…

    Thanks for any help!

  • Hi,

    Did this system come with Windows 8 preinstalled? If so, it is set up to boot using the new “Secure Boot” method which does not always interact well with our Live media. You should be able to switch to regular “BIOS Boot” by adjusting your BIOS settings. More information on that can be found here:

    [https://wiki.archlinux.org/index.php/Unified_Extensible_Firmware_Interface][0]">[https://wiki.archlinux.org/index.php/Un][1] … _Interface

    Please let me know if we need to troubleshoot this further.

    Best Regards,

    [0]: <a href=
    [1]: https://wiki.archlinux.org/index.php/Un

  • I might add to what Dustin suggested in that what I have found on using these live distros is that somtimes one of the installs writes something to the USB flash and causes a problem in booting. It is rare, but it has and does happen!

    If it were me, and Dustin’s suggestion is not the answer, I would reimage the USB stick and see if that may fix it.

    BTW, I have used the dd command to write many images in the past, but had found some time ago that ImageWriter actually does a better job.

    Keep us informed

    In God's love,
    †MaNNa <{{{\>< …to You all thanks and glory Lord Yeshua!

    And Jesus prayed to The Father, "And this is the way to ete…

  • It’s not a UEFI based system. It came with Windows 7 on it. I frequently test distros on this laptop and must have had a good 15 distros on it in the last 3 months. I’ve never had an issue with live-booting one like this before.

    Sorry, but I do have to say, DD is the only thing that has (literally) worked 100% of the time. I’ve used other GUI utilities and sometimes they work but they’re not something I’d bet the farm on. I did however try unetbootin and the Ubuntu startup disk creator, both of which also failed. I DD’d this flash drive again and it boots to the boot screen as I’d suspect but once it hits 100% on loading kernel and passes the system to the next step, black screen, flashing cursor in upper left corner. For what it’s worth, the other systems that I installed Antergos on were installed from this same exact flash drive, same ISO, from the same DD’d instance. I just DD’d it once and installed Antergos on these boxes, except this Toshiba.

    Thanks for the quick response!

  • @“jasauders”:a74pml5r said:

    Sorry, but I do have to say, DD is the only thing that has (literally) worked 100% of the time.[/quote:a74pml5r]

    ImageWriter is just a GUI wrapper around dd command…shhhh don’t tell anyone

    @“jasauders”:a74pml5r said:

    I did however try unetbootin and the Ubuntu startup disk creator, both of which also failed.[/quote:a74pml5r]

    Arch based live images are not compatible with these types of programs. This is because the live system depends on knowing the name of the partition label from which it is booting. These types of programs tend to change the labels in one way or another.

    @“jasauders”:a74pml5r said:

    I DD’d this flash drive again and it boots to the boot screen as I’d suspect but once it hits 100% on loading kernel and passes the system to the next step, black screen, flashing cursor in upper left corner.[/quote:a74pml5r]

    This sounds like a graphics related issue. With an Arch based system you are using the latest versions of everything unlike distros like openSUSE & Ubuntu where updates are held back to stabilize. The downside of holding updates back is that users often don’t see new features until long after they are released. (openSUSE is not as bad as Ubuntu on this). The Arch devs overall do a very good job at keeping the system stable but the occasional hiccup is to be expected.

    Ok, so now back to the topic at hand lol…What graphics stack is the Toshiba laptop using? Try adding the appropriate kernel command at boot from these:
    ATI: radeon.modeset=0
    Intel: i915.modeset=0
    NVIDIA: nouveau.modeset=0
    Intel/NVIDIA Hybrid: i915.modeset=0 nouveau.modeset=0
    Intel/ATI Hybrid: i915.modeset=0 radeon.modeset=0

    Also if there is a “quiet” parameter on the boot line, remove it so any error messages thrown will be shown on screen. Let me know the result!

    Cheers!

  • Hello, I would like to report a similar situation. I am not looking to hijack, so, if “you” believe this is not similar, just let me know and I will start a new topic.

    I have a couple year old
    Toshiba Portege R835-sp3133
    i3-2310M
    mobile intel HM65 chipset
    Intel HD Graphics Dynamic Video Memory Technology 5.0

    It came with windows 7, but, I have been running various linux dist. since new and just removed Opensuse 13.1 to install Antergos

    I heard about this project on LAS (linux action show on jupiterbroadcasting) decided it was right for me.
    I downloaded
    antergos-2013.11.17-i686.iso via torrent and verified file from within transmission
    edit( just wanted to add i did check the md5 as well
    md5sum antergos-2013.11.17-i686.iso
    fcbdf072f3212b3068e98dfe4aee150f antergos-2013.11.17-i686.iso)

    then dd it to a usb drive.

    Similar to the op, Upon boot, I get the Options Start screen, choose the live session and get a black screen with a blinking |

    I also tried many options, including your last suggestion of
    i915.modeset=0
    added to the end of the kernel command boot line

    there was no difference.

    Just in case it was a usb issue, I dd’ed to another usb drive with same results.

    I have to say that one time after waiting for a few minutes I pressed some keys and got an output of invalid kernel parameter or something like that, but, I have not been able to reproduce that screen.

    It might be of interest, I had the same problem trying to install manjaro 8.8 rc3

    Please let me know if you need any other info or suggestions. Thanks

    *edit. I also wanted to add, I tried the suggestions from this thread as well, with no sucess
    [http://forum.antergos.com/viewtopic.php?f=5&t=1229][0]">viewtopic.php?f=5&t=1229

    [0]: <a href=

  • @cltech: This does seem like the same issue so posting here was appropriate. Also thanks for detailing what you have done so for to troubleshoot the issue. It saves everyone time

    I’d like to find the root cause of this issue in order to prevent it from happening (if possible). If you could post the logs it would be much appreciated. Just follow these steps:

    1.
    [list:2lzy3bcb]A) Boot normally, select “boot live system” then begin pressing “Ctrl+Alt+F2” repeatedly. If this gets you to terminal login prompt, go to step 2. If not, go to 1-B. [/list:u:2lzy3bcb]
    [list:2lzy3bcb]B) Restart (Ctrl+Alt+Del). On the White/Gray boot screen, input “systemd.unit=multi-user” and press enter to continue. Attempt “Ctrl+Alt+F2” like before. If this gets you to terminal login prompt, go to step 2. If not, go to 1-C.[/list:u:2lzy3bcb]
    [list:2lzy3bcb]C) Restart (Ctrl+Alt+Del). On the White/Gray boot screen, input “systemd.unit=emergency” and press enter to continue. Attempt “Ctrl+Alt+F2”. If this gets you to terminal login prompt, go to step 2. If not, go to 1-D.[/list:u:2lzy3bcb]
    [list:2lzy3bcb]D) Restart (Ctrl+Alt+Del). On the White/Gray boot screen, check the list of options on the boot command line for the word “quiet” (Use left arrow) If it’s there, delete it and then press enter to continue. Pay close attention and take note of any messages that appear before the blank flashing cursor screen. Post you findings here.[/list:u:2lzy3bcb]

    2. Login as root (It will not ask for password). You need to grab the journal. Depending on which of the previous steps got you this far you may or may not have an internet connection. With that in mind, the easiest method to get the journal is to save it to another USB drive (if you have one) OR on to an existing partition on your system.
    Use the command: “mount” to review a list of devices and find the correct path to your USB or existing partition (/dev/sdXx).
    Now you can save the journal log with: "journalctl -b > /dev/sdXx/journal.log"
    There may be other useful logs. Use these commands, but don’t worry if it says file not found:
    “cp /var/log/Xorg.0.log /dev/sdXx”
    "cp /etc/lxdm/lxdm.log /dev/sdXx"
    Ok, now onto step 3

    3. Although it is unlikely to work, attempt to finish booting into GUI with: “systemctl isolate graphical.target”

    All that is left to do is post the logs that you saved. Sorry for the long post, but I try to ensure there is as little back-and-forth as possible so no time is wasted

    Best Regards,

  • Hello lots.0.logs…thank you very much for the reply. I will work on this now. I seem to be having problems accessing the site, sometimes it loads others it does not…but…i will post back asap.

    Ok, bad news. I am simply unable to get to a terminal log in with a-d

    I am adding your suggested systemd.unit=xxx at the end of the boot options line

    is that correct?

    when i press enter, i start to press ctrl alt f2, I get a loading kernel dialog and then just the flashing cursor. I am not able to get any terminals f2-f8.

    There is no quiet command in the boot options line. I have attached a snapshot of the boot screen.

    I will give it another try while I wait for your response.

    Thank you for your time.

    oh, by the way, I also have a samsung ativ 8 (totally different specs) but the pen drive and live version work fine.

  • Hi again,

    We are experiencing higher than normal traffic to the website which is causing our server to crash. Unfortunately there is only so much we can do about this. However, I’m confident things will stabilize over the next 2-3 hours.

    Do you know what’graphics stack the laptop has? If not, google the model number to find out. From what you are describing, the issue is most certainly related to graphics drivers. Try adding nomodset in addition to the vendor specific string like this:

    ATI: [b:37gkssud]nomodset radeon.modeset=0[/b:37gkssud]
    Intel: [b:37gkssud]nomodset i915.modeset=0[/b:37gkssud]
    NVIDIA: [b:37gkssud]nomodset nouveau.modeset=0[/b:37gkssud]
    NVIDIA Optimus (Hybrid): [b:37gkssud]nomodset i915.modeset=0 nouveau.modeset=0[/b:37gkssud]
    Intel/ATI Hybrid: [b:37gkssud]nomodset i915.modeset=0 radeon.modeset=0[/b:37gkssud]

    Two other parameters that have worked in the past are [b:37gkssud]video=SVIDEO-1:d[/b:37gkssud] and [b:37gkssud]acpi=off[/b:37gkssud] (used seperately)

    The command from my previous post is a shortened version which works from within a booted system. However I am becoming skeptical whether or not it works from the kernel command line. Try the full command which just adds “.target” to the end. So it would look like this: “[b:37gkssud]systemd.unit=multi-user.target[/b:37gkssud]” or “[b:37gkssud]systemd.unit=emergency.target[/b:37gkssud]”

    Basically without knowing more information I am just throwing stuff to see if anything sticks lol Let me know of your progress.

    Cheers!

  • @“lots.0.logs”:2wks6spz said:

    Hi again,

    Do you know what’graphics stack the laptop has?

    Intel: [b:2wks6spz]nomodset i915.modeset=0[/b:2wks6spz]

    Two other parameters that have worked in the past are [b:2wks6spz]video=SVIDEO-1:d[/b:2wks6spz] and [b:2wks6spz]acpi=off[/b:2wks6spz] (used seperately)

    Try the full command which just adds “.target” to the end. So it would look like this: “[b:2wks6spz]systemd.unit=multi-user.target[/b:2wks6spz]” or “[b:2wks6spz]systemd.unit=emergency.target[/b:2wks6spz]”
    ![/quote:2wks6spz]

    Hi!

    Yes, it is the i3 builtin intel mobile hd 3000

    I did try the i915.modset=0 before, but, will try again. I will also try the svideo, acpi off and the other .target and will update

    I am sad to note, nothing I have tried has gotten me into terminal or to a normal loading into the live environment.

    I am not sure what other information you need, but, let me know, I am happy to give it a try. I know the live environment works on other computers (as the op also noted) and i am excited to have it work on this laptop, but maybe it is something deeper.

    I think you are using the same kernel etc as opensuse 13.1, right? that installed and worked fine when I tried it last week.

    Anyway, let me know and thanks for your time.

  • Just a little update.

    I decided to try the arch iso archlinux-2013.11.01-dual.iso

    and having the exact same problem. So, I am going to take a look over there to see if anyone else has found a solution.

    If you have any suggestions, please don’t hesitate to let me know.

  • This really is a strange issue. Especially considering you have Intel graphics which normally work out of the box. I have basically given you every option I know off the top of my head. For none of those to have any affect makes me think your BIOS could have something to do with it. We are not using the same kernel as openSUSE, they are on the 3.11 branch I believe while we have been on 3.12 for a few weeks now. It’s very possible that this is a kernel bug in 3.12. The only way to test that theory is with an iso made using the Arch LTS kernel which is currently on 3.10 branch. I will see what I can do about spinning one up for you to test, but it most likely won’t be until tomorrow at the earliest.

    Best Regards,

  • @“lots.0.logs”:3epsfrg0 said:

    This really is a strange issue. Especially considering you have Intel graphics which normally work out of the box.

    It’s very possible that this is a kernel bug in 3.12. The only way to test that theory is with an iso made using the Arch LTS kernel which is currently on 3.10 branch.

    I will see what I can do about spinning one up for you to test, but it most likely won’t be until tomorrow at the earliest.

    Best Regards,[/quote:3epsfrg0]

    Yes, indeed. Considering I have been using every kernel up to 3.10 and 3.11 I believe, it would seem to be to be something in 3.12, (since that is something in common in all 3 of the current arch based installs I have tried.) I don’t know if I mentioned, but I used to run arch on the laptop a long time ago and I did have manjaro as well…also some time ago.

    If you do make a test version, that would be great, in the meantime I will try to find an older install iso or the lts and see if it loads. As far as BIOS of the laptop, I am on the latest release, so, no help coming there from toshiba.

    Thanks again for all your time and help.

  • Hello, for what it is worth, I went back to archlinux-2013.09.01-dual.iso and it boots to # prompt fine. This version is running kernel 3.10.10-1 which is a kernel i would probably stay on by using the linux-lts package to keep in the 3.10 branch

    I don’t know if you want me to do anything more as I don’t have the time to go through a full install. Please let me know if you are able too add an LTS option to your installer.

    Thanks again.

  • Ok great, it looks like we have pretty much confirmed that this is a 3.12 kernel bug. I am going to go ahead and build an iso right now. It’s hard to say how long, but usually absent of any build failures or other errors it takes about 2-3 hours to get it built and uploaded. I do suggest you report the bug to Arch and let them decide if it needs to be reported further upstream to mainline kernel devs. There was an Arch kernel update pushed out last night… I’d wait until after you have installed and tested the latest version before reporting anything to Arch devs (Trust me on this).

    I’ll update this post when I have a link for you. Cheers!

    Edit: Antergos ISO w/ LTS Kernel: [http://antergos.info/iso/antergos-2013.11.28-x86_64.iso][0]">[http://antergos.info/iso/antergos-2013.11.28-x86_64.iso][1]

    [0]: <a href=
    [1]: http://antergos.info/iso/antergos-2013.11.28-x86_64.iso

  • Awesome, thank you very much. I will give the lts version a try today. Re arch, yes, I know what you mean. I will check out the latest version. I may also just wait for them to post the dec. iso

    Thanks again for helping to solve this. I will update after I get a chance to try the new iso!

  • Well, bad news. not sure what to do at this point.

    The new iso hung at the same point, basically stops just before a normal boot of line of

    running early hook udev

    The lts usb stick runs fine in my vm and other laptop, so, unless you have other ideas, I guess i will drop this toshiba back to something else.

  • I don’t say this very often, but… I am all out of ideas on this

    Edit: Did you try to boot by adding “systemd.unit=emergency.target” to the boot options using the iso I created? I just did a test both on a VM and my physical hardware and the iso works perfectly. You know how in every person’s home there is usually that one “junk drawer” that we pretend isnt there, right?? Well, that pretty much describes the state of my 1TB …yes I said TB, ~/Downloads directory LMAO

    Edit #2: Okay I got it uploaded for you here: [http://antergos.info/iso/antergos-2013.08.20-1-x86_64.iso][0]">[http://antergos.info/iso/antergos-2013][1]. … x86_64.iso Once you boot, you will need to exit and manually update the installer. I packaged the one I revised to install LTS kernel here: [http://antergos.info/repo/cnchi-0.4.2.beta-1-any.pkg.tar.xz][0]">[http://antergos.info/repo/cnchi-0.4.2.b][2] … pkg.tar.xz Just use this pacman command “sudo pacman -U /home/antergos/Downloads/cnchi-0.4.2.beta-1-any.pkg.tar.xz” Now you are ready to restart Cnchi and complete your install! *I hope*

    Best Regards,

    [0]: <a href=
    [1]: http://antergos.info/iso/antergos-2013
    [2]: http://antergos.info/repo/cnchi-0.4.2.b

  • Now you are ready to restart Cnchi and complete your install! *I hope*

    Great…thanks for sticking with it. I will dl now and give it a try!

Posts 28Views 9470
Log in to reply