• Lightdm won't start up and I can't switch to tty either


    Hi Guys,

    I’m not sure how this happened but after a restart lightdm won’t start up. I just get a black screen with a cursor on it. I can move the cursor. When I press Alt + F1, F2, … The screen flickers for a second but eventually goes back to the black screen with the cursor.

    What can I do in such a situation?

    The only weird thing that happened before this was that before the restart I got a notification that 200+ updates were available which is weird as I had just upgraded an hour before that. I tried to upgrade (pacman -Syyu), but there was an error and nothing was upgraded. I suspect that the error was due to insufficient space on my root partition. I had about 1 GB left and the download size for the updates was also about 1 GB. After that failed I restarted to boot Windows and I haven’t been able to boot back into antergos since.

    Any help would be highly appreciated.

  • I am the person who posted this. Why is it posted by Alphanumerix? I posted this !!

  • @tip3r A forum bug is actually ocuring. Been a victim of it myself.

  • restart and edit grub kernel line to runlevel 3, then system boots to console without starting x.

    on grub bootscreen type “e”
    put a “3” right after “quiet” and press F10 to boot.

  • I ended up reinstalling antergos. All my data was in the home partition so I didn’t really lose much. However, if I was to do as you suggest, how would I do it without access to a terminal? I tried booting with a live CD and using the terminal but I wasn’t able to mount any partitions.

  • Without starting x you get directly on textmode (Terminal input)

  • Oh. Got it. Thanks :)
    EDIT: can’t mark as solved since apparently I was logged into someone else’s account when I posted this.

  • @tip3r said:


    EDIT: can’t mark as solved…

    Did it for you.

  • Hey I wish to reopen this topic because I always suffered the same problem in Antergos’ default lightdm-gnome desktop after suspending: the screen stays black and flickers in tty7 and another lightdm login screen appears on tty8. Why two? I can switch to terminal tty1-6 but I just want my session back after suspension and the wonly way I know is restarting gnome-shell with alt+f2 “r” even in the black screen.

    I always had the same problem with Antergos even in another computer with gdm in place of lightdm (both ThinkPads). But this time I wish I could fix this without changing the defaults of Antergos installation because I have seen other people having the same issue and rebooting or avoiding suspension wich is for me not acceptable.

    Anyone with same issue?

Posts 9Views 3982
Bloom Email Optin Plugin

Looks like your connection to Antergos Community Forum was lost, please wait while we try to reconnect.