• Add AZERTY keymaps please


    Hi,
    Installed latest Antergos today; chose French as keymap (and language). Upon rebooting keyboard layout is QWERTY; rather disturbing. E.g tons of shell, vi keybidings are unusable. Also there’s not even a /usr/share/kbd/keymaps/i386/azerty! I’m pretty sure this is a first in my many years with GNU/Linux distros. I’l lcheck but TinyCore has it AFAIR.

  • Hello,

    French here too I installed Antergos 2 days ago with no problem with the key map. Wich keymap did you choose for AZERTY ? I personaly choose the “french (alternative)” one or maybe you just click on “french”. And there I’m not sure it realy install a non-QWERTY keymap. if you don’t choose a particular one.

    Also whar DE are you using ? you can add keymap in you system preferences. I’ll explain that for you later if you need.

    Long Live Antergos
    [Major Linux Problems on the Desktop or Why Linux is not (yet) Ready for the Desktop, 2016 edition] (http://linuxfonts.narod.ru/why.linux.is.not.ready.for.the.desktop.current.html)

  • Hi

    which DE do you use ? Is the issue on the login screen ? or even after logging in ?

    My laptop works fine with a french keyboard. Some tuning has been needed though.

  • Salut

    • Keymap chosen in Cnchi: I think it was « FR » or rather « fr-pc ». Test was good, i.e. had AZERTY fully working in live session and special characters showed up fine while in live session, console & GUI incl.
    • DE installed: GNOME

    Upon rebooting in the installed system, GUI is localized but keyboard is QWERTY in console and GUI. Actually there’s no “azerty” in /usr/share/kbd/keymaps/i386/

    Do you please know which package would bring azerty keymaps ?

  • @kozaki said:


    Do you please know which package would bring azerty keymaps ?

    No additional package is needed. Even on systems which never used French there’s a plenty of different French keyboard layouts available by default, without installing anything:

    0_1449842422848_antergos-french-keyboard.png

    I don’t speak French and never used it, but it’s hard to believe that there’s no layout you’re looking for among these 28.

  • @kozaki said:


    Upon rebooting in the installed system, GUI is localized but keyboard is QWERTY in console and GUI. Actually there’s no “azerty” in /usr/share/kbd/keymaps/i386/

    I would call this layout AZERTY:

    0_1449861981740_keyboard-french-alternative-azerty.png

    It’s French (alternative) keyboard layout, included in any Arch (Antergos) by default.

    If you like this layout, add / select it using Input Sources, and you should be OK.

    Again, I don’t speak French and never used a French keyboard, so this layout might be not what you’re looking for.

  • @just Its the one I use, its the classic AZERTY maping.

    Long Live Antergos
    [Major Linux Problems on the Desktop or Why Linux is not (yet) Ready for the Desktop, 2016 edition] (http://linuxfonts.narod.ru/why.linux.is.not.ready.for.the.desktop.current.html)

  • Sorry for the delay; stock kernel hangs at boot on this machine and I did not find the time to chroot and install some pre-4x kernel to be able entering Antergos (GUI).

    Guys you’re right
    azerty/ stands neat and clear in /usr/share/kbd/keymaps/i386, must have had some big **it covering my eyes earlier when I run loadkeys to no result. That’s what surprised me as it’s part of the kbd base package with the other keyboard layouts (checked it up on Arch).

    @nekosan @just the trick is that I did select « French » upon installing (to call it AZERTY keyboard layout would be more accurate actually).

    but it’s hard to believe that there’s no layout you’re looking for among these 28.

    The first one I did select. Otherwise Cnchi would have been in plain English but it was in French, keyboard test included.
    Then upon restart I tried GNOME Keyboard settings to no avail. I’m not a GNOME user though. « Input Sources » didn’t showed up (but hey! since I missed the keymap… ;))

    OK I’ll come back after I’ll get into this boot hanging issue! Thanks for helping me finding this out.

  • @kozaki said:


    Then upon restart I tried GNOME Keyboard settings to no avail. I’m not a GNOME user though. « Input Sources » didn’t showed up…

    System Settings --> Keyboard --> Input Sources :

    0_1449904536277_antergos-gnome-input-sources-0.png

keyboard-layout3 missing files2 localization1 Posts 9Views 1466
Log in to reply