• Disable lightdm


    Hi,
    I don’t find a way to disable lightdm. Actually I installed Antergos with XFCE and I’d like to remove the login screen at boot to automatically reach the desktop.
    Thanks in advance for your support.

  • I haven’t used XFCE, but isn’t there an option to login automatically in the system settings?

  • @Noctem That’s what I’m looking for :) I didn’t find any option in the system settings.

  • You want to login autmatic with lightDM or without any LoginManager?

    You can start XFCE directly by command without a loginmanager like LightDM:
    **startxfce4
    **
    From Archwiki:
    https://wiki.archlinux.org/index.php/Xfce#Starting_Xfce
    https://wiki.archlinux.org/index.php/Systemd/User#Automatic_login_into_Xorg_without_display_manager

    [updates once a week] = [90% less problems]
    [Li{u}n//u//{i}x] since 1988 - overcoming failure means success
    howto-install-antergos
    how to add system logs
    i3 GNOME

  • @joekamprad said:

    You want to login autmatic with lightDM or without any LoginManager?

    Without any login manager. I chose this option on one my computer during the Antergos installation but not on my other computer.

  • Then read my second link to archwiki…

    [updates once a week] = [90% less problems]
    [Li{u}n//u//{i}x] since 1988 - overcoming failure means success
    howto-install-antergos
    how to add system logs
    i3 GNOME

  • @joekamprad said:

    Then read my second link to archwiki…

    Sorry but could you explain for a newbie?.. I’m on Linux for one year and I was on Mint before coming on Arch/Antergos so I don’t understand what I have to do except using the following command:
    systemctl enable [email protected]

  • i was wondering about automatic loggin too, the otion in the settings doesn’t stick on gnome so even if i select to auto login it just ignores me and sets back to require password, any work around for this?

  • The Arch Wiki says that you need to do this doing root.
    If you fail to do this via root, then it will revert your changes.
    Hence it ignores you.

    From the link that @joekamprad provided:
    Finally, enable (as root) the xlogin service for automatic login at boot:

    So what you do instead is make this:
    systemctl enable [email protected]
    like so
    sudo systemctl enable [email protected]

    sudo is what you use to enable anything as root

    systemd, when-ever you want to enable or disable something, needs to be done via root.
    The Arch Wiki has a super informative page on it.
    check it out.
    I would recommend that it be one of your readings to familiarize your self with.
    That and journald.

    systemd
    and
    journal and how to use journalctl
    hope it helps.

    Download " antergos-wallpapers-extra " and enjoy community sponsored wallpapers.

    Use the "Linux Beginner Search Engine"

    https://cse.google.com/cse/home?cx=017607476515012185699:b_owgx6xyi0

  • @Alphanumerix you try this from gnome settings? this works only on gdm not for lightdm.

    [updates once a week] = [90% less problems]
    [Li{u}n//u//{i}x] since 1988 - overcoming failure means success
    howto-install-antergos
    how to add system logs
    i3 GNOME

  • @Primokorn as @Modisc say: read the manual and learn how it works.
    Other way is to enable autologin for lightdm-greeter:
    https://wiki.archlinux.org/index.php/LightDM#Enabling_autologin.

    What is the reason for you to disable loginmanager? faster booting? older computer?

    [updates once a week] = [90% less problems]
    [Li{u}n//u//{i}x] since 1988 - overcoming failure means success
    howto-install-antergos
    how to add system logs
    i3 GNOME

  • @joekamprad Because DM is buggy. I have a black after clicking on the clock. I have to reboot several times before being able to reach the desktop.
    I’ll try your suggestions. Thanks again!

    EDIT: I don’t know why I didn’t post as Primokorn…

  • @Alphanumerix yes i do uninstall lightDM and install gdm, caus of my dualscreen setup. GDM works perfect for Gnome for other u can use also slim…

    [updates once a week] = [90% less problems]
    [Li{u}n//u//{i}x] since 1988 - overcoming failure means success
    howto-install-antergos
    how to add system logs
    i3 GNOME

  • @Primokorn @Alphanumerix or try this: https://wiki.archlinux.org/index.php/Nodm
    "terminalautologinmanager"

    sudo pacman - S nodm

    After installing nodm, you should modify the /etc/nodm.conf file.
    NODM_USER=’{user}‘
    NODM_XSESSION=’/home/{user}/.xinitrc’

    (replace {user} with your username)

    For the standard GNOME session, add this to the ~/.xinitrc file:
    exec gnome-session

    sudo systemctl disable lightdm && sudo systemctl enable nodm

    reboot

    have fun

    [updates once a week] = [90% less problems]
    [Li{u}n//u//{i}x] since 1988 - overcoming failure means success
    howto-install-antergos
    how to add system logs
    i3 GNOME

Posts 14Views 2142
Log in to reply