• [partitioning] /boot on /, possible?


    Hi to all
    /me is an Arch user wanting to give Antergos a try. The DE and graphical integration has my interest.

    OK I’m installing Antergos-minimal-2015.11.14-x86_64 on an netbook, with a MBR spinning disk, LVM and Arch already installed on it.

    1. Auto updates done, I went through CnChi (1) till
    2. Partitioning: it sees the LVM perfectly, then requires (at least I cannot see an option if it exists) a separate /boot partition. But the one I have is already taken.

    Please how do you use “/” for “/boot” so that one chainloads Antergos bootloader (PBR) from main bootloader, instead of mixing different distros kernels in a single /boot --something I won’t do?

    Laptop disk layout’s like this:
    ±------±--------------------------------------------------------+
    | boot | lvm2: swap, lv_arch, lv_arch2, lv_antergos, … |
    ±------±--------------------------------------------------------+

    (1) UI, fonts and French localization are splendid, woow 🙂

  • Hi,

    I think you’ve found an old “bug”. It’s not really a bug, I’ll explain. Some time ago you couldn’t have a lvm to boot, you needed a different /boot partition (I think it was a Grub2 limitiation, but I’m not sure).

    Well, Cnchi needs a /boot partition if you use lvm. We should remove this restriction, but if I’m not wrong, we still haven’t.

    Have you tried to select your existing /boot partition but NOT selecting to format it? (Please, by all means, if you try this backup your data first!)

  • Thanks for your concern and help.

    select the existing /boot partition NOT selecting to format it.

    I did and also unchecked « Use sda to install Antergos bootloader ». As a result Cnchi installed the kernel and initramfs images in sda1 --replacing Arch’s without a prompt!-- alone. Going this way also resulting in having no bootloader configuration (I did hope to get an example). Like Arch, Antergos do not put its names into the kernels names; out of luck here!

    Now I’ll go this way, hopping to get both systems available:

    1. Add Antergos kernel entries to my original syslinux, test if that boots the OS up. If so,
    2. Chroot in Arch, install a custom kernel (default has an compatibility issue with this little box anyway), reboot and test
    3. Resize /boot; as it seems 200 MB will be too small for the kernels and distros testing I’ll do.

    EDIT:
    Worked without a glitch, yeah 🙂
    Interestingly Antergos stock kernel boots fine, whereas Arch kernels 4+ do not.

    Ah having chosen French as keymap and a language, having an QWERTY keymap layout after installing is rather disturbing. E.g tons of shell, vi keybidings are unusable. ANd there’s not even a /usr/share/kbd/keymaps/i386/azerty! first time I see that in a century: a distro that wiped out some essential input

boot222 install80 boot loader8 multi boot1 Posts 3Views 913
Log in to reply
Bloom Email Optin Plugin

Looks like your connection to Antergos Community Forum was lost, please wait while we try to reconnect.