• (Solved)Samba


    I recently installed the latest version of Antergos (Cinnamon desktop) in Virtualbox and am having issues seeing other computers on my network. I used the bridged adapter in Virtualbox, dowloaded Samba, went to the smb.conf.default file and changed MYGROUP to WORKGROUP to match my group. That is the only modification I made to the file. I restarted Samba and still see nothing. I do not see a firewall application. I’m guessing that may be the issue. Any suggestions?

  • I recently installed the latest version of Antergos (Cinnamon desktop) in Virtualbox and am having issues seeing other computers on my network. I used the bridged adapter in Virtualbox, dowloaded Samba, went to the smb.conf.default file and changed MYGROUP to WORKGROUP to match my group. That is the only modification I made to the file. I restarted Samba and still see nothing. I do not see a firewall application. I’m guessing that may be the issue. Any suggestions?

  • Hi,

    Did you create a share? Have you started both services, nmbd and smbd?

    Lot’s of info here: [url:3smlnco4]https://wiki.archlinux.org/index.php/samba[/url:3smlnco4]

    If you didn’t install ufw (it’s a feature option in the Cnchi Installer) there’s no firewall in Antergos.

  • If you installed using the latest release of our installer, ufw is selected as default firewall setup (unless you deselect it). There is a graphical tool called gufw to manage the firewall if in fact it has been installed. Also, make sure you enable the proper services to run at startup:

    sudo systemctl enable smbd  
    sudo systemctl enable nmbd
    

    You will need “smbclient”, “cifs-utils”, “gnome-user-share”, and “nautilus-share” packages to get full sharing functions.

    Hopefully that will get it working for you!

  • Thanks for the suggestions guys. I’ll work on this over the weeken and let you know the outcome.

  • you should also install gvfs-smb

    pacman -S gvfs-smb
    
  • Hey guys, I got Samba working! I added gvfs-smb and also the nemo-share. It still wasn’t working then I noticed my rookie mistake - forgot to change MYGROUP to WORKGROUP. After a reboot all is good. Thanks for the tips!! This is a really good OS. I love PacmanXG!

Posts 7Views 2939
Log in to reply