• Error with Video Playback


    Hello, I’ve had Antergos for a few months now and everything has been perfect, until yesterday. After I rebooted my system, I was unable to play video at all (HTML5 video won’t load and when I try to play something with Totem it tells me that the libraries could not be found). When trying to play any video, I get the following error message from Totem:

    libva info: VA-API version 0.38.0
    libva info: va_getDriverName() returns 0
    libva info: Trying to open /usr/lib/dri/nvidia_drv_video.so
    libva info: va_openDriver() returns -1
    libva info: VA-API version 0.38.0
    libva info: va_getDriverName() returns 0
    libva info: Trying to open /usr/lib/dri/nvidia_drv_video.so
    libva info: va_openDriver() returns -1
    libva info: VA-API version 0.38.0
    libva info: va_getDriverName() returns -1
    libva error: va_getDriverName() failed with unknown libva error,driver_name=(null)
    libva info: VA-API version 0.38.0
    libva info: va_getDriverName() returns 0
    libva info: Trying to open /usr/lib/dri/nvidia_drv_video.so
    libva info: va_openDriver() returns -1
    libva info: VA-API version 0.38.0
    libva info: va_getDriverName() returns 0
    libva info: Trying to open /usr/lib/dri/nvidia_drv_video.so
    libva info: va_openDriver() returns -1
    libva info: VA-API version 0.38.0
    libva info: va_getDriverName() returns -1
    libva error: va_getDriverName() failed with unknown libva error,driver_name=(null)

    I’ve tried reinstalling Libva and my Nvidia drivers, but neither worked.

  • The same happened to me today. While reviewing the pacman logs I noticed that the package “gstreamer-vaapi” was upgraded from version 0.6.1-1 to 0.7.0-1. Reverting to the former version fixed the problem for me.

    In order to do so, verify whether the version 0.6.1-1 of the gstreamer-vaapi package is present in your pacman cache (lookup gstreamer-vaapi-0.6.1-1-x86_64.pkg.tar.xz in /var/cache/pacman/pkg/).

    If the package is available from your cache, cd to the cache directory and install the previous version of the package by running:

     pacman -U gstreamer-vaapi-0.6.1-1-x86_64.pkg.tar.xz
    

    If the package is missing from your cache (in other words, you have cleaned your cache), you can download the package from the Arch Linux Archive and move it to the pacman cache.

  • @friedchicken It worked, thank you!

    I had checked my logs and had a suspicion it was this, but, I’m still really new to Arch in general and wasn’t quite sure how to downgrade.

  • @friedchicken Great, fixed Gnome Videos :thumbsup:

    PLEASE REPORT TO MODERATOR. I AM UZI NOT ALPHANUMERIX BUT I AM LOGGED IN AS HIM. SOMEHOW.

Posts 4Views 1831
Log in to reply