• help with catalyst


    loading packages…
    resolving dependencies…
    warning: cannot resolve “xorg-server<1.18.0”, a dependency of "catalyst-utils"
    warning: cannot resolve “catalyst-utils”, a dependency of "catalyst-libgl"
    warning: cannot resolve “xorg-server<1.18.0”, a dependency of “catalyst-utils”
    :: The following packages cannot be upgraded due to unresolvable dependencies:
    catalyst-libgl catalyst-utils

    :: Do you want to skip the above packages for this upgrade? [y/N]
    error: failed to prepare transaction (could not satisfy dependencies)
    :: catalyst-utils: requires xorg-server<1.18.0
    :: catalyst-libgl: requires catalyst-utils
    :: catalyst-utils: requires xorg-server<1.18.0

    yup that about sums it up nicely

    • undefined
    • undefined
  • @Lizzi said:

    loading packages…
    resolving dependencies…
    warning: cannot resolve "xorg-server warning: cannot resolve “catalyst-utils”, a dependency of "catalyst-libgl"
    warning: cannot resolve "xorg-server :: The following packages cannot be upgraded due to unresolvable dependencies:
    catalyst-libgl catalyst-utils

    :: Do you want to skip the above packages for this upgrade? [y/N]
    error: failed to prepare transaction (could not satisfy dependencies)
    :: catalyst-utils: requires xorg-server :: catalyst-libgl: requires catalyst-utils
    :: catalyst-utils: requires xorg-server</1.18.0",>

  • @Lizzi last time I checked, Catalyst didn’t support latest Xorg, so you had to install an older version of it.

    How did you install the catalyst drivers? Are you sure you need them? AMD/ATI does not keep up with the latest Xorg version, so normally it’s a pita to use this driver (if you must use them you’ll have more luck in a non rolling release distro).

    Cheers!

  • So is there a way to downgrade xorg then?

  • Thanks!!!

  • @karasu

    gpg --keyserver pgp.mit.edu --recv-keys ABED422D653C3094
    gpg: key 653C3094: "Vi0L0 " not changed
    gpg: Total number processed: 1
    gpg: unchanged: 1

    yaourt -Syyu
    error: catalyst-hd234k: key “ABED422D653C3094” is unknown
    error: key “ABED422D653C3094” could not be looked up remotely
    :: Synchronizing package databases…
    catalyst-hd234k 7.4 KiB 0.00B/s 00:00 [######################] 100%
    catalyst-hd234k.sig 287.0 B 0.00B/s 00:00 [######################] 100%
    error: catalyst-hd234k: key “ABED422D653C3094” is unknown
    error: key “ABED422D653C3094” could not be looked up remotely
    error: failed to update catalyst-hd234k (invalid or corrupted database (PGP signature))
    core 121.2 KiB 1515K/s 00:00 [######################] 100%
    extra 1797.4 KiB 4.88M/s 00:00 [######################] 100%
    community 3.1 MiB 3.21M/s 00:01 [######################] 100%
    multilib 142.1 KiB 1777K/s 00:00 [######################] 100%
    antergos 619.6 KiB 2.02M/s 00:00 [######################] 100%
    error: database ‘catalyst-hd234k’ is not valid (invalid or corrupted database (PGP signature))

  • @karasu

    ==> Building and installing package
    ==> Install or build missing dependencies for catalyst-total-hd234k:
    error: catalyst-hd234k: key “ABED422D653C3094” is unknown
    warning: key FAB2A2779F6F416E1E3E64B3ABED422D653C3094, "Vi0L0 " found on keyserver, keyring is not writable
    error: catalyst-hd234k: key “ABED422D653C3094” is unknown
    error: key “ABED422D653C3094” could not be looked up remotely
    error: database ‘catalyst-hd234k’ is not valid (invalid or corrupted database (PGP signature))
    error: catalyst-hd234k: key “ABED422D653C3094” is unknown
    warning: key FAB2A2779F6F416E1E3E64B3ABED422D653C3094, "Vi0L0 " found on keyserver, keyring is not writable
    ==> Restart building catalyst-total-hd234k ? [y/N]
    ==> ----------------------------------------------
    ==>

  • also trying to get help on arch but cant register.

    What is the output of “date -u +%V$(uname)|sha256sum|sed ‘s/\W//g’”?

    put that in a terminal and got nothing

  • $ date -u +%V$(uname)|sha256sum|sed 's/\W//g

  • This post is deleted!
  • This post is deleted!
  • This post is deleted!
  • This post is deleted!
  • it wants xorg less than 1.13

  • https://wiki.archlinux.org/index.php/AMD_Catalyst#Xorg_repositories

    I7 [email protected]/32GB Ram/3440 x 1440 + 1440p/EVGA 1080 FTW/512GB SSD/2TB HD/Antergos Base w/ Plasma

  • arning: cannot resolve “xf86-input-evdev1.12”, a dependency of “xorg-server1.12”
    :: The following package cannot be upgraded due to unresolvable dependencies:
    xorg-server1.12

Posts 17Views 4791
Log in to reply