• I screwed up the boot/efi partition...


    let me explain further…

    I just tried to have a dual boot with 2 Antergos partitions, having a different DE for each. I wanted to have clean install for each of them.
    I then plugged in my USB flash drive and started the installation. Cnchi update took place (by the way, with cnchi version 42, I got a message that Cnchi is not up to date despite the update took place). I use the manual partitioning option to install Antergos on an empty partition and mounted my already existing /swap and /boot/efi partitions (without formatting them).
    At this point, I might have forgotten to uncheck the grub installation…

    The installation ran well in term of downloading everything (Openbox DE) and package installation started until it got stuck on lightdm installation.
    So, after a while, I interrupted the installation.

    Now, when I start my laptop, I get a first grub window (not Antergos branded) proposing Arch and Arch fallback launch. Selecting Arch brings an error and, after typing a key as proposed, I get the usual Antergos grub and I am able to launch it as I used to.
    The issue is now I cannot run Antergos installation from a flash drive anymore (I wanted to reset my installation). The laptop boots on USB but I get only a black screen.

    Looking into /boot/efi, I see 2 antergos_efi directories (not exactly the same name). One has the creation date of my 2nd install. I am wondering whether I should remove it to have only one grub and to be able to run Antergos install from USB again. What do you think ? Any other advice ?

    Thanks a lot for your support !

  • @squid-f Hi! First, I think it would have been enough with just creating a new user in the original installation to use another DE. I think so, I am a one-DE-guy, but in theory you could switch users (and default DE) from the DM.
    Regarding the issue, do you get one GRUB (unbranded) and then the second GRUB (antergos) when the sub flash is unplugged right? Could it be that one is installed in the device and the other on the first partition??

  • @guillermohs9 Hi

    Apparently I had 2 grubs. Indeed, one unbranded and one branded. By entering into the BIOS, I saw I had 2 Antergos entries. I switched them in the boot priority list and now I boot again on the good one.
    So, I think my install is not clean anymore but I can use it.

    I wonder whether just removing the “corrupted” /boot/efi directory would clean everything. What do you think?

    Creating another user with a different DE is a good hint. I’ll think about it for the next time. Thanks ;)

  • Mmmm I don’t know, I’ve never seen “nested” GRUBs. What could happen if you leave an entry to an inexisting EFI image? You should read the arch wiki first, but I personally would try to run grub-mkconfig (or equivalent depending on the version) to verify the entries, and then try deleting unused images. Hopefully someone more experienced can check this, but the worst case scenario would be having to reinstall grub with arch-chroot from a live cd.
    The little obsessive-compulsive man in me couldn’t have peace of mind booting a grub into another grub.!

  • Also, if you have Windows installed, have in mind that you may have to manually add the entry to the partition in the grub config file, I did it recently with the wiki instructions and it worked fine. It was windows 10 dualbooting with Antergos, on a GPT+UEFI scheme. Good luck!

  • @guillermohs9 Hi
    I removed the unbranded entry from the boot and I have run already mkconfig.
    So, I don’t have an boot isue anymore. I still have an “extra” EFI folder though.
    Don’t know yet what I will due with it. Might not be a big deal.

    Thanks for your time !

boot320 bootefi7 Posts 6Views 2046
Log in to reply
Bloom Email Optin Plugin

Looks like your connection to Antergos Community Forum was lost, please wait while we try to reconnect.