• Cinnamon still no panel!


    I run Antergos on 2 macbook pros. One I installed in August with a minimal install image on retina. Cinnamon is/was my main DE and it still works well on the retina mac.
    On the other mac ( 8,1) I had harddrive problems a month ago and had to do a reinstall. I used live-image and after that I have no panel in cinnamon. I read that a packaging change in python2 caused panel not to work but now this matter is closed and I have removed cinnamon and reinstalled but still no panel. I wonder what I could/should do now?

  • cinnamon-settings panel

    If that does not bring the panel up for you to configure, then post the output of that command. It may tell you that something is missing or gone haywire.
    And if that still does not work, then do cinnamon-settings and see if that works. If no-go, then you could post the output of that to see if there is something missing or gone haywire there too.
    Do you have all the glib packages?

    Download " antergos-wallpapers-extra " and enjoy community sponsored wallpapers.

    Use the "Linux Beginner Search Engine"

    https://cse.google.com/cse/home?cx=017607476515012185699:b_owgx6xyi0

  • Hi!
    Thanks for interest!
    Here is output:

    [[email protected] ~]$ cinnamon-settings panel
    Python module
    Could not find bluetooth module; is the cinnamon-control-center package installed?
    Loading Panel module
    init took 169.507 ms

    There is no panel there! It is not only invisible, it´s nothing there! I can not create a new panel either and cinnamon-control-center package is installed. Could it be bluetooth module? I don´t use bluetooth much.

  • ...is the cinnamon-control-center package installed?

    Sometimes an easy way to determine if something is missing is to read the output of the command when you type it in terminal.

    The AUR and the Wiki is really a great place to find information.
    Have a look here for a bit.
    cinnamon-control-center

    Download " antergos-wallpapers-extra " and enjoy community sponsored wallpapers.

    Use the "Linux Beginner Search Engine"

    https://cse.google.com/cse/home?cx=017607476515012185699:b_owgx6xyi0

  • @Modisc
    Now I have had som time to read!!
    I have done a couple of reinstalls of Cinnamon. (I couldn´t find any real good answers to my problem) The second reinstall worked. Now I have panel but control-center can only be started from terminal! Now I have another problem instead! In control-center the top buttons just below the windowlist is huge now! It is almost impossible to change any preferences at all! I read a little about css and made a css-file that should taylor the buttons for my needs. It didn´t work. I logged in to Gnome instead and noticed the same problem there. Here I afraid I am totally in the dark and wonder If anynone has encountered anything similar?

    WOmp

  • Hi.
    sorry for late reply. I have had some issues in signing in with this new sign in set-up. Its actually quite a headace for me. Had to sign up with Git hub just to finally sign in here to this forum!! Geesh!!

    Anyway, so when you type into Terminal to start it up, what is the output of
    cinnamon-settings
    Post output here.

    Also, do this too:
    cat /usr/lib/cinnamon-settings/bin/SettingsWidgets.py
    and check maybe this
    #import gconf
    to
    import gconf
    but I think that is only if you have gconf installed.

    Download " antergos-wallpapers-extra " and enjoy community sponsored wallpapers.

    Use the "Linux Beginner Search Engine"

    https://cse.google.com/cse/home?cx=017607476515012185699:b_owgx6xyi0

  • @Modisc
    Hi again!
    Here is output
    [[email protected] ~]$ cinnamon-settings
    Could not find bluetooth module; is the cinnamon-control-center package installed?
    init took 84.622 ms

    It is actually the same output as before! Strange huh? Now I have panel and it seems to be working fine! I was lucky to find the “needle” to solve my problem with the huge buttons. I went the long way through themes and then icon-themes. It was an icon-theme called orchangelo. Pity because it looked very nice!
    Now almost everything is working fine here!
    Panel and button is solved!

  • Well that is great news. :)
    Remember, when something for what -ever reason is not working right, try to start it in Terminal and have a look at the output.
    It can be informational at times.
    That is not to say that it provides information all the time, but it can still be useful.
    And as for icon packs producing problems, I have had that too and at times, sadly they do not all work as well as we hope.

    Download " antergos-wallpapers-extra " and enjoy community sponsored wallpapers.

    Use the "Linux Beginner Search Engine"

    https://cse.google.com/cse/home?cx=017607476515012185699:b_owgx6xyi0

cinnamon panel3 Posts 8Views 1763
Log in to reply