• DPI problems, again!


    Hi!

    I’ve had DPI problems before and gotten help from here. Thanks for that! But the problem wasn’t solved completely!
    I have a screen with 1920x1080 resolution. I have set the font size in the openbox settings for 16, so that most of the things are of good size. But that doesn’t effect all programs, for example lxterminal, clementine and pamac have the text so small it is really hard to read. Some of these programs have their own font settings, but not all.
    I know I could fix those programs size by adding xrandr --dpi 144 to autostart.sh or to lightdm.conf, but that would make some texts super big, like in nautilus and firefox, for example.
    Now I could after that make the fonts smaller again from theopenbox settings, but then some fonts of the system, for example all the fonts of the system tray programs of tint2 would become again tiny.

    Is there any solution for this mess?

  • hi.

    First off, I take it you were aware of the Arch Wiki link on this item: Arch Wiki HiDPI It does not mention of any settings specific to OB, but you can have a look if you will. You can try to make adjustments in an ~/.Xresources file.

    Secondly, I have to agree with you that with systems that are installed on HiDPI, it can be a bit of a pain. I have had to deal with this myself.

    I am no guru, but I did have a quick look around the net for you. The link below has to do with Arch installed on a MacBook; however, it’s common knowledge that a laptop like that has HiDPi.

    The link talks about making some file adjustments as well as creating some other files. I will let you read the brief at the link. I hope it offers some solutions. Give it a try. If it doesn’t work, sorry. Trying to help you. You could always undo what changes you made. link text

    The author of the above link given also says that he has his config files at github (stated near the bottom of his blog post).

    Download " antergos-wallpapers-extra " and enjoy community sponsored wallpapers.

    Use the "Linux Beginner Search Engine"

    https://cse.google.com/cse/home?cx=017607476515012185699:b_owgx6xyi0

  • I just checked my theme and found that there were references to fonts within.
    they are, on my system,
    gtk-contained.css
    gtk-widdgets-backgrounds.css

    Perhaps you could just comment the lines as in
    /* font: open sans 11;*/

    Yours might be different as I was just showing how to comment in css if you didn’t know already.
    Terminal programs, the ones I have used, all have there own font settings, usually in the Appearance tab.

    Might just be worth a shot.

    Regards

  • Thanks all! I noticed that the programs that had a tiny fonr were mostly Qt. So I changed the font settings in Qt config file. So it is kind of solved now!

    P.S. posting to these forums is pain in the ass. I have to zoom every internet page to 150% and when I do that to antergos forums this text box goes too low and it can’t be seen.

  • I can only imagine. I know what it is like to deal with things that are too small to write text in. Have had issues similar to that though not directly related to your specific problem.

    Download " antergos-wallpapers-extra " and enjoy community sponsored wallpapers.

    Use the "Linux Beginner Search Engine"

    https://cse.google.com/cse/home?cx=017607476515012185699:b_owgx6xyi0

xrandr3 dpi4 font size1 Posts 5Views 1555
Log in to reply