• Antergos boots into terminal


    I have an antergos with openbox and it was working pretty ok until today. Now I can’t get into openbox as the system boots into terminal. As the computer is booting there comes an error message in the grub texts (or what it is called?): [FAILED] Failed to start x on vt7.

    EDIT: also, I’m using lxdm with autologin

  • Not too sure if the issue is the same but I had the same thing with my openbox install lat night. For some reason I had to install lightdm-webkit2- greeter from the terminal you mentioned and after rebooting everything went back to normal (though I cannot figure out why this happened)…

    1.Antergos Linux KDE plasma / Gnome 2.Ubuntu 17.10 64bit Unity
    Intel Core2 Duo CPU P8400 2.26GHz‖ RAM 3908 MiB ‖ Dell Inc. 0F328M - Dell Inc. Latitude E6500
    Intel Mobile 4 Series Chipset Integrated Graphics [8086:2a42] {i915

  • Thanks, but that didn’t help, even after changing my dm for lightdm.

  • @peruna
    I don’t really know much of this problem. Maybe for the devs?
    But there are some threads at the Arch support forums.
    For example, link text and link text
    After reading those, you will have to understand that any ‘dm’ related conversation will have to be taken into consideration for Antergos.
    That’s all that I can really comment on.
    Don’t know of this problem though.
    Sorry.
    Just wanted to help you with some research on the issue. I basically used your thread’s title to Google (i.e. [FAILED] Failed to start x on vt7

    Download " antergos-wallpapers-extra " and enjoy community sponsored wallpapers.

    Use the "Linux Beginner Search Engine"

    https://cse.google.com/cse/home?cx=017607476515012185699:b_owgx6xyi0

  • dmesg and/or the x11.log file in /var/log/ and/or journalctl -b may help you find the root cause?

  • @danger89 There’s also an excellent sticky post by @lots-0-logs, which explains where to find and how read various logs.

  • Thanks all!
    @Modisc, I tried googling and found those, but with no help. I also tried the methods here, as I think that might be the root of the problem, but nothing helped. I actually broke the system so it went into a loop of trying to launch the dm and never booted, even to the terminal.

    So, I re-installed Antergos as I it is really easy for me. Now everything works fine! I’m glad installing is so easy!

  • @peruna Ahh you have NVIDIA Optimus card (Bumblebee software)? Try to avoid installing the nvidia package before you can’t boot your system.
    Read more:
    https://wiki.archlinux.org/index.php/Bumblebee

  • Thanks @danger89, I’ll keep that in mind!

Posts 9Views 1385
Log in to reply