• HOW TO: Installing nvidia driver


    Hi all,

    I like to explain how to setup NVIDIA driver. NOT ADVISED for NVIDIA Optimus videocards, see note below. With only 3 easy steps you got the official NVDIA driver instead of nouveau. Handy for playing games and such.

    Installation

    1. First check which NVDIA card you have, by executing:
      lspci -k | grep -A 2 -E "(VGA|3D)"
      • GeForce 400 series or newer, you can get the latest package called ‘nvidia’. It will install libgl as well.
        Eg. pacman -Ss nvidia
      • GeForce 8000/9000 and 100-300 series, install the ‘nvidia-340xx’ package.
      • Geforce 6000/7000 series, install the ‘nvidia-304xx’ package.
      • If you got a very new NVIDIA card, use the ‘nvidia-beta’ package from the AUR
        yaourt -Ss nvidia-beta
    2. Optionally: If you would like to install 32bit OpenGL support, install the equivalent lib32 package as well (eg. e.g. lib32-nvidia-libgl, lib32-nvidia-340xx-libgl or lib32-nvidia-304xx-libgl). When you setup wine, you probably also want to have these 32-bit packages installed. Be sure you resolve any conflicts with other libgl packages.

    In my situation, I didn’t need to create xorg.conf (deprecated) or 20-nvidia.conf at all in order to make my system work. If you do, try running nvidia-xconfig. This command will create a new file: /etc/X11/xorg.conf.

    The NVIDIA installation will automatically blacklist the nouveau driver, so no worries.

    Good luck!
    Note: NVIDIA Optimus users should never install the nvidia package directly, but use bumblebee package instead.

    More info: Arch Wiki NVIDIA
    Antergos Wiki: Bumblebee Install
    Ps.
    You can use ‘nvidia-utils’ for more advance settings/options.

  • Nvidia Optimus users, beware!

    Don’t - repeat, do not - follow the instructions above. If you do, it will immediately break Nvidia Optimus configuration. The computer will become unusable.

    Read Antergos WIki for correct drivers installation on Nvidia Optimus cards.

  • @just Thanks I updated the text accordingly.

  • Read Antergos WIki for correct drivers installation on Nvidia Optimus cards.

    I didn’t have checked that wiki guide. Perfectly well written. Congrats and thanks!

  • The only chance I have to install nvidia drivers is right after the installation, before rebooting the comp. BUT - Administrator password is required. If I reboot, Antergos is inaccessible. I’ve tried ‘e’ and then vga=0F00, nomodeset - this worked for installation (these commands I’ve learned out on Apricity forum). With no success, screen goes blank upon every option from Antergos boot list.

  • @marek Are you sure you don’t have a Nvidia Optimus card? Did you tried to boot in to console mode or use alt+f1 (other tty’s). Then see what the /var/log/Xorg.0.log says. I was searching for a dmesg or /var/log/syslog file in Antergos. Where is that file located?

  • @danger89
    Yep, I’m positive.
    Nvidia Quadro FX 3800M.
    I’ll wait for not beta version.

  • @marek NVIDIA tells me to install the 340 version. So please remove the nvidia package completely (+remove any xorg.conf file). And try to install nvidia-340xx package instead. After install run:
    sudo mkinitcpio -p linux

    I didn’t discuses the Quadro series sorry about that.

  • OK, but my problem in the first place is to be able to do ANYTHING after installation. All I get is a blank screen after choosing any of Antergos grub options.

  • @marek Try adding this to your kernel line (press ‘e’ when Grub shows up)

    systemd.unit=multi-user.target

  • Yes, thanks, tried that already.
    Didn’t help either.

  • @marek You tried Alt+1 already (virtual console)? If that STILL doesn’t work try to modify grub kernel line like karasu also explains. You can append ‘3’ at the end of the line. So in Grub bootloader you first press ‘a’ to append (or ‘e’ if that works). An example, from:
    linux /boot/vmlinuz[...] ro quiet
    to:
    linux /boot/vmlinuz[...] ro quiet 3

    If that also not work, try maintenance mode. This is runlevel 1, so add 1 add the end of the linux boot line.

  • Before I go ahead, I’d like to clarify the situation now.
    I have Antergos installed on my desktop pc with NVIDIA GTX 980 card. My monitor description and resolution is OK.
    However, it runs on default graphics: Gallium 0.4 on llvmpipe (LLVM 3.7, 256 bits) as it reads in Info.
    When I tried to install here Nvidia driver before, I think it was 346 package, I got a white screen with an error message: Something went wrong, System logged out or something like that. So, I’ve installed Antergos from scratch not touching already the graphics.

    So if it was a case on my laptop (Nvidia Quadro FX 3800M) which brings that inaccessibility problem, I would be happy.
    Is it possible?
    I’ll try those tips but I’m not sure as on Apricity Forum they gave up on it.

  • @marek

    1. Alt+1 - doesn’t work, in fact I don’t even know when I am supposed to press it; tried every step, nada;
    2. I did append ‘3’ after ‘… quiet’;
    3. I did again add ‘systemd.unit=multi-user.target’ command to the end., which is - after: initrd /boot/initramfs-linux.img;

    …starting version 227
    … disabled by bios
    Screen goes blank. That’s it.

  • @marek
    Wish that installation is so simple as for Linux Mint, which gives me always opportunity to be back on my laptop system in case like this.

  • @danger89 Thanks for taking the time to post this information. It will be helpful to many people. That being said, it would be best if you (or anyone else who has a moment to spare) would move the info over to the wiki, We want to keep information like this accessible from a single resource (which makes it easier for users seeking the info). Thanks! :)

    Best Regards,
    Dustin

  • @danger89 said:

    You can append ‘3’ at the end of the line.

    Just an FYI: Support for booting into runlevels (1-6) is not guaranteed to stick around. Its best to use the proper kernel command which is systemd.unit= + one of the following:

    • rescue.target (similar to old Runlevel 1)
    • multi-user.target (similar to old Runlevel 3)
    • graphical.target (similar to old Runlevel 5)
    • emergency.target

    So, for non-graphical mode with networking enabled you would use: systemd.unit=multi-user.target

    Cheers!

  • This post is deleted!
  • @lots.0.logs Ok, thanks I will. Well, I get “Hello, spam bot”. Mehh

  • @danger89 Are you not able to register? Could you take a screenshot of the message? Thanks.

driver42 how-to3 proprietary8 nvidia111 nouveau13 Posts 24Views 11242
Log in to reply