• lightdm-webkit2-greeter and lightdm-webkit-theme-antergos are in conflict


    Just getting this message this morning with pacman -Syu and wondering what to do? Appreciate the help.

  • If memory serves me correct, allow for delete/removal/replacement of light-webkit-theme-antergos during the upgrade.
    Afterwards, in /etc/lightdm you will then wind up with a lightdm-webkit2-greeter.conf It will also have different contents. No need to worry though. All will be good.

    Download " antergos-wallpapers-extra " and enjoy community sponsored wallpapers.

    Use the "Linux Beginner Search Engine"

    https://cse.google.com/cse/home?cx=017607476515012185699:b_owgx6xyi0

  • @Modisc: That’s what I did, plus updated the conf file. However, now it doesn’t boot into lightdm anymore. I get to a TTY login screen. I’m not sure how Antergos handles starting lightdm natively: neither the startx nor the start lightdm commands are installed by default. How does one get lightdm to start again? Sorry if the answer is obvious…

  • sudo systemctl restart lightdm

    Check your lightdm-webkit2-greeter.conf, just in case.

  • When you say, you updated the .conf file, how and/or what commands if any, did you utilize?
    You should not have needed to use any commands other than to remove the old one to be replaced with the new one.

    When you get to the TTY screen can you do the following:
    cat etc/lightdm/lightdm.conf ;
    Under [Seat:*] you should have uncommented greeter-session=lightdm-webkit2-greeter.conf
    Within that same directory of /etc/lightdm there should be a lightdm-webkit2-greeter.conf
    That is the one that Antergos uses.

    If you have a conf file that says lightdm-gtk-greeter that one is used for Arch.
    You should not be using that file, then.

    If you have neither of those or there is something else missing, you can try the following while in TTY:

    1. First upgrade/update sudo pacman -Syu
      then install lightdm-webkit2-greeter
    2. sudo pacman -S lightdm-webkit2-greeter
      then sudo systemctl enable lightdm
    3. then sudo systemctl start light
    4. You will probably immediately reboot

    If you do not get into a reboot condition,

    1. then do systemctl enable lightdm
      double-check systemctl is-enabled lightdm

    2. You may or may not get to actualize into the DE. That is, it continually goes into a loop where you are returned to the greeter. That is a permissions issue.

    Do the following while in TTY:
    sudo chown -R MichaelSenter:users / home/MichaelSenter

    Download " antergos-wallpapers-extra " and enjoy community sponsored wallpapers.

    Use the "Linux Beginner Search Engine"

    https://cse.google.com/cse/home?cx=017607476515012185699:b_owgx6xyi0

  • @Modisc
    Thanks for the replies! The command I had used at first was
    sudo mv -v /etc/lightdm/lightdm-webkit2-greeter.conf.pacnew /etc/lightdm/lightdm-webkit2-greeter.conf
    I’ve had the issue since then. I can’t seem to start the lightdm service. When I tried sudo systemctl restart lightdm like karasu suggested, I get an error: https://dl.dropboxusercontent.com/u/6892131/lightdm_restart.txt.

    I checked my lightdm.conf and didn’t have the line greeter-session at all. I reinstalled as you suggested (sudo pacman -Syu lightdm-webkit2-greeter), but the line was still not there. I manually wrote it in with vim. I only have the webkit2greeter conf in there, not the gtk greeter file. The next problem I ran into was trying to start the greeter: sudo systemctl start lightdm-webkit2-greeter is met with “Failed to start lightdm-webkit2-greeter.service: Unit lightdm-webkit2-greeter.service failed to load: No such file or directory.”

  • HI @Michael-Senter
    Ok. So the command you entered to rename was correct. Sorry. Had to ask. One never knows.

    The line at the link:
    Active: failed (Result: start-limit) since Sat 2015-11-21 18:34:45 EST; 35s ago
    should say Active: active

    Also, you mentioned you have “Unit lightdm-webkit2-greeter.service failed to load” That is why it states it is ‘failed’

    Can you systemctl enable lightdm and see where that takes you.

    A couple of things.
    Your link states:
    Start request repeated too quickly
    and
    Failed with result 'start-limit'
    Hmmm. I am curious about those.
    Am not too sure of what those would mean.
    Will have to defer that to someone else with a bit more experience.

    Could you please cat display-manager.service from /etc/systemd/system

    @karasu suggestion was correct and actually with his suggestion, should have worked out well.

    EDIT: Can you please do systemctl status systemd-logind and post output.

    EDIT x2: Ok. I figured out why you are getting those 2 errors as I listed above from your dropbox output.
    The reason why it says that is because somewhere along the line your system had you restart the service too frequently and systemd has an integrated mechanism to detect this and block it before too many restarts which will then cause these troubles.

    From the man pages it states that

    Configure service start rate limiting. By default, services which are started more than 5 times within 10 seconds are not permitted to start any more times until the 10 second interval ends. With these two options, this rate limiting may be modified. Use StartLimitInterval= to configure the checking interval (defaults to DefaultStartLimitInterval= in manager configuration file, set to 0 to disable any kind of rate limiting)
    
    

    Systemd
    SEARCH for StartLimitInterval

    If I understand this correctly you have to set the rate to 0 (zero).
    The problem here is I don’t know EXACTLY where you would have to configure that to 0 (zero).

    Download " antergos-wallpapers-extra " and enjoy community sponsored wallpapers.

    Use the "Linux Beginner Search Engine"

    https://cse.google.com/cse/home?cx=017607476515012185699:b_owgx6xyi0

  • Ok here is the output from systemd-logind: https://dl.dropboxusercontent.com/u/6892131/logind.txt

    Display-manager service:
    https://dl.dropboxusercontent.com/u/6892131/display_manager.txt

    When I enter systemctl enable lightdm-webkit2-greeter I get the output Failed to execute operation: No such file or directory. This occurs even after a reinstall of the webkit2-greeter.

  • I am so sorry. My bad completely.
    It is not lightdm-webkit2-greeter to enable. It is lightdm.service to enable.
    My mistake completely. I was not watching what I was typing.
    As a result, I had to EDIT my prior post for future readers
    Sorry for the confusion.

    Do you have any other greeter services installed? If so, disable those.
    Can you try
    systemctl enable lightdm -f (you are using a force option this time)
    or
    systemctl enable lightdm.service -f
    Your config and service file outputs are normal. Nothing incorrect there.

    If nothing works out here, we go on to another step.

    Download " antergos-wallpapers-extra " and enjoy community sponsored wallpapers.

    Use the "Linux Beginner Search Engine"

    https://cse.google.com/cse/home?cx=017607476515012185699:b_owgx6xyi0

  • @Modisc
    I can enable lightdm, but it still won’t start. I tried rebooting just to test it, but I still have the same issue. In case it helps, here’s the output from dmesg: https://dl.dropboxusercontent.com/u/6892131/dmesg.txt

    When I try sudo systemctl start lightdm I get the error message

    Job for lightdm.service faild because the control process exited with error code. See “systemctl status lightdm.service” and “journalctl -xe” for details.

    The output from those:
    https://dl.dropboxusercontent.com/u/6892131/journal.txt
    https://dl.dropboxusercontent.com/u/6892131/lightdmserv.txt

    Note that it again includes the line

    Start request repeated too quickly.

  • Hi,

    That repeated too fast message is because lightdm fails to launch, and then tries again, and again… so systemd blocks it so your system does not get unusable.

    • First, check that you have the correct packages installed
      sudo pacman -Q | grep lightdm
      You should have lightdm and lightdm-webkit2-greeter packages (nothing else).

    • Then check your setup files.
      In /etc/lightdm.conf you should have these lines (among others):

    greeter-session=lightdm-webkit2-greeter
    session-wrapper=/etc/lightdm/Xsession
    

    And in /etc/lightdm/lightdm-webkit2-greeter.conf

    webkit-theme=antergos
    

    If you have all of this, then we must check your logs.
    Go to /var/log/lightdm and paste here the contents of all .log files (.old files are not necessary, as are old logs).

    Hope this helps.

  • @karasu
    I got it solved now! Thanks :) The step that fixed it for me was adding the line greeter-session=lightdm-webkit2-greeter, i.e. without the “.conf” suffix. Now it boots normally.

Posts 12Views 3384
Log in to reply