• making chromium default web browser


    not sure when it happened but i cant figure out how to make chromium default on openbox? firefox has taken over and wants to be default. ive tried many searches on the problem but most dont work. what sets the defaults in the current openbox setup?

    thanks

  • @megaman add this to your ~/.bashrc and then log out/in again.

    BROWSER=/usr/bin/chromium
    

    Cheers!

  • @lots.0.logs no luck on that one. still defaults to firefox

  • @lots.0.logs Maybe also ‘export’ it?

  • You shouldn’t have to export it when placed in ~/.bashrc though it can’t hurt to try. As is always the case with linux, there is more than one way to to do it. I would just let Chromium handle it (Settings>>Default Browser).

  • @lots.0.logs ya i tried letting chromium handle it but doesnt work. every time the browser opens it lets me know it isnt default and would i like to set it as default. i always click yes. in the settings the button to make it default doesnt work. very odd ive never had this happen before. i prob wouldnt care other then the default message everytime chromium opens.

    in my searches on google found many different ways to set it on openbox but none seem to work.

  • @megaman Have you tried this command:

    xdg-settings set default-web-browser chromium.desktop
    
  • @lots.0.logs it kicked me this back
    xdg-settings: $BROWSER is set and can’t be changed with xdg-settings

  • That is so weird. Let’s back up a bit, what action are you taking exactly where Firefox is opened instead of Chromium?

  • chromium is my main browser and i use that most the time. so when i open it up it says chromium is not the default browser would you like to make it default. i click yes every time. but just drives me nuts because the message wont leave unless you click it.

    when i use Pamac links to websites it will open firefox. its always defaulted to firefox but only recently has chromium started asking me to default to chromium. every single time lol

    so if it wasnt for the message every time i wouldnt even care. i even try to open a html file with chromium from the file manager and no go there either.

  • You should be able to disable the Default Browser check in Chromium’s Settings (unless something changed recently?). Check to see if and what you have set for http URI’s and html files in: ~/.local/share/applications/mimeapps.list. Here is mine for reference:

    [Default Applications]
    text/html=google-chrome.desktop
    x-scheme-handler/http=google-chrome.desktop
    x-scheme-handler/https=google-chrome.desktop
    x-scheme-handler/about=google-chrome.desktop
    x-scheme-handler/unknown=google-chrome.desktop
    inode/directory=nemo.desktop;
    
  • @lots.0.logs ya i looked at that also but my mimeapps.list is blank :worried:

  • nevermind i didnt noticed the option on the popup that says never ask again. i just kept hitting yes to make chromium default. so guess this will work. no more popup window now that i can see.

    i feel super dumb now :smile:

    thanks for the help :+1:

Posts 16Views 1899
Log in to reply