• {SOLVED} Openbox, how to manage wi-fi connections

    Hi all
    Two naive 😊 questions which I have not been able to resolve myself after hours of searching.

    1. After changing the WLAN name & password, of my router, I can no longer access my Internet connection. So far, so good. The problem is that I cannot figure out a way to add the new one which is visible, amongst other neighboring networks.
    2. Keeping in mind that this is a laptop, (thus portable) should I need to connect to another network, how is this done?
      ***No way this is a card issue. My Antergos/Gnome & Ubuntu work just fine on both of my laptops…👍
  • @anarch Do you have the following line in ~/.config/openbox/autostart?

    nm-applet &
  • No, @lots-0-logs , I dont have the line you mentioned. In spite of already having an applet, I tried your command and gave me a 2nd network applet, which I removed
    I do have a network applet in the bar. As I said before, I can see my network and other available ones in the “available networks”. I highlight it to choose it. I click on it and it notifies me that “no connection. You are disconnected from the network”.
    Thats why I also asked the 2nd question. If I simply wanted to conect to another network, without my present problem, how would I manage to connect???
    Am I missing something?

  • You should be able to do everything using the applet I mentioned. Its the same one we use on our Minimal ISO.

  • I should, but I cant! From what I have described above, am I missing something?
    Should I re-install it you think? It s a new installation, the laptop is used to “torture” distos, I dont mind if I give it a 2nd try…😆

  • No, that’s not necessary. I think the problem is that we aren’t including gnome-keyring in our Openbox installation. Try installing Gnome Keyring then restart NetworkManager. Let me know the result.

  • Hmmmm, I am already in the proccess of re-installing. I will check if the same issue appears and if it does, I will install the gnome-keyring and let you know either way…
    Thanks for your time, mate!👏

  • Yeap! I confirm gnome-keyring was missing. Problem solved, too bad I was too impatient and re-istalled…👊

  • @anarch 😆 Take it as a learning experience hehe. I will make sure we include the package by default from now on. Cheers!

  • I do, @lots-0-logs !😆
    And talking about learning experience…could you also do something about including a keyboard layout switcher applet? ☺ It took me two nights of searching 😓 just to add a greek layout, using this command…
    { setxkbmap -layout “us,gr” -option “grp:alt_shift_toggle” }
    but would be nice to have an applet to see which language I am using (not that I have not started digging into it…😉

  • Well one option is to use Xfce’s panel instead of Tint2. You can install Xfce’s panel without pulling in all of Xfce and it will be fully functional (including the large number of panel applets/plugins that are available for it–one of which happens to be a keyboard layout switcher 😉)


Posts 11Views 6671
Log in to reply
Bloom Email Optin Plugin

Looks like your connection to Antergos Community Forum was lost, please wait while we try to reconnect.