• lightdm.service: Unit entered failed state


    Hi.
    An issue has surfaced with ligthdm again. Not too sure what the issue might be. To circumnavigate around the issue temporarily, I just installed/enabled gdm. Doing ok with that for the moment.
    I did Syu after I managed to get into startx as well as console
    No change as hoped for.

    Some information:
    uname -r 4.1.13-1-lts
    Here are the log files at pastebin.
    Journal_2.last
    journal_3.last
    journal_4.last
    xorg.0.log
    xorg.0.log.old

    Xsession and Xsession.old are empty.

    cat lightdm.log
    [+0.13s] DEBUG: Logging to /var/log/lightdm/lightdm.log
    [+0.13s] DEBUG: Starting Light Display Manager 1.16.5, UID=0 PID=554
    [+0.13s] DEBUG: Loading configuration dirs from /usr/share/lightdm/lightdm.conf.d
    [+0.13s] DEBUG: Loading configuration dirs from /usr/local/share/lightdm/lightdm.conf.d
    [+0.13s] DEBUG: Loading configuration dirs from /etc/xdg/lightdm/lightdm.conf.d
    [+0.13s] DEBUG: Loading configuration from /etc/lightdm/lightdm.conf
    [+0.13s] DEBUG: Using D-Bus name org.freedesktop.DisplayManager
    [+0.13s] DEBUG: Registered seat module xlocal
    [+0.13s] DEBUG: Registered seat module xremote
    [+0.13s] DEBUG: Registered seat module unity
    [+0.13s] DEBUG: Monitoring logind for seats
    [+0.13s] DEBUG: New seat added from logind: seat0
    [+0.13s] DEBUG: Seat seat0: Loading properties from config section Seat:*
    [+0.13s] DEBUG: Seat seat0: Starting
    [+0.13s] DEBUG: Seat seat0: Creating greeter session
    [+0.13s] DEBUG: Seat seat0: Failed to find session configuration lightdm-gtk-greeter
    [+0.13s] DEBUG: Seat seat0: Failed to create greeter session
    [+0.13s] DEBUG: Failed to start seat: seat0
    
    
    cat lightdm.log.old
    [+0.00s] DEBUG: Logging to /var/log/lightdm/lightdm.log
    [+0.00s] DEBUG: Starting Light Display Manager 1.16.5, UID=0 PID=548
    [+0.00s] DEBUG: Loading configuration dirs from /usr/share/lightdm/lightdm.conf.d
    [+0.00s] DEBUG: Loading configuration dirs from /usr/local/share/lightdm/lightdm.conf.d
    [+0.00s] DEBUG: Loading configuration dirs from /etc/xdg/lightdm/lightdm.conf.d
    [+0.00s] DEBUG: Loading configuration from /etc/lightdm/lightdm.conf
    [+0.00s] DEBUG: Using D-Bus name org.freedesktop.DisplayManager
    [+0.00s] DEBUG: Registered seat module xlocal
    [+0.00s] DEBUG: Registered seat module xremote
    [+0.00s] DEBUG: Registered seat module unity
    [+0.00s] DEBUG: Monitoring logind for seats
    [+0.00s] DEBUG: New seat added from logind: seat0
    [+0.00s] DEBUG: Seat seat0: Loading properties from config section Seat:*
    [+0.00s] DEBUG: Seat seat0: Starting
    [+0.00s] DEBUG: Seat seat0: Creating greeter session
    [+0.00s] DEBUG: Seat seat0: Failed to find session configuration lightdm-gtk-greeter
    [+0.00s] DEBUG: Seat seat0: Failed to create greeter session
    [+0.00s] DEBUG: Failed to start seat: seat0
    
    
    cat x-0-greeter.log
    file:///usr/share/lightdm-webkit/themes/antergos/index.html:102:16: CONSOLE LOG Is random
    file:///usr/share/lightdm-webkit/themes/antergos/js/greeter.js:263:14: CONSOLE LOG [object Object]
    
    

    EDIT: I don’t understand why it “Failed to find session configuration lightdm-gtk-greeter” as nothing the last time I logged into this system was changed. I do recall at some point that there was an update to the greeter. Though I did not think much of it as it.

    Download " antergos-wallpapers-extra " and enjoy community sponsored wallpapers.

    Use the "Linux Beginner Search Engine"

    https://cse.google.com/cse/home?cx=017607476515012185699:b_owgx6xyi0

  • @Modisc said:

    Hi.
    An issue has surfaced with ligthdm again…

    Can’t confirm that.

    There are 20 Antergos installations here. DE used are Mate, Cinnamon, Gnome, Kde. All use the standard, default Antergos lightdm with lightdm-webkit2-greeter. Autologin is used in all sessions.

    Lightdm package was updated recently. A day or two ago. Autologin continues to work without a problem. Logging out and back in doesn’t present any problem as well.

    Besides Antergos, there are many native Arch installations here. I use lightdm with lightdm-gtk-greeter, where appropriate. In Budgie, Mate, Cinnamon. After lightdm update also all Arch-Lightdm systems continue to work flawlessly.

  • @Modisc Check your /etc/lightdm/lightdm.conf, it should not have lightdm-gtk-greeter if you are using our greeter (it should be lightdm-webkit2-greeter)

  • Hi. So I did have a look inside the .conf file.
    I have this under the [Seat:*] section:
    #greeter-session=example-gtk-gnome
    but my guess is that must be because I decided to switch over to gdm temporarily until I would have the issue resolved.
    And it just says ‘example’ to illustrate how to place it in that file.

    So far I have not changed this over to #greeter-session=lightdm-webkit2-greeter
    I believe that this is the setting to have it changed back after the systemctl command to enable lightdm, is it not?
    The Arch Wiki states that this would be the setting.

    I did not see lightdm-gtk-greeter when I went
    ls -l /usr/share/xgreeters/ total 4 -rw-r--r-- 1 root root 155 Oct 18 20:23 lightdm-webkit2-greeter.desktop
    So ligthdm-webkit2-greeter is the one.

    @just I guess I made an ‘oopsie’ at the beginning of my post near the beginning.
    I guess I should have left that small part out. It’s only an issue on my end, not globally affecting all users.

    Download " antergos-wallpapers-extra " and enjoy community sponsored wallpapers.

    Use the "Linux Beginner Search Engine"

    https://cse.google.com/cse/home?cx=017607476515012185699:b_owgx6xyi0

  • @Modisc said:

    Hi. So I did have a look inside the .conf file.
    I have this under the [Seat:*] section:
    #greeter-session=example-gtk-gnome
    but my guess is that must be because I decided to switch over to gdm temporarily until I would have the issue resolved.
    And it just says ‘example’ to illustrate how to place it in that file.

    In a working lightdm.conf this line reads

    greeter-session=lightdm-webkit2-greeter
    

    It’s not commented out. I don’t think that installing GDM comments this line out and changes the setting’s value.

    So far I have not changed this over to #greeter-session=lightdm-webkit2-greeter
    I believe that this is the setting to have it changed back after the systemctl command to enable lightdm, is it not?

    AFAIK, systemctl enable/disable does not modify any file content. It only creates/deletes softlinks with special names in special directories. Systemd calls those softlinks as “services”.

    The Arch Wiki states that this would be the setting.

    I did not see lightdm-gtk-greeter when I went
    ls -l /usr/share/xgreeters/ total 4 -rw-r--r-- 1 root root 155 Oct 18 20:23 lightdm-webkit2-greeter.desktop
    So ligthdm-webkit2-greeter is the one.

    That is correct. There’s no lightdm-gtk-greeter.desktop in the /usr/share/xgreeters/ , in Antergos. It is present in native Arch only. In Antergos, there’s /usr/share/xgreeters/lightdm-webkit2-greeter.desktop only. No other greeter(s).

    @just I guess I made an ‘oopsie’ at the beginning of my post near the beginning.
    I guess I should have left that small part out. It’s only an issue on my end, not globally affecting all users.

    I understood that 5 min later after posting the reply. Otherwise there was already a plethora of posts about the problem with lightdm.

    This is my working Antergos lightdm.conf. You could use it as an example. I don’t remember if two lines to autologin the user just were modified by hand or automatically by Antergos. I didn’t modify any other line in it. No other display manager was ever installed. LightDM was never enabled/disabled with systemctl.

  • Issue is resolved.

    I had to uncomment greeter-session= and change to greeter-session=lightdm-webkit2-greeter
    then continue with systemctl related command to enable one and disable the other.

    I am none too sure how or why the above line in ligtdm.conf would have been commented. I did nothing to change it’s value at any point in history prior to enabling gdm for a brief time.

    Again,I am wondering that there was an upgrade of webkit2-greeter at some point in recent history and somehow, somewhere, it did not respect current configurations. I am not too sure, though. Only guessing.

    Your .conf file is pretty much the same one that I have.
    Thank you both for your help.

    Download " antergos-wallpapers-extra " and enjoy community sponsored wallpapers.

    Use the "Linux Beginner Search Engine"

    https://cse.google.com/cse/home?cx=017607476515012185699:b_owgx6xyi0

  • @Modisc said:

    Again,I am wondering that there was an upgrade of webkit2-greeter at some point in recent history and somehow, somewhere, it did not respect current configurations.

    Provided that the package has been properly “packaged”, pacman will not overwrite config files. It will install new config files in the target directory with the .pacnew file extension added to the filename. Some AUR helpers include options to manage pacnew files (for example, yaourt -C). Maybe that helps explain what happened in your case?

    Cheers!

Posts 7Views 2906
Log in to reply