• Cant boot into Antergos after successfull install


    So ive tried installing antergos twice, both says successfull but after i restart my PC, unlike when after i install ubuntu, it didnt show me option to boot into antergos. Instead it directly boot into Windows 10. My HDD is MBR and installed antergos on an extended partition

    sda1 Windows Reserved
    sda2 Windows 10
    sda3 Extended Partition
    –sda5 ext4 /
    –sda6 fat /boot/efi
    –sda7 swap
    sda4 My Data

    I tried using easybcd to manually add the option to boot into the /boot and root partition. Both booted into a grub> commandline, but i dont know what to do after that :/

    Is it because i installed it on an extended partition?

  • @blazefx Was sda6 your existing EFI partition or did you create it at the time of install? You should not create a new partition, you should set your existing EFI partition to be mounted as /boot/efi (just don’t format it!)

  • @lots.0.logs idk which one my efi partition is. and yes i make a new partition as /boot/efi since i cant find any partition that formatted as FAT. Is windows reserved is the efi partition? i tried using it as /boot/efi but still no differece

  • Are you sure you have a UEFI boot system? Please post a screenshot of the advanced partitioning screen here. Thanks.

  • @lots.0.logs the boot option in my laptop bios list the installer media to boot as UEFI
    Here is the screenshot of my partition link to image
    I tried installing on a virtual machine, but unlike my PC the one on the VM doesnt tell me to set a /boot partition.

  • Hmm…That is weird. Could you run the gparted application (its included on the live system) and post a screenshot of the partition layout it shows?

Posts 6Views 947
Log in to reply