• Huge Error During Boot


    The error can be seen here: http://imgur.com/H27YIoz
    I have recorded a video which can be seen here: https://www.youtube.com/watch?v=n5X4dVJcP6U

    The problem seem to be my dual boot. I use Windows 10 and Antergos in dual boot, and when ever I use Windows and want to log into Linux it gives me this error, I have to force shutdown my laptop and reboot once or twice in order for it to boot successfully into Antergos :/

    The numbers are always different, but this part of the error stays the same: nouveau E[ PFIF0][0000:01:00.0] SCHED_ERROR

    After a bit of looking on Google its suggested to boot with “nouveau.modeset=0” parameter in Grub, but Implementing this in Grub Customizer does not seem to work. Any1 know a fix?

    My rig and setup can be found here if its of any significance: http://dulic.me/my-things

    "Sufficiently advanced technology is indistinguishable from magic" - Arthur C. Clarke

    Lets be magicians ^^

  • @Damir-Dulic

    Do you have fast startup turned on in your windows 10?

  • @karasu Ah yes, forgot to mention that I have disabled fast startup due to Linux not registering my Windows partitions otherwise. So it was disabled even when I created Linux on my system.

    "Sufficiently advanced technology is indistinguishable from magic" - Arthur C. Clarke

    Lets be magicians ^^

  • Hi,

    • Edit the grub configuration file:
      sudo nano /etc/default/grub
    • Search for this line:
      GRUB_CMDLINE_LINUX_DEFAULT="quiet splash"
    • And change it to:
      GRUB_CMDLINE_LINUX_DEFAULT="nomodeset nouveau.modeset=0"
    • Rebuild your GRUB cfg file:
      grub-mkconfig -o /boot/grub/grub.cfg

    And reboot.

    Tell us how it goes.

    Cheers!

  • @karasu That fixed the issue it seems, didn’t get an error on the last boot after Windows ^^
    Thank you very much for your help.

    "Sufficiently advanced technology is indistinguishable from magic" - Arthur C. Clarke

    Lets be magicians ^^

  • Seem it isn’t fixed after all :(

    Just booted from Windows and got the error :/

    "Sufficiently advanced technology is indistinguishable from magic" - Arthur C. Clarke

    Lets be magicians ^^

  • Geez… Sorry to hear that.

    Please, check that you are really using the nomodeset and nouveau.modeset=0 options (just press ‘e’ in the grub menu and check the kernel line).

    Let’s see if anybody else has a better idea.

  • @karasu I have good and bad news.

    The good. Your fix seems to have worked. I did a fresh install of Linux cause Windows latest th2 release broke everything and once I did I implemented your fix again and viola, no error on boots.

    The extremely bad news. - doing this breaks my gpu driver it seems. Animations don’t work and only my laptop monitor works, my other monitor which is connected via HDMI is not detected :/

    "Sufficiently advanced technology is indistinguishable from magic" - Arthur C. Clarke

    Lets be magicians ^^

  • I think you should give the proprietary driver a try. Have you ever tested it on your laptop?

  • @karasu No I have not tried it, used the default ones with Antergos, is there any guide I can follow?

    "Sufficiently advanced technology is indistinguishable from magic" - Arthur C. Clarke

    Lets be magicians ^^

Posts 11Views 1178
Log in to reply