• USB Live Image - Boots to White Screen / Unresponsive


    Trying to use “antergos-2015.10.18-x86_64.iso” burned via dd and with ddrescue (same results) on Lenovo Y510P laptop with dual Nvidia GeForce 755M graphics cards. Live USB boots to a white/gray shaded screen and is un responsive - no CTRL-ALT-F2 either.

    Typically for Nouveau drivers I have to add the following kernel parameters to prevent a “black screen” issue at boot.

    nomodeset nouveau.modeset=0

    I tried these and found no difference, same white/gray screen.

  • BTW - This laptop does have UEFI, Legacy boot support is enabled but I have used Antergos UEFI before with just using the kernel parameters above.

    UPDATE - I also booted with Legacy (no UEFI), while I get a prettier boot screen, I still get the white/grey screen with or without the above kernel parameters.

  • @reefland said:


    nomodeset nouveau.modeset=0

    These two parameters are fine, but sometimes they work, sometimes not.

    Try to use only one parameter instead of them. It’s the vga=nnn parameter. nnn is any of vesa video modes, available for your graphic card. There’s no an easy way to find all vesa video modes availbale. Try the following combinations:

    vga=895   corresponds to 1980x1020, nVidia cards only
    vga=789   corresponds to 800x600, all cards
    vga=normal   corresponds to "default" screen res
    vga=ask   will list basic vesa modes available and ask which one to use
    

    The parameter doesn’t affect in any way the screen resolution in X session. It affects text screen res during boot only, nothing else.

  • Thanks for the prompt reply. I tried each of them in UEFI and in Legacy Boot, same result of a white/grey screen.

    I removed the quiet splash kernel parameters to see the text of the boot and found something interesting:

    :: Mounting /run/archiso/cowspace (tmpfs) filesystem, size=320M...
    losetup: /run/archiso/bootmnt/arch/root-image.sfs: failed to set up loop device: no such file or directory
    :: Mounting '' to '/run/archiso/sys/root-image'
    Waiting 30 seconds for device ...
    ERROR: '' device did not show up after 30 seconds...
       Falling back to interactive prompt
       You can try to fix the problem manually, log out when you are finished
    sh: can't access tty: job control turned off
    

    After that it drops me at a root prompt.

    I double checked the MD5 value of the ISO I downloaded vs expected value and it matches.

  • @reefland The problem doesn’t seem to be related to video card. It has happened several times in the past, but I can’t recall a solution :confounded: .

    Another thing. Some UEFI BIOSes has also the Secure Boot option. To boot in Legacy mode on such BIOSes it’s not enough just to switch them from UEFI to Legacy, it is also necessary to disable the Secure Boot. Did you do that?

  • @just said:

    @reefland The problem doesn’t seem to be related to video card. It has happened several times in the past, but I can’t recall a solution :confounded: .

    Another thing. Some UEFI BIOSes has also the Secure Boot option. To boot in Legacy mode on such BIOSes it’s not enough just to switch them from UEFI to Legacy, it is also necessary to disable the Secure Boot. Did you do that?

    Yes, confirmed that Secure Boot is set to disabled. All I’m doing is toggling options between UEFI Boot Only mode and Legacy mode to try both boot options to see if they were consistent.

    BTW - I already triple boot Windows 10, Ubuntu and Antergos (KDE) on this laptop. What I’m planning to do is remove Ubuntu and Antergos partitions, create new partitions based on combined space, switch to GNOME and have a cleaner partition layout. So I know at one point the Antergos boot USB worked fine on this laptop since I’ve installed it before.

  • I found a reference to this “30 second error” in the Arch wiki

    https://wiki.archlinux.org/index.php/USB_flash_installation_media#BIOS_and_UEFI_Bootable_USB

    “If you get the “30 seconds” error due to the /dev/disk/by-label/ARCH_XXXXYY not mounting, try renaming your USB media to ARCH_XXXXYY (e.g. ARCH_201501).”

    I see the USB drive has 3 partitions, 2 with the the following names (rest is free space).
    ANTERGOS
    ARCHISO_EFI

    Are these the right volume names? Ignore the wiki suggestion?

  • @reefland said:

    I found a reference to this “30 second error” in the Arch wiki

    https://wiki.archlinux.org/index.php/USB_flash_installation_media#BIOS_and_UEFI_Bootable_USB

    “If you get the “30 seconds” error due to the /dev/disk/by-label/ARCH_XXXXYY not mounting, try renaming your USB media to ARCH_XXXXYY (e.g. ARCH_201501).”

    I didn’t see this article until now. Will read it later, with attention. Until then can’t say anything on the matter.

    I see the USB drive has 3 partitions, 2 with the the following names (rest is free space).
    ANTERGOS
    ARCHISO_EFI

    Are these the right volume names? Ignore the wiki suggestion?

    3 partitions? Seems strange. In the example below I use a 4G Antergos LiveUSB, which boots perfectly on boxes with pure Legacy and UEFI BIOSes, switched to Legacy mode and with Secure Boot disabled.

    The usb stick is currently recognized as /dev/sdc .

    It has only 2 partitions.

    This is how it is seen by fdisk :

    $ sudo fdisk -l /dev/sdc
    Disk /dev/sdc: 3.7 GiB, 4004511744 bytes, 7821312 sectors
    Units: sectors of 1 * 512 = 512 bytes
    Sector size (logical/physical): 512 bytes / 512 bytes
    I/O size (minimum/optimal): 512 bytes / 512 bytes
    Disklabel type: dos
    Disk identifier: 0x19c0b867
    
    Device     Boot Start     End Sectors  Size Id Type
    /dev/sdc1  *        0 3192447 3192448  1.5G  0 Empty
    /dev/sdc2         304   63791   63488   31M ef EFI (FAT-12/16/32)
    $ 
    

    And this is how it is seen by gparted :

    antergos-iso-gparted.png

    I can’t see 3 partitions on it.

  • I misspoke, it’s 2 partitions and free space. I incorrectly stated the “freespace” was a partition, it is not.

    $ sudo fdisk -l /dev/sdg
    Disk /dev/sdg: 14.9 GiB, 16026435072 bytes, 31301631 sectors
    Units: sectors of 1 * 512 = 512 bytes
    Sector size (logical/physical): 512 bytes / 512 bytes
    I/O size (minimum/optimal): 512 bytes / 512 bytes
    Disklabel type: dos
    Disk identifier: 0x19c0b867
    
    Device     Boot Start     End Sectors  Size Id Type
    /dev/sdg1  *        0 3192447 3192448  1.5G  0 Empty
    /dev/sdg2         304   63791   63488   31M ef EFI (FAT-12/16/32)
    

    I was looking at this and saw 3 sections, and visually equated it to 3 partitions.
    Screenshot from 2015-11-12 15-51-48.png

    I’ll wait for feedback on the partition renaming. Thanks.

  • Your fdisk output is absolutely identical to mine. That’s good. But it doesn’t explain, why you can’t boot.

    Could the problem reside not on LiveUSB side but in the computer?

    The article’s Troubleshooting section doesn’t convince me.

    • it doesn’t explain, why changing the label should solve the problem. It looks more like a black woodoo magic.

    • Antergos ISOs are always labeled this way, exactly as we see them now. Never seen an Antergos ISO labeled as ARCH_yyyymm.

  • @just said:

    • Antergos ISOs are always labeled this way, exactly as we see them now. Never seen an Antergos ISO labeled as ARCH_yyyymm.

    Agreed. Looking at the boot screen a little closer, this is mounting ok, so the issue I have is different, it happens immediately after the mount below:

    :: Mounting '/dev/disk/by-label/ANTERGOS' to '/run/archiso/bootmnt'
    :: Device '/dev/disk/by-label/ANTERGOS' mounted successfully
    

    It then shows this

    :: Mounting /run/archiso/cowspace (tmpfs) filesystem, size=320M...
    losetup: /run/archiso/bootmnt/arch/root-image.sfs: failed to set up loop device: no such file or directory
    :: Mounting '' to '/run/archiso/sys/root-image'
    Waiting 30 seconds for device ...
    ERROR: '' device did not show up after 30 seconds...
    

    I assume the issue is the losetup line, which I did find references to:

    https://www.reddit.com/r/archlinux/comments/18mr3o/ive_run_into_a_brick_wall_while_installing_arch/
    https://bbs.archlinux.org/viewtopic.php?id=157948

    But I don’t see anything useful as a cause in these threads.

  • @reefland Sorry for two stupid suggestions, but it’s one past midnight here, the head doesn’t work well anymore :smile: .

    • try to use another usb stick, if you have one

    • if there’s no another stick then, before writing the ISO with dd one more time, return the stick to “factory conditions”, by completely filling it with zeroes:

      sudo ionice dd if=/dev/zero of=/dev/sdX bs=4M && sync
      

    Only after that write the ISO with dd again. And please, always add the && sync after dd - it ensures that all physical writes to device are finished when the bash prompt will turn back.

    Must go to bed.

  • Here’s something that stumbled into my my mind… what happens when a partition named ANTERGOS already exists within the laptop and is a duplicate of the label used on the USB stick. I bet it tries to mount the drive on the laptop instead of the USB stick.

    After the boot fails, I tried a mount command and I see this:

    /dev/sda10 on /run/archiso/bootmnt type ext4 (ro,relatime,data=ordered)
    

    It should not a reference to the HDD yet, that should be referencing the USB stick. On this laptop, /dev/sda10 is valid – it is the existing ANTERGOS partition on the laptop. Perhaps the USB Live installer shouldn’t be looking for something so generic??? As humans like myself might name something generic to make it obvious that partition is ANTERGOS vs my UBUNTU partition.

  • Ah hah! Boot up the existing Antergos on the laptop and did the following to change the existing /dev/sda10 disk label from “ANTERGOS” to “ANT_ROOT”.

    $ sudo e2label /dev/sda10 "ANT_ROOT"

    Booted from the USB disk (did NOT do the steps you suggested about alternate USB or wipe with zero) with only UEFI enabled but Secure Boot disabled and the USB stick worked like a charm.

    I’d suggest this be considered a bug/feature request to alter the Live USB to NOT not try to boot such a generic volume name as ANTERGOS. I bet this is why Arch uses the ARCH_YYYYMM format to make to less likely someone would have a conflicting partition label.

  • @reefland said:

    Ah hah!..
    …and the USB stick worked like a charm.

    Well done, @reefland ! Good job. You’re a very skilled, well-conducting a dialog user. It’s a real pleasure to communicate with you.

    And thank you for marking the topic as [Solved] .

  • Hi there.

    I’ve just bought Lenovo Z51-70 and I’ve got exactly the same problem as You. I’ve try to change label using tune2fs and e2label, but I’ve ended up with some errors, so I’ve start over “my way” :P

    I’ve remove quiet splash from kernel parameters list and then when Waiting 30 seconds for device ... text show up I’ve plug usb stick out and in. Everything goes as usual from that point.

    Just leaving this info here for some folks with similar problem.

usb live instal4 white screen3 Posts 16Views 5516
Log in to reply