• Installation stalled


    Hi all
    I have antergos happily installed and running on 2 laptops and have not had any problems. However for the past 3 days I’ve tried installing antergos on an additional laptop and aside from the long wait on sorting mirrors just before installation, the installation stalls at various points. Sometimes early and sometimes just past the 50% mark.

    Strangely enough updates are running smoothly on my previously installed laptops. I would really like antergos installed on all machines. Please help.

  • @Terrence-Johnson It may be caused by slow mirrors.

    Do not start installation immediately upon boot.

    Open terminal first. Install reflector package:

    sudo pacman -Syy reflector
    

    Then, let reflector find 32 best mirrors for you:

    sudo reflector --fastest 128 --latest 64 --number 32 --sort rate --save /etc/pacman.d/mirrorlist
    

    Now you may click [Install It] button in Cnchi window to start the installation. Hopefully, installation will finish with better mirrors.

  • @just Thanks will try solution and keep you posted

  • @Terrence-Johnson I forgot the --age n option. It will instruct reflector to search for mirrors, updated in the last n hours. For example, the list of best mirrors, updated in the last 8 hours, may be obtained with

    sudo reflector --age 8 --fastest 128 --latest 64 --number 32 --sort rate --save /etc/pacman.d/mirrorlist
    

    Edit

    Probably this was a stupid advice. It worked earlier, until Cnchi didn’t rank the mirrors. By doing it now, Cnchi does the same job as reflector. Cnchi will rewrite the mirrorlist with its own. I’m sorry.

  • @just
    Is there anything else I could try. I tried the above - no joy.
    This time I stalled at 19% while it was downloading network manager.

  • I am having a different issue.
    A day or two ago (dot recall) I installed on my notebook without issues.

    I wanted to reinstall today and I just cant. It tries to upgrade cnchi and it does to 0.12.34 and then it says cnchi is out dated

    I run it from terminal and it showed a 2.36 version. I cant find that version on any repository.

    I am stuck now

  • @bulls4ever
    You should definitly consider starting a seperate thread for your issue.
    TerranceJohnson’s thread is about the installer, stalling.
    Your issue is about a different version of cnchi.
    Two seperate issues. Posting in a thread that is not relevant to the OP thread is not really a polite thing to do.
    Beside: cnchi stalling

    Download " antergos-wallpapers-extra " and enjoy community sponsored wallpapers.

    Use the "Linux Beginner Search Engine"

    https://cse.google.com/cse/home?cx=017607476515012185699:b_owgx6xyi0

  • @bulls4ever Sorry you having issues. I have no idea what’s happening at the moment - The first two installs about 2 weeks ago went perfectly. I figured - given the time I took trying to get the ‘easy install’ working I might just as well have installed arch. Eventually got that up and running. Will check back at antergos in a month’s time to see if the issues are resolved. Its a pity cos it really is the easiest way to install arch on your pc when it works. Good luck. Hopefully the mirrors issue gets sorted quickly. I’m in South Africa and maybe you too. There doesn’t appear to be mirror close to us. Maybe that explains my issue. Try again tomorrow - by the sounds of it you might have downloaded a package from a mirror not yet synced.

  • @Terrence-Johnson
    Have you thought about installing without network for the moment? Can possibly install needed updated packages post install.
    It’s just an idea aside from @just idea

    Download " antergos-wallpapers-extra " and enjoy community sponsored wallpapers.

    Use the "Linux Beginner Search Engine"

    https://cse.google.com/cse/home?cx=017607476515012185699:b_owgx6xyi0

  • @just That’s a good idea. I regret not thinking of that earlier. But since I’ve already got Arch up and running via command line install, I’m going to leave that off until the next installation. Probably over the weekend. Thanks for your help though.
    I do appreciate it.

  • i thought network was mandatory to install. (and it is)
    It is weird as it was working one or 2 days ago…

    Well I thought I could download the testing 11.09 version and it could solve the problem… it hangs on loading. shows the icon the middle with running dots under that wont stop for several minutes.

    It is not really a very big issue as I have it installed already. i just thought about doing a new clean install and choose NVIDIA instead so i didn’t have to mess with removing nouveau (at least I am hoping that choosing the right nvidia would do it)

    so i tried again the 10.18 and it shows the right version 0.12.38 and says its up to date

    honestly, if i had to wait a month Id rather install manjaro even though it is not vanilla arch

  • well … i thought there were an option to choose nvidia. must have confused to another distro.

    the other thing i noticed was i could not install LVM. would give error.

    I had to manually do it by changing
    pvcreate -f -v /dev/sdb2

    to
    pvcreate -ff -v /dev/sdb2

    – note -ff not -f

    then it worked.

    before i tried everything including manually removing all partitions.

  • @bulls4ever Guys, I’m a bit in trouble trying to follow all posts in this thread. To simplify, what seems to be a main goal / question here? If we want only to copy an Antergos, already installed and configured somewhere, onto another computer, there’s absolutely no need to repeat all installation and configuration steps.

    Just use the wonderfull fsarchiver to clone any existing Antergos from one computer to another.

    An example. There are 5 cumputers here. There are 5 Antergoses on each one. 5 different DEs, each one in its own, separate partition. It takes roughly 2 hours to install and configure well a single DE. 10 hours of hard work for a single computer.

    I don’t ever mind to waste 40 more hours installing and configuring Antergos on 4 remaining computers. I simply backup with fsarchiver all 5 Antergos partitions on an external hard disk. It takes about an hour. Then, I simply restore them on other 4 computers. The restore of all 5 partitions takes about 15 min.

    Only very minor adjustments are needed on target computers. I must change only four things

    • fstab, to reflect partitions used on target systems
    • regenerate initramfs
    • re-establish the network connection, change network controller name in conky
    • eventually, not always, adjust the video driver

    In 1 hour (backup) and 15 x 4 = 1 more hour (restore) five Antergoses are cloned to other 4 computers. Without any trouble.

  • Hi all

    seems the mirrors issue is resolved. Install is running at full speed again.

    Thanks

sorting mirrors1 download stalls1 cnchi104 Posts 14Views 1449
Log in to reply