• Display is black after waking from suspend and unlocking


    I just installed antergos. So far so good. When I suspend my computer, though, it wakes up fine, and prompts me to enter my password (as it should when it wakes up). But when I enter my password the screen is blank from then on. I can press the volume keys and hear the volume changing, and I can activate caps lock, it’s only the display that isn’t working. Pressing Alt+Ctrl+F1 doesn’t get me a TTY like it normally does. How can I fix this? I didn’t have this problem on Arch.

  • @jon.reeve Hi jon.reeve. Sorry for my english, my mother tongue is french :).
    The problem you describe has been added in the archlinux wiki few weeks ago by myself.
    It would be nice if you could have a look at the Wiki before asking this. I don’t mind answering at all, but You do save yourself a lot of time waiting for a solution like that :D.

    Anyway, the problem is related to lightdm. 2 solving ways come to my mind :

    1. disable lightdm and install gdm instead (gdm is an example, you might install something else ;)).
    2. disable lock when lid is closed. When you’ll wake up the computer, the lock screen won’t appear and so the problem won’t appear too.

    Howtos:

    1. Go to a terminal and write this (might use sudo if you are a normal user) :
      -> systemctl disable lightdm (we disable the auto launch on boot)
      -> pacman -Syu gdm (we install gdm (replace it with a login manager you like if you want)
      -> systemctl enable gdm (we enable gdm to auto-start at launch)
      Now, else you reboot the computer, else you write this :
      -> systemctl stop lightdm (we stop lightdm now)
      -> systemctl start gdm (we start gdm now)
      Be carreful, you might have to use ctrl+alt+f1 (or f2, or something else) to be able to enter the last command (systemctl start gdm).

    2. Check in “tweak tools” and “preferences”, I do think it’s in “power”, and untick all the cases linked to lock when lid is closed.

    Hope this help you and that my solution is correct 🙂

    The only limit to freedom is your mind.

  • Thanks! Uninstalling lightdm and installing gdm did the trick.

  • @jon.reeve Glad this help. You’re welcome Jon.

    The only limit to freedom is your mind.

lightdm115 suspend41 display40 suspension3 Posts 4Views 2263
Log in to reply
Bloom Email Optin Plugin

Looks like your connection to Antergos Community Forum was lost, please wait while we try to reconnect.