• Problems with Chromium


    I recorded a video which show a 4 minutes startup for chromium.
    What the hell is it?

    [https://drive.google.com/file/d/0B2_XIe25TBZFN0c1bDV3T3dKV2s/edit?usp=sharing][0]">[https://drive.google.com/file/d/0B2_XIe][1] … sp=sharing

    [0]: <a href=
    [1]: https://drive.google.com/file/d/0B2_XIe

    Don't forget to mark as [SOLVED], if your problem was solved!

  • I recorded a video which show a 4 minutes startup for chromium.
    What the hell is it?

    [https://drive.google.com/file/d/0B2_XIe25TBZFN0c1bDV3T3dKV2s/edit?usp=sharing][0]">[https://drive.google.com/file/d/0B2_XIe][1] … sp=sharing

    [0]: <a href=
    [1]: https://drive.google.com/file/d/0B2_XIe

    Don't forget to mark as [SOLVED], if your problem was solved!

  • I am a devoted Chromium user but I will still tell you that it is far from perfect. It tends to be a greedy memory HOG. The more memory you have the more it takes lol. Something to keep in mind is that each tab you have open in chromium is run as a separate instance of the browser with it’s own process. This means that having 6 tabs is the same as opening 6 chromium windows. Also, every extension you have enabled also is started on a separate process in the background. It’s always good to keep that in mind when deciding what extensions to leave enabled. Also, from past experience I do not pin any tabs or if I do I will unpin them before closing. If it continues to have any issue try cleaning out your entire cache. Also, you could try installing the current beta version and see if it works better. If you have not reviewed this article already I highly recommend it: [https://wiki.archlinux.org/index.php/Chromium_Tips_and_Tweaks][0]">[https://wiki.archlinux.org/index.php/Ch][1] … and_Tweaks

    Best Regards,

    [0]: <a href=
    [1]: https://wiki.archlinux.org/index.php/Ch

  • On Win8.1 with 7 tabs (3 pinned) the startup time is ~10s, with same extensions.

    Don't forget to mark as [SOLVED], if your problem was solved!

  • Yeah I can believe that. The Windows versions get the majority of the development manpower. Although that trend is on the decline as linux is getting more attention everyday.

    Best Regards,

  • [img:tpvqd5gb]http://www.favbrowser.com/wp-content/uploads/2009/02/windows-vs-linux.jpg[/img:tpvqd5gb]

    Don't forget to mark as [SOLVED], if your problem was solved!

  • I tried to install chromium-dev package but every times I got this error:

    ==\> Starting check()...  
    ==\> Entering fakeroot environment...  
    ==\> WARNING: To build need active [multilib] repository, if not , fail build  
    ==\> Starting package()...  
    -\> Adding PepperFlash  
    -\> Adding libpdf  
    ==\> Tidying install...  
    -\> Purging unwanted files...  
    -\> Compressing man and info pages...  
    ==\> Creating package "chromium-dev"...  
    -\> Generating .PKGINFO file...  
    -\> Adding install file...  
    -\> Generating .MTREE file...  
    -\> Compressing package...  
    xz: (stdout): Write error: No space left on device  
    bsdtar: Write error  
    ==\> ERROR: Failed to create package file.  
    ==\> ERROR: Makepkg was unable to build chromium-dev.  
    ==\> Restart building chromium-dev ? [y/N]  
    ==\> -------------------------------------  
    ==\>   
    
    

    The yaourt compiled ~ 1/1,5 hours the “re2” package with 100% cpu load.

    What is the re2 package?

    Don't forget to mark as [SOLVED], if your problem was solved!

  • I guess that if you still have an ntfs home that would be the problem. The compilation error could be that you need to asign more space to tmp

  • I cleaned the /tmp folder, and I am compiling the chromium-dev now.
    I am waiting for the result.

    Don't forget to mark as [SOLVED], if your problem was solved!

  • The compilation finished with the same error.
    Before the compilation I cleaned the /tmp folder
    Faidoc, the ntfs home partition is >300GB, and the / is ~30GB

    Don't forget to mark as [SOLVED], if your problem was solved!

  • Compiling Chromium is an intensive task for even the highest spec systems. Try your changing your /etc/makepkg.conf to make it use a dir that is not /tmp to build. /tmp is limited to half the amount of RAM on your system. So just create an empty dir on whichever disk is the fastest, set that in makepkg.conf, and then give it another try.

    Cheers!

  • Hi,

    Maybe you have your /tmp mounted on RAM? (tmpfs)

    See this: [https://wiki.archlinux.org/index.php/fstab#tmpfs][0]">[https://wiki.archlinux.org/index.php/fstab#tmpfs][1]

    Do you have any swap?

    [0]: <a href=
    [1]: https://wiki.archlinux.org/index.php/fstab#tmpfs

  • @“karasu”:335dnmjp said:

    Hi,

    Maybe you have your /tmp mounted on RAM? (tmpfs)

    See this: [https://wiki.archlinux.org/index.php/fstab#tmpfs][0]">[https://wiki.archlinux.org/index.php/fstab#tmpfs][1]

    Do you have any swap?[/quote:335dnmjp]

    Using tmpfs for /tmp is actually the default setting in Arch. It is no longer done via fstab, but rather systemd takes care of it. Under MOST circumstances it makes for a faster system.

    [0]: <a href=
    [1]: https://wiki.archlinux.org/index.php/fstab#tmpfs

  • Hi,

    Under MOST circumstances it makes for a faster system.

    I know, but when you’re trying to compile some big program you’ll face the problem I-sty is reporting

    I’m sorry I didn’t make myself clearer in the last post.

    Cheers!

  • Hi,
    Thanks lots.0.logs, i changed the makepkg’s directories and I compiled it and installed it.
    I removed 3 extensions from the dev version, but the startup time is also long
    When the chromium is starting the whole system is lagging
    I can’t change the musics in deadbeef while chromium is starting

    I have 6gb ram, and 12 gb swap partition, but I use default fstab.

    Don't forget to mark as [SOLVED], if your problem was solved!

  • 12GB swap?

    /etc/sysctl.d/99-sysctl.conf
    [code:1jofa00d]vm.swappiness=5[/code:1jofa00d]

    This can be set to any number between 0-100. Higher numbers tell the kernel to use swap more frequently. Lower numbers tell the kernel it shouldn’t use swap as much. With 6GB of RAM, a sane setting for you would be around 10. I have mine at 5, so you may want to try a few settings to see what works best. You will need to restart the system for any changes to take affect. Here is the link to some more information

    [https://wiki.archlinux.org/index.php/Swap#Swappiness][0]">[https://wiki.archlinux.org/index.php/Swap#Swappiness][1]

    Cheers!

    [0]: <a href=
    [1]: https://wiki.archlinux.org/index.php/Swap#Swappiness

  • This is my conf file:

    [[email protected] ~]$ cat /etc/sysctl.d/99-sysctl.conf   
    vm.dirty\_ratio=3  
    vm.dirty\_background\_ratio=2  
    vm.swappiness=10  
    vm.vfs\_cache\_pressure=50
    

    I will do several test with differents values.

    I changed the swappniess value from 10 to 0, (disabled swap ?)
    If the chromium service runs in the background the startup time is very good, <20s, but if doesn’t run then also very bad

    Don't forget to mark as [SOLVED], if your problem was solved!

  • Hi,

    Chromium stores its user configuration in ~/.config/chromium

    Just for testing, rename this directory and try to run chromium again (it will be as if running a clean install).

    If it runs faster it means that your configuration has been corrupted in some way.

    If not… I really don’t know what’s happening to you. Is Chromium the only program that is soooo slow? Also, have you tried Firefox? Its startup is slow too?

    Cheers!

  • @“karasu”:qrvivoty said:

    Hi,

    Chromium stores its user configuration in ~/.config/chromium

    Just for testing, rename this directory and try to run chromium again (it will be as if running a clean install).

    If it runs faster it means that your configuration has been corrupted in some way.

    If not… I really don’t know what’s happening to you. Is Chromium the only program that is soooo slow? Also, have you tried Firefox? Its startup is slow too?

    Cheers![/quote:qrvivoty]

    I tried with Opera and Firefox with the same pages (saved from the last session):
    facebook.com
    google.com
    usite.hu
    mail.yahoo.com

    Opera and FF are also start quickly.
    I tried again chrome with old .config/chromium folder but the same “error”.

    Don't forget to mark as [SOLVED], if your problem was solved!

  • @“I-sty”:68rro93v said:

    This is my conf file:

    [[email protected] ~]$ cat /etc/sysctl.d/99-sysctl.conf   
    > vm.dirty\_ratio=3  
    > vm.dirty\_background\_ratio=2  
    > vm.swappiness=10  
    > vm.vfs\_cache\_pressure=50
    

    I will do several test with differents values.

    I changed the swappniess value from 10 to 0, (disabled swap ?)
    If the chromium service runs in the background the startup time is very good, <20s, but if doesn’t run then also very bad

    I would advise to adjust those settings as they may be contributing to this problem. You don’t want your swap at zero because you run the risk of OOM (Out Of Memory) errors which is not good. These are the settings from my file, try them and see if there is a difference.

    vm.swappiness=5  
    > vm.vfs\_cache\_pressure=50  
    > vm.dirty\_ratio = 6  
    > vm.dirty\_background\_ratio = 3
    

    Also, I am curious if you see better performance from a clean user account. Create a new user on your system with:

    useradd -m -g users -G wheel -s /bin/bash newuser  
    > sudo -u newuser passwd
    

    Now, log in with the new user account and see if Chromium performs any differently. Please update us with result

Posts 33Views 6446
Log in to reply