• [SOLVED] Blank black screen after suspension/hibernation. Dell Latitude 7350

    Hi everyone,
    Actually I don’t know if this is the right place for my topic…please let me know.
    Well, I’ve installed Antergos GNOME on a Dell Latitude 7350, a hybrid laptop-debian.
    I have a problem whenever I suspend the session/hibernate both by closing the lid both by pushing rapidly the power button or not using the laptop for a while.
    Whenever I try to recover the session:

    1. pushing power button again or opening the lid is ineffective;
    2. I have to push power button many times (and even longer then usual) and then desktop appears for a fraction of second. Afterwards the screen to enter back the session pops up,
      I insert then my password and…the screen becomes completely blank black and there’s no way to recover the sesion.
    3. If I hold power button down for a long time then of course laptop reboots. Anyway at this time not only I can get into the session but, moreover, I don’t even enter a new session but the previous one as all the documents and windows I had opened before are still there.

    Any suggestion how to solve this issue?

    Thanks a lot,

  • HI @MatteP

    (1). First, the easy thing to check for is/are the power settings. What power settings do you have and does altering any of those change things? Have you checked the Arch Wiki on any of this? link text.
    There is a thread here in this forum that may or may not hold some relevance to your situation: link text
    Check (and read) the obvious first and if changing any of the power settings in that does not change things for the better then do the following as listed below:

    (2). What BIOS version do you have? Post the full output of sudo dmidecode | less to find out.
    Within your BIOS settings, do you have something like Memory Remapping Hole enabled or disabled?
    Post the full output of cat /etc/mkinitcpio.conf and uname -r
    Post the full output of cat /usr/share/X11/xorg.conf.d
    Post the full output of lspci We are looking for VGA and controller. Or do lspci | grep -e VGA -e 3D instead.
    And just in case, please post the output of cat /usr/share/X11/app-defaults/XScreenSaver I would like to see what there is inside this file from your system.
    I would also ask you to post the output of loginctl list-sessions to find out what login mgr/greeter you are using. This may or maynot be an issues. Probably not, but just in case.

    Do you have pm-utils installed? Do you have xf86-video installed?
    Are you able to get boot messages of your boot up via journalctl command?

  • Hi @Modisc ,
    Thanks again for your help!

    1)Well, is everything alright in the GRUB basic settings?
    Here the part containing resume filed:

    GRUB_CMDLINE_LINUX_DEFAULT="resume=UUID=13fd24ec-6820-4455-9e92-67bd26955a12 qu$

    and actually I’ve checked the UUID is the one given to my swap partition.
    The GRUB_CMDILINE_LINUX is empty, but I haven’t got if it has to be empty or not.

    1. If I type dmidecode | less the output is empty
      Here the output of cat /etc/mkinitcpio.conf
    cat /etc/mkinitcpio.conf
    # vim:set ft=sh
    # The following modules are loaded before any boot hooks are
    # run.  Advanced users may wish to specify all system modules
    # in this array.  For instance:
    #     MODULES="piix ide_disk reiserfs"
    # This setting includes any additional binaries a given user may
    # wish into the CPIO image.  This is run last, so it may be used to
    # override the actual binaries included by a given hook
    # BINARIES are dependency parsed, so you may safely ignore libraries
    # FILES
    # This setting is similar to BINARIES above, however, files are added
    # as-is and are not parsed in any way.  This is useful for config files.
    # HOOKS
    # This is the most important setting in this file.  The HOOKS control the
    # modules and scripts added to the image, and what happens at boot time.
    # Order is important, and it is recommended that you do not change the
    # order in which HOOKS are added.  Run 'mkinitcpio -H ' for
    # help on a given hook.
    # 'base' is _required_ unless you know precisely what you are doing.
    # 'udev' is _required_ in order to automatically load modules
    # 'filesystems' is _required_ unless you specify your fs modules in MODULES
    # Examples:
    ##   This setup specifies all modules in the MODULES setting above.
    ##   No raid, lvm2, or encrypted root is needed.
    #    HOOKS="base"
    ##   This setup will autodetect all modules for your system and should
    ##   work as a sane default
    #    HOOKS="base udev autodetect block filesystems"
    ##   This setup will generate a 'full' image which supports most systems.
    ##   No autodetection is done.
    #    HOOKS="base udev block filesystems"
    ##   This setup assembles a pata mdadm array with an encrypted root FS.
    ##   Note: See 'mkinitcpio -H mdadm' for more information on raid devices.
    #    HOOKS="base udev block mdadm encrypt filesystems"
    ##   This setup loads an lvm2 volume group on a usb device.
    #    HOOKS="base udev block lvm2 filesystems"
    ##   NOTE: If you have /usr on a separate partition, you MUST include the
    #    usr, fsck and shutdown hooks.
    HOOKS="base udev autodetect modconf block keyboard keymap resume filesystems fsck"
    # Use this to compress the initramfs image. By default, gzip compression
    # is used. Use 'cat' to create an uncompressed image.
    # Additional options for the compressor

    uname -r gives 4.1.11-1-lts

    With cat /usr/share/X11/xorg.conf.d I ahve this outcome

    cat /usr/share/X11/xorg.conf.d
    cat: /usr/share/X11/xorg.conf.d: It is a directory


    lspci | grep -e VGA -e 3D
    00:02.0 VGA compatible controller: Intel Corporation Broadwell-U Integrated Graphics (rev 09)


    cat /usr/share/X11/app-defaults/XScreenSaver
    !                              XScreenSaver
    !            a screen saver and locker for the X window system
    !                            by Jamie Zawinski
    !                              version 5.34
    !                              24-Oct-2015
    ! See "man xscreensaver" for more info.  The latest version is always
    ! available at http://www.jwz.org/xscreensaver/
    ! These resources, when placed in the system-wide app-defaults directory
    ! (e.g., /usr/lib/X11/app-defaults/XScreenSaver) will provide the default
    ! settings for new users.  However, if you have a ".xscreensaver" file in
    ! your home directory, the settings in that file take precedence.
    ! Don't hand this file to "xrdb" -- that isn't how app-defaults files work.
    ! Though app-defaults files have (mostly) the same syntax as your ~/.Xdefaults
    ! file, they are used differently, and if you run this file through xrdb,
    ! you will probably mess things up.
    #error Do not run app-defaults files through xrdb!
    #error That does not do what you might expect.
    #error Put this file in /usr/lib/X11/app-defaults/XScreenSaver instead.
    ! /* (xrdb prevention kludge: whole file)
    *mode:			random
    *timeout:		0:10:00
    *cycle:			0:10:00
    *lockTimeout:		0:00:00
    *passwdTimeout:		0:00:30
    *dpmsEnabled:		False
    *dpmsQuickoffEnabled:	False
    *dpmsStandby:		2:00:00
    *dpmsSuspend:		2:00:00
    *dpmsOff:		4:00:00
    *grabDesktopImages:	True
    *grabVideoFrames:	False
    *chooseRandomImages:	False
    ! This can be a local directory name, or the URL of an RSS or Atom feed.
    *nice:			10
    *memoryLimit:		0
    *lock:			False
    *verbose:		False
    *timestamp:		True
    *fade:			True
    *unfade:		False
    *fadeSeconds:		0:00:03
    *fadeTicks:		20
    *splash:		True
    *splashDuration:	0:00:05
    *visualID:		default
    *captureStderr: 	True
    *ignoreUninstalledPrograms: False
    *authWarningSlack:	20
    *textMode:		file
    *textLiteral:		XScreenSaver
    *textProgram:		fortune
    *textURL:		https://en.wikipedia.org/w/index.php?title=Special:NewPages&feed=rss
    *overlayTextForeground:	#FFFF00
    *overlayTextBackground:	#000000
    *overlayStderr:		True
    *font:			*-medium-r-*-140-*-m-*
    ! The default is to use these extensions if available (as noted.)
    *sgiSaverExtension:	True
    *xidleExtension:	True
    *procInterrupts:	True
    ! Turning this on makes pointerHysteresis not work.
    *xinputExtensionDev:	False
    ! Set this to True if you are experiencing longstanding XFree86 bug #421
    ! (xscreensaver not covering the whole screen)
    GetViewPortIsFullOfLies: False
    ! This is what the "Demo" button on the splash screen runs (/bin/sh syntax.)
    *demoCommand: xscreensaver-demo
    ! This is what the "Prefs" button on the splash screen runs (/bin/sh syntax.)
    *prefsCommand: xscreensaver-demo -prefs
    ! This is the URL loaded by the "Help" button on the splash screen,
    ! and by the "Documentation" menu item in xscreensaver-demo.
    *helpURL: http://www.jwz.org/xscreensaver/man.html
    ! loadURL       -- how the "Help" buttons load the helpURL (/bin/sh syntax.)
    ! manualCommand -- how the "Documentation" buttons display man pages.
    ! And there are so very many options to choose from!
    !   Gnome 2.4, 2.6: (yelp can't display man pages, as of 2.6.3)
    !	*loadURL: gnome-open '%s'
    !	*manualCommand: gnome-terminal --title '%s manual' \
    !			--command '/bin/sh -c "man %s; read foo"'
    !   Gnome 2.2:
    !	*loadURL: gnome-url-show '%s'
    !	*manualCommand: gnome-terminal --title '%s manual' \
    !			--command '/bin/sh -c "man %s; read foo"'
    !   Gnome 1.4:
    !	*loadURL: gnome-moz-remote --newwin '%s'
    !	*manualCommand: gnome-help-browser 'man:%s'
    !   non-Gnome systems:
    *loadURL: firefox '%s' || mozilla '%s' || netscape '%s'
    *manualCommand: xterm -sb -fg black -bg gray75 -T '%s manual' \
    		    -e /bin/sh -c 'man "%s" ; read foo'
    ! The format used for printing the date and time in the password dialog box
    ! (see the strftime(3) manual page for details.)
    *dateFormat:		%d-%b-%y (%a); %I:%M %p
    ! To show the time only:
    ! *dateFormat:		%I:%M %p
    ! For 24 hour time:
    ! *dateFormat:		%H:%M
    ! This command is executed by the "New Login" button on the lock dialog.
    ! (That button does not appear on the dialog if this program does not exist.)
    ! For Gnome: probably "gdmflexiserver -ls".  KDE, probably "kdmctl reserve".
    ! Or maybe yet another wheel-reinvention, "lxdm -c USER_SWITCH".
    ! Oh wait, this wheel just keeps getting better: "dm-tool switch-to-greeter".
    *newLoginCommand:	gdmflexiserver -ls
    ! Turning on "installColormap" on 8-bit systems interacts erratically with
    ! certain jurassic window managers.  If your screen turns some color other
    ! than black, the window manager is buggy, and you need to set this resource
    ! to false.  Or switch WMs.  Or join the 21st century and get a 24-bit
    ! graphics card.
    *installColormap:	True
    ! This is the list of installed screen saver modes.  See "man xscreensaver"
    ! for the syntax used here.
    ! If you want to disable a screensaver, DO NOT remove it from this list:
    ! instead, mark it as inactive by placing a "-" at the beginning of the line.
    ! You can use the `xscreensaver-demo' program to edit the current list of
    ! screen savers interactively.
    *programs:								      \
    				maze -root				    \n\
    				electricsheep --root 1			    \n\
      GL: 				superquadrics -root			    \n\
    				attraction -root			    \n\
    				blitspin -root				    \n\
    				greynetic -root				    \n\
    				helix -root				    \n\
    				hopalong -root				    \n\
    				imsmap -root				    \n\
    -				noseguy -root				    \n\
    -				pyro -root				    \n\
    				qix -root				    \n\
    -				rocks -root				    \n\
    				rorschach -root				    \n\
    				decayscreen -root			    \n\
    				flame -root				    \n\
    				halo -root				    \n\
    				slidescreen -root			    \n\
    				pedal -root				    \n\
    				bouboule -root				    \n\
    -				braid -root				    \n\
    				coral -root				    \n\
    				deco -root				    \n\
    				drift -root				    \n\
    -				fadeplot -root				    \n\
    				galaxy -root				    \n\
    				goop -root				    \n\
    				grav -root				    \n\
    				ifs -root				    \n\
      GL: 				jigsaw -root				    \n\
    				julia -root				    \n\
    -				kaleidescope -root			    \n\
      GL: 				moebius -root				    \n\
    				moire -root				    \n\
      GL: 				morph3d -root				    \n\
    				mountain -root				    \n\
    				munch -root				    \n\
    				penrose -root				    \n\
      GL: 				pipes -root				    \n\
    				rd-bomb -root				    \n\
      GL: 				rubik -root				    \n\
    -				sierpinski -root			    \n\
    				slip -root				    \n\
      GL: 				sproingies -root			    \n\
    				starfish -root				    \n\
    				strange -root				    \n\
    				swirl -root				    \n\
    				triangle -root				    \n\
    				xjack -root				    \n\
    				xlyap -root				    \n\
      GL: 				atlantis -root				    \n\
    				bsod -root				    \n\
      GL: 				bubble3d -root				    \n\
      GL: 				cage -root				    \n\
    -				crystal -root				    \n\
    				cynosure -root				    \n\
    				discrete -root				    \n\
    				distort -root				    \n\
    				epicycle -root				    \n\
    				flow -root				    \n\
      GL: 				glplanet -root				    \n\
    				interference -root			    \n\
    				kumppa -root				    \n\
      GL: 				lament -root				    \n\
    				moire2 -root				    \n\
      GL: 				sonar -root				    \n\
      GL: 				stairs -root				    \n\
    				truchet -root				    \n\
    -				vidwhacker -root			    \n\
    				blaster -root				    \n\
    				bumps -root				    \n\
    				ccurve -root				    \n\
    				compass -root				    \n\
    				deluxe -root				    \n\
    -				demon -root				    \n\
    - GL: 				extrusion -root				    \n\
    -				loop -root				    \n\
    				penetrate -root				    \n\
    				petri -root				    \n\
    				phosphor -root				    \n\
      GL: 				pulsar -root				    \n\
    				ripples -root				    \n\
    				shadebobs -root				    \n\
      GL: 				sierpinski3d -root			    \n\
    				spotlight -root				    \n\
    				squiral -root				    \n\
    				wander -root				    \n\
    -				webcollage -root			    \n\
    				xflame -root				    \n\
    				xmatrix -root				    \n\
      GL: 				gflux -root				    \n\
    -				nerverot -root				    \n\
    				xrayswarm -root				    \n\
    				xspirograph -root			    \n\
      GL: 				circuit -root				    \n\
      GL: 				dangerball -root			    \n\
    - GL: 				dnalogo -root				    \n\
      GL: 				engine -root				    \n\
      GL: 				flipscreen3d -root			    \n\
      GL: 				gltext -root				    \n\
      GL: 				menger -root				    \n\
      GL: 				molecule -root				    \n\
    				rotzoomer -root				    \n\
    				speedmine -root				    \n\
      GL: 				starwars -root				    \n\
      GL: 				stonerview -root			    \n\
    				vermiculate -root			    \n\
    				whirlwindwarp -root			    \n\
    				zoom -root				    \n\
    				anemone -root				    \n\
    				apollonian -root			    \n\
      GL: 				boxed -root				    \n\
      GL: 				cubenetic -root				    \n\
      GL: 				endgame -root				    \n\
    				euler2d -root				    \n\
    				fluidballs -root			    \n\
      GL: 				flurry -root				    \n\
    - GL: 				glblur -root				    \n\
      GL: 				glsnake -root				    \n\
    				halftone -root				    \n\
      GL: 				juggler3d -root				    \n\
      GL: 				lavalite -root				    \n\
    -				polyominoes -root			    \n\
      GL: 				queens -root				    \n\
    - GL: 				sballs -root				    \n\
      GL: 				spheremonics -root			    \n\
    -				thornbird -root				    \n\
    				twang -root				    \n\
    - GL: 				antspotlight -root			    \n\
    				apple2 -root				    \n\
      GL: 				atunnel -root				    \n\
    				barcode -root				    \n\
      GL: 				blinkbox -root				    \n\
      GL: 				blocktube -root				    \n\
      GL: 				bouncingcow -root			    \n\
    				cloudlife -root				    \n\
      GL: 				cubestorm -root				    \n\
    				eruption -root				    \n\
      GL: 				flipflop -root				    \n\
      GL: 				flyingtoasters -root			    \n\
    				fontglide -root				    \n\
      GL: 				gleidescope -root			    \n\
      GL: 				glknots -root				    \n\
      GL: 				glmatrix -root				    \n\
    - GL: 				glslideshow -root			    \n\
      GL: 				hypertorus -root			    \n\
    - GL: 				jigglypuff -root			    \n\
    				metaballs -root				    \n\
      GL: 				mirrorblob -root			    \n\
    				piecewise -root				    \n\
      GL: 				polytopes -root				    \n\
    				pong -root				    \n\
    				popsquares -root			    \n\
      GL: 				surfaces -root				    \n\
    				xanalogtv -root				    \n\
    				abstractile -root			    \n\
    				anemotaxis -root			    \n\
    - GL: 				antinspect -root			    \n\
    				fireworkx -root				    \n\
    				fuzzyflakes -root			    \n\
    				interaggregate -root			    \n\
    				intermomentary -root			    \n\
    				memscroller -root			    \n\
      GL: 				noof -root				    \n\
    				pacman -root				    \n\
      GL: 				pinion -root				    \n\
      GL: 				polyhedra -root				    \n\
    - GL: 				providence -root			    \n\
    				substrate -root				    \n\
    				wormhole -root				    \n\
    - GL: 				antmaze -root				    \n\
      GL: 				boing -root				    \n\
    				boxfit -root				    \n\
      GL: 				carousel -root				    \n\
    				celtic -root				    \n\
      GL: 				crackberg -root				    \n\
      GL: 				cube21 -root				    \n\
    				fiberlamp -root				    \n\
      GL: 				fliptext -root				    \n\
      GL: 				glhanoi -root				    \n\
      GL: 				tangram -root				    \n\
      GL: 				timetunnel -root			    \n\
      GL: 				glschool -root				    \n\
      GL: 				topblock -root				    \n\
      GL: 				cubicgrid -root				    \n\
    				cwaves -root				    \n\
      GL: 				gears -root				    \n\
      GL: 				glcells -root				    \n\
      GL: 				lockward -root				    \n\
    				m6502 -root				    \n\
      GL: 				moebiusgears -root			    \n\
      GL: 				voronoi -root				    \n\
      GL: 				hypnowheel -root			    \n\
      GL: 				klein -root				    \n\
    -				lcdscrub -root				    \n\
      GL: 				photopile -root				    \n\
      GL: 				skytentacles -root			    \n\
      GL: 				rubikblocks -root			    \n\
      GL: 				companioncube -root			    \n\
      GL: 				hilbert -root				    \n\
      GL: 				tronbit -root				    \n\
      GL: 				geodesic -root				    \n\
    				hexadrop -root				    \n\
      GL: 				kaleidocycle -root			    \n\
      GL: 				quasicrystal -root			    \n\
      GL: 				unknownpleasures -root			    \n\
    				binaryring -root			    \n\
      GL: 				cityflow -root				    \n\
      GL: 				geodesicgears -root			    \n\
      GL: 				projectiveplane -root			    \n\
      GL: 				romanboy -root				    \n\
    				tessellimage -root			    \n\
      GL: 				winduprobot -root			    \n\
      GL: 				splitflap -root				    \n\
    				testx11 -root				    \n
    !      You probably don't want to change anything after this point.
    XScreenSaver.pointerPollTime:		0:00:05
    XScreenSaver.pointerHysteresis:		10
    XScreenSaver.initialDelay:		0:00:00
    XScreenSaver.windowCreationTimeout:	0:00:30
    XScreenSaver.bourneShell:		/bin/sh
    ! Resources for the password and splash-screen dialog boxes of
    ! the "xscreensaver" daemon.
    *Dialog.headingFont:		*-helvetica-bold-r-*-*-*-180-*-*-*-iso8859-1
    *Dialog.bodyFont:		*-helvetica-bold-r-*-*-*-140-*-*-*-iso8859-1
    *Dialog.labelFont:		*-helvetica-bold-r-*-*-*-140-*-*-*-iso8859-1
    *Dialog.unameFont:		*-helvetica-bold-r-*-*-*-120-*-*-*-iso8859-1
    *Dialog.buttonFont:		*-helvetica-bold-r-*-*-*-140-*-*-*-iso8859-1
    *Dialog.dateFont:		*-helvetica-medium-r-*-*-*-80-*-*-*-iso8859-1
    ! Helvetica asterisks look terrible.
    !*passwd.passwdFont:		*-helvetica-medium-r-*-*-*-140-*-*-*-iso8859-1
    *passwd.passwdFont:		*-courier-medium-r-*-*-*-140-*-*-*-iso8859-1
    *Dialog.foreground:		#000000
    *Dialog.background:		#E6E6E6
    *Dialog.Button.foreground:	#000000
    *Dialog.Button.background:	#F5F5F5
    !*Dialog.Button.pointBackground: #EAEAEA
    !*Dialog.Button.clickBackground: #C3C3C3
    *Dialog.text.foreground:	#000000
    *Dialog.text.background:	#FFFFFF
    *passwd.thermometer.foreground:	#4464AC
    *passwd.thermometer.background:	#FFFFFF
    *Dialog.topShadowColor:		#FFFFFF
    *Dialog.bottomShadowColor:	#CECECE
    *Dialog.logo.width:		210
    *Dialog.logo.height:		210
    *Dialog.internalBorderWidth:	24
    *Dialog.borderWidth:		1
    *Dialog.shadowThickness:	2
    *passwd.heading.label:		XScreenSaver %s
    *passwd.body.label:		This screen is locked.
    *passwd.unlock.label:		OK
    *passwd.login.label:		New Login
    *passwd.user.label:		Username:
    *passwd.thermometer.width:	8
    *passwd.asterisks:              True
    *passwd.uname:                  True
    *splash.heading.label:		XScreenSaver %s
    *splash.body.label:		Copyright \251 1991-2015 by
    *splash.body2.label:		Jamie Zawinski 
    *splash.demo.label:		Settings
    *splash.help.label:		Help
    ! Pretty names for the hacks that have unusual capitalization.
    *hacks.antinspect.name:     AntInspect
    *hacks.antmaze.name:        AntMaze
    *hacks.antspotlight.name:   AntSpotlight
    *hacks.binaryring.name:     BinaryRing
    *hacks.blinkbox.name:       BlinkBox
    *hacks.blitspin.name:       BlitSpin
    *hacks.blocktube.name:      BlockTube
    *hacks.bouncingcow.name:    BouncingCow
    *hacks.boxfit.name:         BoxFit
    *hacks.bsod.name:           BSOD
    *hacks.bubble3d.name:       Bubble3D
    *hacks.ccurve.name:         CCurve
    *hacks.cloudlife.name:      CloudLife
    *hacks.companioncube.name:  CompanionCube
    *hacks.cubestorm.name:      CubeStorm
    *hacks.cubicgrid.name:      CubicGrid
    *hacks.cwaves.name:         CWaves
    *hacks.dangerball.name:     DangerBall
    *hacks.decayscreen.name:    DecayScreen
    *hacks.dnalogo.name:        DNA Logo
    *hacks.euler2d.name:        Euler2D
    *hacks.fadeplot.name:       FadePlot
    *hacks.flipflop.name:       FlipFlop
    *hacks.flipscreen3d.name:   FlipScreen3D
    *hacks.fliptext.name:       FlipText
    *hacks.fluidballs.name:     FluidBalls
    *hacks.flyingtoasters.name: FlyingToasters
    *hacks.fontglide.name:      FontGlide
    *hacks.fuzzyflakes.name:    FuzzyFlakes
    *hacks.geodesicgears.name:  GeodesicGears
    *hacks.gflux.name:          GFlux
    *hacks.gleidescope.name:    Gleidescope
    *hacks.glforestfire.name:   GLForestFire
    *hacks.hyperball.name:      HyperBall
    *hacks.hypercube.name:      HyperCube
    *hacks.ifs.name:            IFS
    *hacks.imsmap.name:         IMSMap
    *hacks.jigglypuff.name:     JigglyPuff
    *hacks.juggler3d.name:      Juggler3D
    *hacks.lcdscrub.name:       LCDscrub
    *hacks.lmorph.name:         LMorph
    *hacks.m6502.name:          m6502
    *hacks.memscroller.name:    MemScroller
    *hacks.metaballs.name:      MetaBalls
    *hacks.mirrorblob.name:     MirrorBlob
    *hacks.moebiusgears.name:   MoebiusGears
    *hacks.morph3d.name:        Morph3D
    *hacks.nerverot.name:       NerveRot
    *hacks.noseguy.name:        NoseGuy
    *hacks.popsquares.name:     PopSquares
    *hacks.quasicrystal.name:   QuasiCrystal
    *hacks.rd-bomb.name:        RDbomb
    *hacks.rdbomb.name:         RDbomb
    *hacks.romanboy.name:       RomanBoy
    *hacks.rotzoomer.name:      RotZoomer
    *hacks.rubikblocks.name:    RubikBlocks
    *hacks.sballs.name:         SBalls
    *hacks.shadebobs.name:      ShadeBobs
    *hacks.sierpinski3d.name:   Sierpinski3D
    *hacks.skytentacles.name:   SkyTentacles
    *hacks.slidescreen.name:    SlideScreen
    *hacks.speedmine.name:      SpeedMine
    *hacks.splitflap.name:      SplitFlap
    *hacks.starwars.name:       StarWars
    *hacks.stonerview.name:     StonerView
    *hacks.t3d.name:            T3D
    *hacks.testx11.name:        TestX11
    *hacks.timetunnel.name:     TimeTunnel
    *hacks.topblock.name:       TopBlock
    *hacks.tronbit.name:        TronBit
    *hacks.vidwhacker.name:     VidWhacker
    *hacks.webcollage.name:     WebCollage
    *hacks.whirlwindwarp.name:  WhirlWindWarp
    *hacks.winduprobot.name:    WindupRobot
    *hacks.xanalogtv.name:      XAnalogTV
    *hacks.xrayswarm.name:      XRaySwarm
    ! obsolete, but still used by xscreensaver-demo-Xm.
    *hacks.documentation.isInstalled: True
    ! (xrdb prevention kludge: whole file) */

    And finally

    loginctl list-sessions
       SESSION        UID USER             SEAT            
            c2       1000 matteo           seat0           
    1 sessions listed.
    [[email protected] power]# loginctl list-sessions
       SESSION        UID USER             SEAT            
            c2       1000 matteo           seat0           
    1 sessions listed.

    No. Not pm-utils nor xf86-video are installed.
    Yes, if I type journalctl I get a long list of messages.


  • HI.
    Ok, so a couple of things are trying to edit your file in etc/default/grub
    GRUB_CMDLINE_LINUX_DEFAULT="resume=UUID=13fd24ec6820-4455-9e92-67bd26955a12 qu$
    Then reboot.
    If that does not work, change to GRUB_CMDLINE_LINUX_DEFAULT='' ''
    Then reboot
    We will try that first.
    We will work on anything other afterwards.
    After you have changed your grub file as mentioned above, do sudo grub-mkconfig -o /boot/grub/grub.cfg
    Then reboot
    I think that the last one might actually be best.

    The other thing is that you have to use sudo for the demidecode command posted earlier. You say you did not get any results because you** may** not have done it via root privilages. I posted the command above for you. Please do as I posted to provide you directions.

    (1). Did you check your BIOS settings within your computer and try to check and/or change as per the question I asked you earlier? You didn’t say. Please post your answer here.
    (2). Did you check your power mgmt settings within your OS and try to see if any of those obvious settings changed anything? You didn’t say. Please post your answer here.
    (3). I may have inadvertantly given you the wrong loginctl command. As I am on a different OS while typing this post for you (therefore loginctl won’t work for me at this moment). I just want to find out what greeter you are using. Unless you already know. Please post your answer here. It may or may not be an issue. I remember reading something on the Arch Forums about a problem similar to this and the report was that the fault was the greeter and it’s settings. Hence the request to post answer for that.
    (4). Also, since you have an Intel graphics, and you say you don’t have the Intel package from the repositories, you might want/need to install as per the instructions given at the Arch Wiki link.
    link text

  • Hi @Modisc

    1. I’ve tried all three solutions you suggested, but the issue is still there. Should I change back GRUB configuration setting
      GRUB_CMDLINE_LINUX_DEFAULT="resume=UUID=13fd24ec6820-4455-9e92-67bd26955a12 quiet"?

    2. Actually my power manager doesn’t allow to choose many option, but only if suspending or not suspending when the lid is closed.

    3. Sorry, I believed BIOS settings would have been modified/tested with the commands you gave afterwards. Anyway, indeed I also do not know what I should check in the BIOS settings, may you tell me please? How can I check if Memory Remapping Hole is enabled or not?

    4. I usually work as su instead of typing sudo, so I had root privileges when I gave demidecode command. I tried both dmidecode (as in the first reply of yours) and demidecode as in the last one but, in both cases, I get the error bash: demidecode: command not found.

    5. I carefully read (without unfortunately understanding everything) both Arch Wiki link text both the previous topic link text. As I wrote in the previos post I already checked the correctness of swap partition that used to be provided to resume field in GRUB configurations. I’ve checked systemd is installed but I haven’t understood what I should do with that. Should I use terminal command to suspend or hibernate instead of pushing power button?
      As suggested in the previous topic I’ve checked HOOKS line in /etc/mkinitcpio.conf and this is my (untouched) HOOK line:
      HOOKS="base udev autodetect modconf block keyboard keymap resume filesystems fsck".
      Exactly as the user there, resume does not appear, should I add it?

    6. I already posted loginctl output, anyway here it is again:

       SESSION        UID USER             SEAT            
            c2       1000 matteo           seat0           
    1 sessions listed.

    No problem! 😊

    1. Ok. I’ll install them then.

    Thanks again for your patience!


  • @Modisc
    P.S. I’ve just checked BIOS power management options (during boot phase) but the most of them seems to deal with battery and none of them appears to be useful for my problem.
    Here the list of availble option tabs:

    • AC Behaviour

    • Auto On Time

    • Peak Shift

    • Advanced Battery Charge Configuration

    • Primary Battery Charge Configuration

    • Battery Slice Charge Configuration

  • Hi @MatteP
    Sorry for the late reply :)
    (1). Ok, so if there was no change or any other errors on boot from modifying/altering the Grub file, you can revert it back to it’s original state.
    (2). If your pwr management does not allow you to change things, that is fine then. It’s all good. At least you have checked.
    (3). Sorry, I did not know that you were working in su mode. If you do not have the dmidecode command installed, no worries. It was only to have a quick look at some information on your BIOS. No need to install it either. If you do not have anything like Memory Remapping Hole anywhere within your BIOS, no worries there either. Again, I only brought it up because I had read about it on another forum. So no worries there either.
    (4). You do not need to use any terminal command to suspend or resume instead of the power button.
    I do not think that you should have to.
    (5) with the pm-utils it is supposed to work around with some drivers that might not recognize or work correctly with the suspend. If you have installed them, have they done anything good on this issue? Also, from your output of HOOKS="base udev autodetect modconf block keyboard keymap resume filesystems fsck". you already have resume listed there, so it is good. Because you have Intel, installing xf86-video-intel should do some positive.

  • @Modisc
    Sorry for MY late reply!
    And sorry for my oversight, too: I didn’t see that resume was actually there!
    I’ve installed both pm-utils and xf86-video-intel but the issue is tsill present.



  • Hi @MatteP
    You may need to configure the pm-utils for your system. pm-utils
    SUSPEND_MODULES="uhci_hd button ehci_hd iwlwifi"

    From the Arch Wiki:

    pm-utils is a set of shell scripts that encapsulate the backend's suspend/hibernate functionality. It comes with a set of pre- and post-suspend tweaks and various hooks to customize the process.

    But if you want things like suspend to occur when you are closing your laptop’s lid, for example, don’t forget about acpid acpid

    From the Arch Wiki:

    To configure invoking pm-suspend automatically on power events like laptop lid close, please refer to Acpid.
    acpid comes with a number of predefined actions for triggered events, such as what should happen when you press the Power button on your machine

    Just something to consider. Please let us know.

  • Hi everyone,
    I was finally able to solve this issue following this post:


  • Hi @MatteP
    Good to hear. :)

  • Talk about late awakenings… ;)

blank screen12 black screen11 hibernation9 suspension3 Posts 12Views 12560
Log in to reply
Bloom Email Optin Plugin

Looks like your connection to Antergos Community Forum was lost, please wait while we try to reconnect.