• {SOLVED} Black screen during boot after last updates


    {SOLVED) My, my, lucky me!:smile: Once more with a black screen during boot proccess. It all happened after installing the last bunch of updates, 88 MB, including kernel 4;2.4-1, to one of my machines (the other one was not affected).
    It starts booting, after Antergos messages about stops and blocks it becomes black and for a short time there is still disc activity. It then stays there inactive with the black screen.
    I tried to do this
    https://forum.antergos.com/topic/2905/booting-stops-after-last-updates-systemd-computer-completely-irresponsive/9
    since it worked the previous time, but no luck. It stopped booting in exactly the same way as before.
    Trying fallback gives the same results, too.
    Any ideas to resolved, very much appreciated…:thumbsup:

    1.Antergos Linux KDE plasma / Gnome 2.Ubuntu 17.10 64bit Unity
    Intel Core2 Duo CPU P8400 2.26GHz‖ RAM 3908 MiB ‖ Dell Inc. 0F328M - Dell Inc. Latitude E6500
    Intel Mobile 4 Series Chipset Integrated Graphics [8086:2a42] {i915

  • First, do lspci -v | less to get a bigger picture of what we are dealing with here. Post the VGA portion as well as any 3D controller. output.
    Are the fans out of control when it boots into the black screen? I take it you are not able to get to your DE. Is that correct? Are there any messages, such as a PID message saying PID (1)?
    Can you do this at least

    Ctrl+S to Stop
    Ctrl+Q to Resume
    

    Are you able to read messages?
    Able to get dmesg | less ?
    Can also try nomodeset
    If that does not work, would you be interested in lts-linux ? It is version 4.1.12-1 if you are interested. More information here to read if you feel that current updated/upgraded kernel is the culprit and don’t want to deal with this. link text Other kernels listed there too.

    From the Arch Wiki:

    The linux-lts package is an alternative Arch kernel package, and is available in the core repository. This particular kernel version has long-term support (LTS) from upstream, including security fixes and some feature backports. It is useful if you prefer the stability of less-frequent kernel updates or if you want a fallback kernel in case a new kernel version causes problems
    

    You must have the 2 necessary files installed to make LTS work for you. vmlinuz-linux-lts and initramfs-linux-lts.img

    Download " antergos-wallpapers-extra " and enjoy community sponsored wallpapers.

    Use the "Linux Beginner Search Engine"

    https://cse.google.com/cse/home?cx=017607476515012185699:b_owgx6xyi0

  • Thanks @Modisc for your immediate reply. My question is how am I supposed to try out all that stuff you suggested. My system is tottally irresponsive. It starts booting, I get these messages
    starting version 227
    Antergos : recovering journal
    Antergos: clean 365847/48,90624 files, 6076571/19540824 blocks,

    and then ithe screen goes black. I can see some diisc activity for a while and then boom! Nothing!. It stays completely black forever till I hardshutdown it…
    I can not even reach a tty screen.
    I will do my search myself in the meantime so I get an idea of what can be done…

    1.Antergos Linux KDE plasma / Gnome 2.Ubuntu 17.10 64bit Unity
    Intel Core2 Duo CPU P8400 2.26GHz‖ RAM 3908 MiB ‖ Dell Inc. 0F328M - Dell Inc. Latitude E6500
    Intel Mobile 4 Series Chipset Integrated Graphics [8086:2a42] {i915

  • chroot ? Might need to do that to fix system. Sorry, didn’t fully understand that you were not able to get to desktop.

    Download " antergos-wallpapers-extra " and enjoy community sponsored wallpapers.

    Use the "Linux Beginner Search Engine"

    https://cse.google.com/cse/home?cx=017607476515012185699:b_owgx6xyi0

  • I wiill give it a try when I have some time, later on. Luckily the issue is on my second laptop which I use fo torturing and experimentation. :laughing:
    In the mean time, I installed a fresh Openbox, but no luck with this, either, @megaman : :broken_heart: .
    Same (shame) issue there, too…

    1.Antergos Linux KDE plasma / Gnome 2.Ubuntu 17.10 64bit Unity
    Intel Core2 Duo CPU P8400 2.26GHz‖ RAM 3908 MiB ‖ Dell Inc. 0F328M - Dell Inc. Latitude E6500
    Intel Mobile 4 Series Chipset Integrated Graphics [8086:2a42] {i915

  • @anarch on a fresh install you still get a blank screen? new kernel maybe doesnt like something about your hardware.

  • Well, after trying to mount it and add the LTS kernel with no success to boot and after reintalling with the same bad result, the answer was to enter the nomodeset parameter.
    The gain was the openbox flavor I now have on my secondary computer. Strange enough as it was my first Antergos host computer two years ago, with no installation problems at all.
    A word of advice, before i make the change permament…is there some other fix or something else I should take care of?

    1.Antergos Linux KDE plasma / Gnome 2.Ubuntu 17.10 64bit Unity
    Intel Core2 Duo CPU P8400 2.26GHz‖ RAM 3908 MiB ‖ Dell Inc. 0F328M - Dell Inc. Latitude E6500
    Intel Mobile 4 Series Chipset Integrated Graphics [8086:2a42] {i915

  • Hi,

    This could be caused by a regression on your graphics card driver.

    Which chip do you have?

  • I read somewhere that AMD staf was creating problems with kernel 4.2. It also affected my Ubuntu installation (takes ages in splash screen before it finally boots up).
    So, I considered it would be wise to wait for an updated kernel to see if it will get fixed. I m glad the last LTS kernel did the job. SOLVED!:thumbsup:

    1.Antergos Linux KDE plasma / Gnome 2.Ubuntu 17.10 64bit Unity
    Intel Core2 Duo CPU P8400 2.26GHz‖ RAM 3908 MiB ‖ Dell Inc. 0F328M - Dell Inc. Latitude E6500
    Intel Mobile 4 Series Chipset Integrated Graphics [8086:2a42] {i915

Posts 9Views 13337
Log in to reply