• how to recognize firefox bookmarks in krunner


    my firefox bookmarks aren’t shown in krunner anymore. I use plasma 5.
    Default browser is firefox, in krunner-config tick mark is set for bookmarks.
    How to fix that? Is there a way to “reload” (krunner)-search entries?

  • @atergo Please, share the output of

    cat /usr/share/kservices5/plasma-runner-bookmarks.desktop | grep Enabled
    
  • X-KDE-PluginInfo-EnabledByDefault=true

  • @atergo said:

    X-KDE-PluginInfo-EnabledByDefault=true

    Hmm. The result is different from what I was expecting.

    X-KDE-PluginInfo-EnabledByDefault settings are:

    • true = includes Firefox bookmarks in KRunner
    • false = excludes Firefox bookmarks from KRunner

    So I was expecting that it was set to false. If you don’t see Firefox bookmarks in KRunner.

    It works the same way in both old Kde 4 and in newer Plasma 5. Though I’m running Plasma in native Arch, not in Antergos.

    Re-tested two settings again, right now. Work as expected:

    • true = bookmarks are included
    • false = bookmarks are excluded

    I’m sorry for not being able to help you further.

  • @atergo Wait a moment. I have no idea how did you install Plasma in Antergos, but if you have started from Kde 4, then KRunner behaviour could still be controlled by the old setting.

    In Kde 4 the file is found in

    /usr/share/kde4/services/plasma-runner-bookmarks.desktop
    

    Try to change the setting here, if you have this file.

    I’m sorry if this is a stupid thing. Installing vanilla Arch with Plasma is much easier for me, than adding it to Antergos.

  • I install antergos base, then plasma. I haven’t kde4 plasma-runner.

    ok. thank you anyway.

    I am not able to preset krunner, too. Only possible to change single entries.

    Maybe krunner “forgot” the path to firefox bookmarks?
    Any idea?

  • @atergo said:

    …I am not able to preset krunner, too. Only possible to change single entries…

    There’s no GUI to change this setting. Two files are simply edited by hand, in Kate with root privileges.

  • System-setting -> search -> plasma-search ?!

    or: alt+f2 then the left icon to change entries?

  • @atergo That does not change X-KDE-PluginInfo-EnabledByDefault value.

    You may set, unset, check, uncheck that setting in GUI, X-KDE-PluginInfo-EnabledByDefault doesn’t vary.

    Changing it by hand is the only way that I’m aware of. And it works, at least in plain Arch.

  • yeah, i have checked /usr/share/kservices5/plasma-runner-bookmarks.desktop with kate. setting was true.

    I made new install antergos/base/plasma 5.
    Don’t like something runs wrong. Thank you for help.

Posts 10Views 1422
Log in to reply