• No Antergos Grub


    Hi All
    Just tried installing another distro on a separate SSD (Kubuntu 15.10) I uplugged my Antergos SSD installation. Now I cant boot into Antergos there is no grub after plugging the SSD back in
    My Bios used to say Antergos Grub now that has gone and says windows bootloader and a sepaerate partition that does not boot … I have update grub on my Kubuntu install to get back to Antergos .Would rather have my Antergos boot fixed

  • Hi,

    I uplugged my Antergos SSD installation

    That was not necessary. In fact, that’s why Kubuntu Grub didn’t see Antergos installation.

    You have to tell your BIOS with which grub you want to boot, Kubuntu’s one or Antergos.

    Then, after booting the distro you’re using the grub from, you have to update your grub to add the boot entry of the other distro.

    Cheers!

  • @karasu said:

    Hi,

    I uplugged my Antergos SSD installation

    That was not necessary. In fact, that’s why Kubuntu Grub didn’t see Antergos installation.

    You have to tell your BIOS with which grub you want to boot, Kubuntu’s one or Antergos.

    Then, after booting the distro you’re using the grub from, you have to update your grub to add the boot entry of the other distro.

    Cheers!

    Hi Thanks for your reply
    Yeah I think I understand … right now if I set the bios to boot the drive that has Antergos on it does not boot , I have updated grub from Kubuntu and have Antergos in the grub screen via Kubuntu.
    Problem is the Antergos Grub screen is completely gone …for some reason unplugging the drive got rid of the Grub ?? So if I boot my machine with just the Antergos SSD plugged in I have the same problem …no grub .
    I need to work out how to fix/reinstall Antergos grub .( I’m not planning on keeping Kubuntu) I use my second SSD for checking out distros …very happy with my KDE Antergos and want to to use it as my main distro.

  • Rescatux? link text

    Download " antergos-wallpapers-extra " and enjoy community sponsored wallpapers.

    Use the "Linux Beginner Search Engine"

    https://cse.google.com/cse/home?cx=017607476515012185699:b_owgx6xyi0

  • @Modisc said:

    Rescatux? link text

    cool thanks will give it ago …

  • Im afraid Rescatux did not work restoring grub “something went wrong” updating grub went OK but did not work
    This a new install of Antergos so I may just redo it …what steps should I take so this does not happen again?

  • @bigbossa : Please, do not reinstall again… you should work this out (it will be faster and you will learn).

    There’re plenty of tutorials on the Internet that will help you (and if you have any questions, please ask!)

    http://fasterland.net/reinstall-grub-arch-linux.html

  • @karasu
    Hi mate yeah I tried that method yesterday …Seem to have tried all the different fixes that I could find but had no luck :(
    Sorry I gave up!! Just finished a fresh install and and setup Plasma 5.4 all good so far :)
    The real test will be when I install a new distro to test on my second SSD …Kubuntu 15.10 is on there at the moment ( and included on Antergos Grub :) ) but I cant see myself booting into it …Antergos is so much better

  • @bigbossa:
    I did fresh install cause many probs, too. But for lost grub you don’t have to.

    for next time:
    (Don’t know about Rescatux. Don’t know nothing about chrooting.)
    But on supergrub 2 there was always reliance (for me)
    http://www.supergrubdisk.org/category/download/supergrub2diskdownload/super-grub2-disk-stable/

    Burn Super Grub2 iso or make Usb-Stick

    Boot from supergrub2 CD/Usb,
    There are various ways/entries, but it should find your distro.
    Select and boot your wanted distro.

    Then install grub with konsole:
    sudo grub-install /dev/sda (make sure to use the correct partition)

    generate new grub.cfg:
    sudo grub-mkconfig -o /boot/grub/grub.cfg
    reboot.

  • Hello mate yep tried this yesterday and afraid it did not work …nor did Rescatux ,
    Thanks

Posts 10Views 1401
Log in to reply