• How to change keyboard language?


    I’m trying to install antergos but the installer changes the keyboard language and I cannot set username/password to continue the installation. Is there a keyboard combination to change to english? I tried alt+shift, both shift, ctrl+space and some other combinations but none worked.

  • Hello
    I do not know if there is a key combination for setting the English language for installing but what you could try doing if your still in the installation mode is select Try Mode first and then afterwards select to Install the system.
    If that does not work, while in Try Mode, do the following:
    locale -a That command will let you see all the different languages available. Then open as root /etc/locale.gen and uncomment for US English en_US.UTF-8 UTF-8 Save the file and then do locale-gen
    To see and double check you language, do locale You should have everything listed in that output as US.UTF-8
    Post your results and hopefully this has helped you out . :)

    EDIT: Maybe also try this: localectl set-locale LANG=en_US.UTF-8

    Download " antergos-wallpapers-extra " and enjoy community sponsored wallpapers.

    Use the "Linux Beginner Search Engine"

    https://cse.google.com/cse/home?cx=017607476515012185699:b_owgx6xyi0

  • @Modisc
    I think that english is already set. If I switch to another virtual console I can write in english. I think this is must consider as a bug, because it’s not possible to continue the installation if you choose a none latin character language.

    EDIT:
    I didn’t follow your instructions because I couldn’t write anything in english, and I also I couldn’t start the installer(after quiting) to change the layout to english from there. I’ve manage to restart it though because I installed midnight commander and firefox before change the layout. So using copy/paste I started mc as root and I started manually the installer. Then I choose en_us as layout and now I’m waiting to finish the installation(hopefully with no other problems).

  • Wonderful!! :)
    Post here if all turns out good or bad. Try to help you out. Thats what this forum is all about. Helping one another. If all works out great, don’t forget to mark as solved. :)

    EDIT: What I noticed before from historical accounts in installing systems, either Antergos or some other system, is that sometimes, I had to reboot rather than quit the installation because for some reason, some installers remember the previous input after the installation process has already started. This seemed to have interfered with what I was looking for within my installation. Hence a reboot seemed to offer a trick to start fresh.

    Download " antergos-wallpapers-extra " and enjoy community sponsored wallpapers.

    Use the "Linux Beginner Search Engine"

    https://cse.google.com/cse/home?cx=017607476515012185699:b_owgx6xyi0

  • I had this happened when I tried out my first install. Nothing to do with Antergos, it is all about Arch. I chose greek installation and thereafter I could not set my user and password to continue.
    All I did was going back, selecting english and so I completed the installation successfully. On first boot, I changed the system language to greek and…surprise! surprise! on my next booting I could not enter my password which was (of course) in english… So, the workaround I used was this.

    1. Select "English "to install the OS.
    2. On first boot, open System Settings and change the System Language into your native one,
      BUT ALSO
    3. Select “ENGLISH” as the 1st input language source and your “NATIVE LANGUAGE” as 2nd

    1.Antergos Linux KDE plasma / Gnome 2.Ubuntu 17.10 64bit Unity
    Intel Core2 Duo CPU P8400 2.26GHz‖ RAM 3908 MiB ‖ Dell Inc. 0F328M - Dell Inc. Latitude E6500
    Intel Mobile 4 Series Chipset Integrated Graphics [8086:2a42] {i915

  • @anarch
    I already did those but thanks anyway. I just had problem to rerun the installer, so I couldn’t go back. Fortunately I installed and ran midnight commander before run the installer and I was able to copy/paste the “su” and “mc” command to a terminal and then I found the installer’s binary from midnight commander.

  • @dancaer69 said:

    I’m trying to install antergos but the installer changes the keyboard language and I cannot set username/password to continue the installation. Is there a keyboard combination to change to english? I tried alt+shift, both shift, ctrl+space and some other combinations but none worked.

    Sorry, but I do not understand. Cnchi changes the keyboard layout as you select it, so if you select Spanish, the keyboard is automagically changed to it from that screen. Next screens will use the Spanish layout. This is an intended behaviour.

    Could you tell us which layout did you select and what was your problem exactly when trying to enter your desired username/password?

    @anarch : that should not happen. If you select Greek, Cnchi should change to it and let you enter your username/password using a Greek keyboard layout. Why you say you could not set your username and password?

    Thanks both!

  • @karasu , no, you did not quite understand the issue I was refering to. Cnchi did change languge to greek. The problem was that when I got to the point where I had to enter my username & password, I could not enter it in english. The keyboard layout remained in greek. But I wanted my username /password in latin characters. That I could not change and that is why I had to go back and follow the procedure I described. Actually, I got this advice from the greek Archlinux forum.
    To tell you the truth I dont know if this still is an issue. It was in my first install (about 1,5 years ago) and I just followed the same procedure with all my installs thereafter on other machines . It has to do with Archlinux as I was told (greek Archlinux forum), not Cnchi itself…:thumbsup:

    1.Antergos Linux KDE plasma / Gnome 2.Ubuntu 17.10 64bit Unity
    Intel Core2 Duo CPU P8400 2.26GHz‖ RAM 3908 MiB ‖ Dell Inc. 0F328M - Dell Inc. Latitude E6500
    Intel Mobile 4 Series Chipset Integrated Graphics [8086:2a42] {i915

  • Thanks @anarch , I got it, nice explanation.

    Cheeers!

  • @karasu
    I’ve installed antergos succesfully with en layout, so i’m posting this just to demonstrate a problem.

    I get this is intended, and i see the appeal, but is this a right thing to do (technically)?
    If you choose non-latin layout, it FORCES you to enter your username and host name in that layout. Im not sure than you can have those containing non-latin symbols.

    And with cyrillic layout, you really can’t: http://imgur.com/q8hVnje
    Even if you could go with that, you probably won’t be able to login outside of X session. Imagine a video driver issue happens (like nouveau not supporting maxwell cards, and you have to go into tty)

    This may be a showstopper for an inexperienced user.

Posts 10Views 2642
Log in to reply