• [SOLVED] Sound does not work


    Hi everyone!
    I’ve just installed Antergos on my new laptop Dell Latitude 7350…and it looks great!
    Unfortunately I have some issues and therefore…I am here!

    I do not know why but sound does not work: I’ve checked both in sound settings, both with alsamixer but everything looks to be alright.

    Any suggestions?
    Thanks!

    Cheers,
    MatteP

    P.S. Ah! GNOME is my Desktop environment

  • It would be really useful if you output the details of your sound cards first to provide some useful information.
    lspci --nn
    You mention that you have checked in sound settings, but have you also tried the following?
    what modules do you have loaded? cat /proc/asound/modules
    Is there any output for this? aplay-l
    Have you tried doing what they mention in the Arch Wiki? amixer sset Master unmute
    What happens when you do this at high volume: speaker-test -c 2
    Have you checked to see if your sound modules are autoloaded?
    You would start off with lsmod and look for a ‘snd’ module and then after you have found whether it is listed there, checked to see information on it? For example, mine would be modprobe snd_hda_intel You would find the name of your modules from the above command given earlier cat /proc/asound/modules
    Have you tried to load it manually? modprobe your_sound_card and then to try systemctl to find out it’s status and to load it on boot up? Have you tried systemctl --failed
    Post any relevant outputs.

    Download " antergos-wallpapers-extra " and enjoy community sponsored wallpapers.

    Use the "Linux Beginner Search Engine"

    https://cse.google.com/cse/home?cx=017607476515012185699:b_owgx6xyi0

  • Hi @Modisc
    Here the results.

    00:00.0 Host bridge [0600]: Intel Corporation Broadwell-U Host Bridge -OPI [8086:1604] (rev 09)
    00:02.0 VGA compatible controller [0300]: Intel Corporation Broadwell-U Integrated Graphics [8086:161e] (rev 09)
    00:03.0 Audio device [0403]: Intel Corporation Broadwell-U Audio Controller [8086:160c] (rev 09)
    00:04.0 Signal processing controller [1180]: Intel Corporation Broadwell-U Camarillo Device [8086:1603] (rev 09)
    00:14.0 USB controller [0c03]: Intel Corporation Wildcat Point-LP USB xHCI Controller [8086:9cb1] (rev 03)
    `00:16.0 Communication controller [0780]: Intel Corporation Wildcat Point-LP MEI Controller #1 [8086:9cba] (rev 03)
    00:1c.0 PCI bridge [0604]: Intel Corporation Wildcat Point-LP PCI Express Root Port #3 [8086:9c94] (rev e3)
    00:1f.0 ISA bridge [0601]: Intel Corporation Wildcat Point-LP LPC Controller [8086:9cc7] (rev 03)
    00:1f.2 SATA controller [0106]: Intel Corporation Wildcat Point-LP SATA Controller [AHCI Mode] [8086:9c83] (rev 03)
    00:1f.3 SMBus [0c05]: Intel Corporation Wildcat Point-LP SMBus Controller [8086:9ca2] (rev 03)
    01:00.0 Network controller [0280]: Intel Corporation Wireless 7265 [8086:095a] (rev 59)
    

    Then:

    cat /proc/asound/modules
    0 snd_hda_intel
    1 snd_soc_sst_broadwell
    

    then

    aplay -l
    **** List of PLAYBACK Hardware Devices ****
    card 0: HDMI [HDA Intel HDMI], device 3: HDMI 0 [HDMI 0]
      Subdevices: 0/1
      Subdevice #0: subdevice #0
    card 0: HDMI [HDA Intel HDMI], device 7: HDMI 1 [HDMI 1]
      Subdevices: 1/1
      Subdevice #0: subdevice #0
    card 0: HDMI [HDA Intel HDMI], device 8: HDMI 2 [HDMI 2]
      Subdevices: 1/1
      Subdevice #0: subdevice #0
    card 1: broadwellrt286 [broadwell-rt286], device 0: System Playback/Capture (*) []
      Subdevices: 1/1
      Subdevice #0: subdevice #0
    card 1: broadwellrt286 [broadwell-rt286], device 1: Offload0 Playback (*) []
      Subdevices: 1/1
      Subdevice #0: subdevice #0
    card 1: broadwellrt286 [broadwell-rt286], device 2: Offload1 Playback (*) []
      Subdevices: 1/1
      Subdevice #0: subdevice #0
    

    I tried amixer sset Master unmute but nothing changed.
    If I dial speaker-test -c 2 I’ll get the following INFINITE loop:

    `Playback device is default`
    `Stream parameters are 48000Hz, S16_LE, 2 channels`
    `Using 16 octaves of pink noise`
    `Rate set to 48000Hz (requested 48000Hz)`
    `Buffer size range from 96 to 1048576`
    `Period size range from 32 to 349526`
    `Using max buffer size 1048576`
    `Periods = 4`
    `was set period_size = 262144`
    `was set buffer_size = 1048576`
     `0 - Front Left`
     `1 - Front Right`
    `Time per period = 10,940648`
     `0 - Front Left`
     `1 - Front Right`
    

    I tried also modprobe snd_hda_intel but nothing happened and to set it manually I don’t know my_sound_card. How can I get to know about it?

    Thanks

  • @MatteP said:
    I don’t know my_sound_card. How can I get to know about it?

    Hi @MatteP
    You already have your sound card listed in the output above. The command I gave you earlier told you what your sound card was.
    Where is the systemctl output? link text If you want to enable a service, you may need to do it using root.
    Did you hear sound when you dialed your speakers (volume up)? You didn’t say.
    And yes, it will be an infinite loop when you dial your speakers. What is the name of the broadwell service?

    Download " antergos-wallpapers-extra " and enjoy community sponsored wallpapers.

    Use the "Linux Beginner Search Engine"

    https://cse.google.com/cse/home?cx=017607476515012185699:b_owgx6xyi0

  • Hi @Modisc ,
    Ah! Ok! Well, then no: it does not work.
    No, when I unmuted the speaker I did not hear anything.

    the outcome of systemctl --failed is
    0 loaded units listed. Pass --all to see loaded but inactive units, too.
    To show all installed unit files use 'systemctl list-unit-files'.

    @Modisc ,
    isn’t it broadwell-rt286? As displayed above?
    (Actually I don’t know what it is so I’m just guessing from previous outcomes)
    And yes, I tried modprobe snd_hda_intel being root.

    Thanks,
    Cheers,
    MatteP

  • Did you check if you havealsa-utils installed? May not need to re-install. Just check. Answer No if it says to re-install.
    alsa-utils and Systemd
    from the Arch Wiki

    When using systemctl, you generally have to specify the complete name of the unit file, including its suffix
    

    Download " antergos-wallpapers-extra " and enjoy community sponsored wallpapers.

    Use the "Linux Beginner Search Engine"

    https://cse.google.com/cse/home?cx=017607476515012185699:b_owgx6xyi0

  • @Modisc
    Ooops! I’m afraid I a have reinstalled it!
    Anyway, yes, alsa-utils was already installed.

    I’ve tried both with modprobe snd_hda_intel both with modprobe snd_soc_sst_broadwell-rt286 but nothing happens.
    Then when I give systemctl I don’t manage to find snd_hda_intel nor snd_soc_sst_broadwell-rt286 in the list of units.

    So?

  • Please post the output of systemctl list-units Right now, your default sound card is 0 snd_hda_intel which I think is normal. When you have a 0 in front, that designates it to be default.

    By the way, when you quote large output, please could you quote like this:

    Press the key below the ESC key (3 times, that is);
    Press the ENTER key to go to the next line;
    Enter your content;
    Select the ENTER KEY to go the next line;
    Press the key below the ESC key ( 3 times, that is)

    EDIT: Is there an alsa-store.service listed?
    EDIT: I read somewhere that it might be necessary to reboot for changes to take effect.
    EDIT: I am only listing this as an alternate option that I found on the arch Wiki. link text Hold off on it. first let’s have this sound issue resolved.

    Download " antergos-wallpapers-extra " and enjoy community sponsored wallpapers.

    Use the "Linux Beginner Search Engine"

    https://cse.google.com/cse/home?cx=017607476515012185699:b_owgx6xyi0

  • @Modisc
    Thank you fro your availability and kindness!
    Well this is the long outcome:

    systemctl list-units
    UNIT                          LOAD   ACTIVE SUB       DESCRIPTION
    proc-sys-fs-binfmt_misc.automount loaded active waiting   Arbitrary Executable File
    sys-devices-pci0000:00-0000:00:02.0-drm-card0-card0\x2deDP\x2d1-intel_backlight.dev
    sys-devices-pci0000:00-0000:00:03.0-sound-card0.device loaded active plugged   Broa
    sys-devices-pci0000:00-0000:00:14.0-usb1-1\x2d7-1\x2d7:1.0-bluetooth-hci0.device lo
    sys-devices-pci0000:00-0000:00:1c.0-0000:01:00.0-net-wlp1s0.device loaded active pl
    sys-devices-pci0000:00-0000:00:1f.2-ata2-host1-target1:0:0-1:0:0:0-block-sda-sda1.d
    sys-devices-pci0000:00-0000:00:1f.2-ata2-host1-target1:0:0-1:0:0:0-block-sda-sda2.d
    sys-devices-pci0000:00-0000:00:1f.2-ata2-host1-target1:0:0-1:0:0:0-block-sda-sda3.d
    sys-devices-pci0000:00-0000:00:1f.2-ata2-host1-target1:0:0-1:0:0:0-block-sda-sda4.d
    sys-devices-pci0000:00-0000:00:1f.2-ata2-host1-target1:0:0-1:0:0:0-block-sda-sda5.d
    sys-devices-pci0000:00-0000:00:1f.2-ata2-host1-target1:0:0-1:0:0:0-block-sda-sda6.d
    sys-devices-pci0000:00-0000:00:1f.2-ata2-host1-target1:0:0-1:0:0:0-block-sda-sda7.d
    sys-devices-pci0000:00-0000:00:1f.2-ata2-host1-target1:0:0-1:0:0:0-block-sda-sda8.d
    sys-devices-pci0000:00-0000:00:1f.2-ata2-host1-target1:0:0-1:0:0:0-block-sda-sda9.d
    sys-devices-pci0000:00-0000:00:1f.2-ata2-host1-target1:0:0-1:0:0:0-block-sda.device
    sys-devices-pci0000:00-INT3438:00-broadwell\x2daudio-sound-card1.device loaded acti
    sys-devices-platform-dell\x2dlaptop-leds-dell::kbd_backlight.device loaded active p
    sys-devices-platform-serial8250-tty-ttyS0.device loaded active plugged   /sys/devic
    sys-devices-platform-serial8250-tty-ttyS1.device loaded active plugged   /sys/devic
    sys-devices-platform-serial8250-tty-ttyS2.device loaded active plugged   /sys/devic
    sys-devices-platform-serial8250-tty-ttyS3.device loaded active plugged   /sys/devic
    sys-devices-virtual-misc-rfkill.device loaded active plugged   /sys/devices/virtual
    sys-module-configfs.device    loaded active plugged   /sys/module/configfs
    sys-module-fuse.device        loaded active plugged   /sys/module/fuse
    sys-subsystem-bluetooth-devices-hci0.device loaded active plugged   0a2a
    sys-subsystem-net-devices-wlp1s0.device loaded active plugged   Wireless 7265 (Dual
    -.mount                       loaded active mounted   /
    boot-efi.mount                loaded active mounted   /boot/efi
    dev-hugepages.mount           loaded active mounted   Huge Pages File System
    dev-mqueue.mount              loaded active mounted   POSIX Message Queue File Syst
    home.mount                    loaded active mounted   /home
    run-user-1000-gvfs.mount      loaded active mounted   /run/user/1000/gvfs
    run-user-1000.mount           loaded active mounted   /run/user/1000
    sys-kernel-config.mount       loaded active mounted   Configuration File System
    sys-kernel-debug.mount        loaded active mounted   Debug File System
    tmp.mount                     loaded active mounted   Temporary Directory
    org.cups.cupsd.path           loaded active running   CUPS Scheduler
    systemd-ask-password-console.path loaded active waiting   Dispatch Password Request
    systemd-ask-password-wall.path loaded active waiting   Forward Password Requests to
    init.scope                    loaded active running   System and Service Manager
    session-c2.scope              loaded active running   Session c2 of user matteo
    accounts-daemon.service       loaded active running   Accounts Service
    avahi-daemon.service          loaded active running   Avahi mDNS/DNS-SD Stack
    bluetooth.service             loaded active running   Bluetooth service
    colord.service                loaded active running   Manage, Install and Generate 
    dbus.service                  loaded active running   D-Bus System Message Bus
    [email protected]            loaded active running   Getty on tty1
    haveged.service               loaded active running   Entropy Harvesting Daemon
    kmod-static-nodes.service     loaded active exited    Create list of required stati
    lightdm.service               loaded active running   Light Display Manager
    ModemManager.service          loaded active running   Modem Manager
    NetworkManager.service        loaded active running   Network Manager
    org.cups.cupsd.service        loaded active running   CUPS Scheduler
    pamac.service                 loaded active running   Pamac
    polkit.service                loaded active running   Authorization Manager
    rtkit-daemon.service          loaded active running   RealtimeKit Scheduling Policy
    [email protected]:intel_backlight.service loaded active exited    Load/Sa
    [email protected]:dell::kbd_backlight.service loaded active exited    Load/Sav
    systemd-journal-flush.service loaded active exited    Flush Journal to Persistent S
    systemd-journald.service      loaded active running   Journal Service
    systemd-logind.service        loaded active running   Login Service
    systemd-modules-load.service  loaded active exited    Load Kernel Modules
    systemd-random-seed.service   loaded active exited    Load/Save Random Seed
    systemd-remount-fs.service    loaded active exited    Remount Root and Kernel File 
    systemd-sysctl.service        loaded active exited    Apply Kernel Variables
    systemd-tmpfiles-setup-dev.service loaded active exited    Create Static Device Nod
    systemd-tmpfiles-setup.service loaded active exited    Create Volatile Files and Di
    systemd-udev-trigger.service  loaded active exited    udev Coldplug all Devices
    systemd-udevd.service         loaded active running   udev Kernel Device Manager
    systemd-update-utmp.service   loaded active exited    Update UTMP about System Boot
    systemd-user-sessions.service loaded active exited    Permit User Sessions
    systemd-vconsole-setup.service loaded active exited    Setup Virtual Console
    udisks2.service               loaded active running   Disk Manager
    ufw.service                   loaded active exited    CLI Netfilter Manager
    upower.service                loaded active running   Daemon for power management
    [email protected]             loaded active running   User Manager for UID 1000
    wpa_supplicant.service        loaded active running   WPA supplicant
    -.slice                       loaded active active    Root Slice
    system-getty.slice            loaded active active    system-getty.slice
    system-systemd\x2dbacklight.slice loaded active active    system-systemd\x2dbacklig
    system.slice                  loaded active active    System Slice
    user-1000.slice               loaded active active    user-1000.slice
    user.slice                    loaded active active    User and Session Slice
    avahi-daemon.socket           loaded active running   Avahi mDNS/DNS-SD Stack Activ
    dbus.socket                   loaded active running   D-Bus System Message Bus Sock
    dm-event.socket               loaded active listening Device-mapper event daemon FI
    lvm2-lvmetad.socket           loaded active listening LVM2 metadata daemon socket
    org.cups.cupsd.socket         loaded active running   CUPS Scheduler
    systemd-initctl.socket        loaded active listening /dev/initctl Compatibility Na
    systemd-journald-dev-log.socket loaded active running   Journal Socket (/dev/log)
    systemd-journald.socket       loaded active running   Journal Socket
    systemd-rfkill.socket         loaded active listening Load/Save RF Kill Switch Stat
    systemd-udevd-control.socket  loaded active running   udev Control Socket
    systemd-udevd-kernel.socket   loaded active running   udev Kernel Socket
    dev-disk-by\x2duuid-13fd24ec\x2d6820\x2d4455\x2d9e92\x2d67bd26955a12.swap loaded ac
    basic.target                  loaded active active    Basic System
    bluetooth.target              loaded active active    Bluetooth
    cryptsetup.target             loaded active active    Encrypted Volumes
    getty.target                  loaded active active    Login Prompts
    graphical.target              loaded active active    Graphical Interface
    local-fs-pre.target           loaded active active    Local File Systems (Pre)
    local-fs.target               loaded active active    Local File Systems
    multi-user.target             loaded active active    Multi-User System
    network.target                loaded active active    Network
    nss-user-lookup.target        loaded active active    User and Group Name Lookups
    paths.target                  loaded active active    Paths
    remote-fs.target              loaded active active    Remote File Systems
    slices.target                 loaded active active    Slices
    sockets.target                loaded active active    Sockets
    sound.target                  loaded active active    Sound Card
    swap.target                   loaded active active    Swap
    sysinit.target                loaded active active    System Initialization
    timers.target                 loaded active active    Timers
    logrotate.timer               loaded active waiting   Daily rotation of log files
    man-db.timer                  loaded active waiting   Daily man-db cache update
    shadow.timer                  loaded active waiting   Daily verification of passwor
    systemd-tmpfiles-clean.timer  loaded active waiting   Daily Cleanup of Temporary Di
    
    LOAD   = Reflects whether the unit definition was properly loaded.
    ACTIVE = The high-level unit activation state, i.e. generalization of SUB.
    SUB    = The low-level unit activation state, values depend on unit type.
    
    117 loaded units listed. Pass --all to see loaded but inactive units, too.
    To show all installed unit files use 'systemctl list-unit-files'.
    lines 79-125/125 (END)
    

    No, there is no alsa-store.service listed.
    I also tried rebooting but sound still does not work.

    Thanks,
    MatteP

  • @MatteP
    Had a look at your output. Don’t know what to say. All the outputs you have provided are as expected. Can you ensure that you have alsa-firmware alsa-plugins pulseaudio-alsa pulseaudio installed.

    In a terminal, could you also do pavucontrol Output Devices TAB and Configuration TAB are the primary concerns.

    1. Port should be Speakers. Port should/could be HDMI. Check Advanced in same TAB. It might say PCM.
    2. Profile should be Digital Stereo. . Profile should/could be Analog Stereo Duplex.

    You said earlier that you went into alsamixer. Did you select your sound card? F6 What do the CARD and CHIPSET say?

    Download " antergos-wallpapers-extra " and enjoy community sponsored wallpapers.

    Use the "Linux Beginner Search Engine"

    https://cse.google.com/cse/home?cx=017607476515012185699:b_owgx6xyi0

  • Hi @Modisc ,
    Sorry for my late reply. Actually I reinstalled every package you mentioned but nothing.
    On alsamixer I chose “HDA Intel HDMI” as sound card (even if I tried also with broadwell-rt286 afterwards).
    Giving pavucontrol and for instance, having a youtube video playing in background I have the attached screenshot…but still no sound.
    Might be somehow connected to “internal sound” instead of "“analog stereo”?
    0_1445989693811_Schermata da 2015-10-28 00-47-06.png

    Thanks ;)

  • Hi @MatteP
    Question: somewhat off topic but are you also trying to run 32 bit programs on an x86_64 system?
    If so, install lib32-libpulse and lib32-alsa-plugins Again, only if you are trying to run those programs on that particular system (if you have that system, that is). Or is only VLC as you mention? Otherwise do not install. No need to at this point.

    Also, I forgot to make mention of it earlier, is alsa-lib also installed. Sorry, should have asked you earlier (forgot).

    Back to topic: Can you please try pulseaudio --start

    EDIT: Why is there a red lock icon on your image beside the 2 ports?

    Download " antergos-wallpapers-extra " and enjoy community sponsored wallpapers.

    Use the "Linux Beginner Search Engine"

    https://cse.google.com/cse/home?cx=017607476515012185699:b_owgx6xyi0

  • Hi @Modisc,
    No, actually I don’t think I’m running any 32bit program…should I?
    Yes alsa-lib is installed.
    With the two red lock I can "“b==block both channel” and getting this screenshot 0_1445996575986_Schermata da 2015-10-28 02-42-24.png.

    When I give pulseaudio --start, I get

    pulseaudio --start
    N: [pulseaudio] main.c: Server configurato dall'utente in {06c5ddaabc774baca8211729adb1cab5}unix:/run/user/1000/pulse/native, sembra essere locale. Esame più approfondito.
    

    (sorry for the Italian!)

    Thanks again,
    MatteP

  • No. Not necessary to install 32 bit libs if not using them. Only was asking if you were using 32 bit apps like Steam, etc. Leave them.

    Are all you sound modules autodetected and loaded? lsmod | grep '^snd' | column -t You should have a whole bunch of modules with the prefix snd listed.
    I am wondering that perhaps what is happening is that Alsa finds your cards (s) but PulseAudio does not. Not too sure. Only conjecturing. Not 100 percent sure.

    Please do cat /etc/libao.conf and if default_driver=alsa please change to default_driver=pulse. Then reboot. If no change, **ensure that you revert to value previous to change. **

    Download " antergos-wallpapers-extra " and enjoy community sponsored wallpapers.

    Use the "Linux Beginner Search Engine"

    https://cse.google.com/cse/home?cx=017607476515012185699:b_owgx6xyi0

  • Hi @Modisc,
    I tried also your last suggestion but…nothing :disappointed:
    Well, if I give lsmod | grep '^snd' | column -t I get a lot of snd modules actually.
    A doubt came that maybe speakers might not work so I booted Windows and unfortunately…there they work!

  • sorry for chiming in here with the truly thoroug job you are doing. I have found that to use hmdi sound output in pavucontrol you have to turn of the built in audio setting in pavucontrol and it works every time.

  • Hi @Lizzi,
    Thanks a lot but unfortunately it didn’t work this time :confounded:
    In the screenshots my new configuration. Well, now the moving sound bar which is the one below broadwell-rt286 but nothing has changed!0_1446061612049_Schermata da 2015-10-28 20-41-47.png
    0_1446061625727_Schermata da 2015-10-28 20-41-42.png

  • @Lizzi said:

    sorry for chiming in here with the truly thoroug job you are doing. I have found that to use hmdi sound output in pavucontrol you have to turn of the built in audio setting in pavucontrol and it works every time.

    Dont be sorry. I actually appreciate the help. The more people involved, the better and the quicker a resolution to this.

    @MatteP I have a few options that could be exercised. One of them would be to install linux-lts which is a different kernel that might provide better performance, etc. But that is another action if all does not go well.
    The other one is removing what you have now and installing OSS (mentioned earlier). Again, if all does not go well following continuing procedures, we can try those. Not give up yet.

    The next thing we will do is open alsamixer again, and unmute the devices. You can do this with M You have to make sure that each column says 00 under each.
    Or you can do that with the following alsamixer -c 0

    From the Arch Wiki:

    Note: alsamixer will not tell you which output device is set as the default. One possible cause of no sound after install is that PulseAudio detects the wrong output device as a default. Install pavucontrol and check if there is any output on the pavucontrol panel when playing a .wav file.
    

    You must do that. You should play a.wav file. The Arch Wiki is a superb resource and tool. It is thorough and well written. I suggest to become friends with it.

    Question #1: The application that you are using to play files with. What application is it? Do you have the obvious engaged? That is, do you have volume up? Is volume muted or low? Ensure volume levels.

    Next thing if the above does not work is to start up your application for playing music and do the following:
    pacmd list-sink-inputs Also, play a video from Youtube. This is also an application that may or may not have output in the above command.
    Post the full output here. This is being done to rule out other things and to investigate other avenues.

    Also, post the full output of amixer -c 0 contents

    Question#2: Have you tried to see if you have sound through your headphones plugged into you headphone jack? Do you have sound available via that route? State the answer here.

    Post the full output of each command here.

    Download " antergos-wallpapers-extra " and enjoy community sponsored wallpapers.

    Use the "Linux Beginner Search Engine"

    https://cse.google.com/cse/home?cx=017607476515012185699:b_owgx6xyi0

  • Hi @Modisc,
    YEEAAAHHH! Now it works!
    I’ve unmuted all the channel (one by one, by hand) with alsamixer and now it works!
    Of course I already had tried to give alsamixer -c 0 and unmuting channels on the previous days but it didn’t use to work. While now I’ve indiscriminately unmuted all the channels by hand and finally it works.
    So:

    1. or the command alsamixer -c 0 doesn’t work properly
    2. or in the previous attempts of solving the issue following yours suggestions I’ve unblocked something which I have then triggered with alsamixer.

    Thanks for the patience!

    Best,
    MatteP

  • @MatteP
    That’s fantastic. This is a classic case of sticking it through to the end to get a resolution. So glad you demonstrated patience and stuck with me to get you this sound issue resolved. :)

    Umuting it all manually was probably the method to get sound going again.

    Download " antergos-wallpapers-extra " and enjoy community sponsored wallpapers.

    Use the "Linux Beginner Search Engine"

    https://cse.google.com/cse/home?cx=017607476515012185699:b_owgx6xyi0

sound44 Posts 20Views 4410
Log in to reply