• Like 0

    Installation to SSD drive on HP Stream 11?


    I’ve been trying to install on my HP Stream laptop. It comes with a Samsung MBG4GC drive. Using the installation option from a flash drive the install fails, saying it cannot find/use the partition map. I saw some references to cynchi not being able to handle anything out of the ordinary, and that the CLI installer should be used instead. There is probably an easy way to invoke such, but I haven’t seen it yet. Windows 10 is currently installed.
    I can provide more detailed diagnostics if this isn’t a straightforward newbie type issue.
    Thanks in advance!

  • Like 0
    This post is deleted!
  • Like 0

    Hello

    to my knowledge, if you want to install Antergos and a dual boot with Windows 10, you need to use the manual option of the installer. You can do that using its GUI version ; not need to switch to CLI.
    Looking around on this forum, you should find many post related to dual boot installation already.

    If you think you have a specific setup, please, post a snapshot or a description of the partitioning you are trying to use.

    Hope it helps.

  • Like 0

    Thanks for the reply. I considered a dual boot, even though I don’t plan on using the Other One very much if at all. However, the drive only comes with 32G. I’ve got a download of Antergos and with only that data I only have 7G local storage left. As I remember, Antergos takes about 8G with the software I installed on my other machine. Short story: I don’t feel there is enough room to do a dual boot. Thus, my attempt to just have the installer do what it will with the drive.
    On the Manjaro site there is an instruction for partitioning manually. I’m leaning towards doing that and then having Antergos do the install. Thoughts? Here is the link:
    https://wiki.manjaro.org/index.php/Installation_to_SSD_(quick_guide)
    Thanks again!

  • Like 0

    @mmacdonaldsce Hi

    So, I guess you use the automatic partitioning of the installer. It means everything on your disk is going to be erased.

    Am I correct ?

    If yes, have you tried with and without the LVM option selected ? if LVM is ticked, a new partitioning is going to be created and I hope it should clean up your old setup. So, if you have not tried yet, I would consider this.
    I have installed Antergos many times on laptops with SSD. I did it again very recently and using the LVM option without any issue. I don’t think the SSD is the issue by itself ; except if yours is specific maybe or if your BIOS is blocking something, As you are able to boot on a live USB, I assume you have changed your BIOS options to install something else than Windows.

    If anyone on this forum has another idea, feel free to step in.

  • Like 0

    I haven’t been noting down which options I have and have not tried. I’d be surprised if I haven’t done both with and without LVM. I will give it a whack and see what happens.
    I also see that the gummiboot option is related to UEFI, and that is the setup on this drive. But I also have the impression that UEFI is only relevant if doing a dual boot setup, correct? I may give that a try also after the LVM.
    Given that I’ve been trying all sorts of combinations I have to consider the possibility that I’ve mucked up the partition mapping entirely. If that is the case, is it true that the only way out would be to use the Windows recovery processing to restort all to a good starting point?

  • Like 0

    Hi

    I don’t use gummiboot but grub on my UEFI laptop without any issue. You need one them to launch your linux distro even without a dual boot.

    Booting on your liveUSB Antergos, could you then launch the installer and tick the manual partitioning option. Then, could you post a snapshot of the partition table seen by Antergos ?

  • Like 0

    I will capture the partition map if I am still having issues tonight. Last night I was able to start the installation process, so I think I’m past the UEFI/SSD issues. I got it to start working by checking LVM as you suggested, and that worked after I chose the gummiboot loader, for whatever reason.
    (Now I’m down to hanging on an http call, as I remember to build.antergos.com or sumsuch, after restarting cnchi with --disable-rank-mirrors. Ran out of time after that, but will research during the day.)

  • Like 0

    I did a workaround; sorry, but Manjaro installer didn’t even blink at the SSD, though to be honest the gummiboot/LVM process in Antergos seemed to be working. I found that the hp device is choking up on massive downloads under either distro, and I’ve just manually dealt with that. … Now on to the mobile broadband issue…
    Thanks for the time and thought!
    Michael

  • Like 0

    @mmacdonaldsce You’re welcome :smirk:

  • Like 0

    This actually seems to be a bigger problem than just the HP Stream. The problem lies in that the HP Stream does not use a normal SSD but rather it uses eMMC flash storage.
    This type of storage is different than that of a regular SSD that you would find in most laptops or desktops (poor man’s SSD). Now the problem I’m finding is that Cnchi just doesn’t know what to do with the partitioning of the drive so it errors out.
    This could be partly due to Cnchi trying to write to the RPMB (replay protected memory block) which is read-only.
    Resource:
    https://bbs.archlinux.org/viewtopic.php?id=205363

    As for the HP it has been installed MANUALLY with an older model (HP Stream 7) here:
    https://bbs.archlinux.org/viewtopic.php?id=195499
    I can’t guarentee this will work with the Stream 11 but this at least gives you an idea.
    As far as automatic gui installers, all I can say is hopefully the wonderful devs at Antergos will incorperate it in Cnchi in the future to autodetect when eMMC is being used.
    I also used a workaround in the meantime of Debian. It is currently using Grub2 (not gummiboot), didn’t use LVM, it has GUID partitioning , filesystem partition 1 fat32 (/dev/mmcblk0p1), part2 is Ext4, and part3 is swap. It also has 2 other disks set to /dev/mmcblc0rpmb and /dev/mmcblk0boot0 (read-only). Both of these partitions are set to Unknown. BIOS is also set to AHCI, Windows8.x, and UEFI.

    TL;DR? As far as I know Cnchi don’t work for eMMC unless someone knows a way to manually configure it.

  • Like 0

    Just to be clear: I was apparently able to use the gummiboot and LVM combination, and I that installation seemed to be working.
    I ran into what seemed to be other issues and at that point was holding up other work so I went down the path of installing Manjaro. I had the same secondary problem, which turned out to be in my home network bandwidth rather than either installation process.
    In case it helps someone down the line, here is what the disk is configured as installed my Manjaro’s installer:

    Disk /dev/mmcblk0: 29.1 GiB, 31268536320 bytes, 61071360 sectors
    Units: sectors of 1 * 512 = 512 bytes
    Sector size (logical/physical): 512 bytes / 512 bytes
    I/O size (minimum/optimal): 512 bytes / 512 bytes
    Disklabel type: gpt
    Disk identifier: 8F2C1FBC-6974-4034-8E02-1E965B63ACE4
    
    Device            Start      End  Sectors  Size Type
    /dev/mmcblk0p1     4097   618497   614401  300M Microsoft basic data
    /dev/mmcblk0p2   618498 52516785 51898288 24.8G Linux filesystem
    /dev/mmcblk0p3 52516786 61063064  8546279  4.1G Linux swap
    
    Disk /dev/mmcblk0boot1: 4 MiB, 4194304 bytes, 8192 sectors
    Units: sectors of 1 * 512 = 512 bytes
    Sector size (logical/physical): 512 bytes / 512 bytes
    I/O size (minimum/optimal): 512 bytes / 512 bytes
    
    
    Disk /dev/mmcblk0boot0: 4 MiB, 4194304 bytes, 8192 sectors
    Units: sectors of 1 * 512 = 512 bytes
    Sector size (logical/physical): 512 bytes / 512 bytes
    I/O size (minimum/optimal): 512 bytes / 512 bytes
    
    Filesystem      Size  Used Avail Use% Mounted on
    dev             945M     0  945M   0% /dev
    run             949M  1.1M  948M   1% /run
    /dev/mmcblk0p2   25G  7.4G   16G  33% /
    tmpfs           949M  140K  949M   1% /dev/shm
    tmpfs           949M     0  949M   0% /sys/fs/cgroup
    tmpfs           949M  616K  948M   1% /tmp
    /dev/mmcblk0p1  300M  256K  300M   1% /boot/efi
    tmpfs           190M   24K  190M   1% /run/user/1000
  • Like 0

    Hi, I used Antergos on an acer s3 laptop with a 32 gb ssd and a 500 gb sata disk. It worked fine with gummiboot. However, I read more than once that these 20-30 gb ssd disks attached to the sata aren’t really ssd disks on its own. They are more like a flash memory. Actually, the manufacturer configuration uses it as hibernation cache partition with win8 installed on the 500g disk. As cnchi treated the ssd portion as a separate device, i installed root partition in it, uefi config and left the 500 for home. Also, the bootloader should be installed in the non-ssd partition. This is my little experience with ssds. Hope it helps!

  • Like 0

    Good to hear you fixed the problem mmacdonald, I assumed that with the post saying unsolved you were still looking for a solution. What I don’t understand is why other distro installers managed to auto install using grub2. Not saying gummiboot doesn’t work, just wondering why you have to switch Cnchi to it in order for it to install. Maybe a bug? Anyways as a side note did you try installing without LVM? Or was this the only method you found that worked?

  • Like 0

    The ticket can be marked as solved, as I do have a workaround. I will be, at some point when I have time, reattempting the installation with Antergos. (I am finding that I do prefer this distro over Manjaro, though they are close.) The combination that was working in the Antergos installation, using Cnchi was to choose gummiboot and the LVM option.

  • Like 0

    Did you check your BIOS settings to make sure AHCI is enabled? Did you clone your OS using a tool that came with the drive or did you install a clean OS image to that solid state drive? If not then do it. And then use Hp Stream 11 Manual for further setup and support.

  • Like 0

    It’s a very old topic friend…

    Antergos (default OS) - WIN10 (abandoned)
    MATE desktop
    AMD - A4 7300 Radeon graphics
    16 GB ram
    HD 1 TB

hp stream2 mmd1 ssd11 partition map2 install67 Posts 17Views 2474
Log in to reply