• vmlinuz not found when adding Antergos Live ISO on HDD to Grub.

    cat /etc/grub.d/40_custom
    menuentry "Antergos Live" {
          set isofile="/home/path/to/iso/file/antergos-2015.06.03-x86_64.iso"
          loopback loop (hd0,1)$isofile
          linux (loop)/live/vmlinuz boot=live config union=aufs noswap noprompt vga=788 ip=frommedia toram=filesystem.squashfs findiso=$isofile
          initrd (loop)/live/initrd.img

    After sudo grub-mkconfig -o /boot/grub/grub.cfg and then reboot is that I get an error telling me `you need to load the kernel first’ with a reboot back to grub.

    Error: file vmlinuz not found
    Error: You need to load the kernel first

    hd0,1 is where Antergos Live ISO is located on. I am doing something wrong here. Not too sure on how to load the kernel first when wanting to have Antergos as Live ISO on HDD and boot it through Grub?

  • Try this:

    menuentry "Antergos Live" {
          set isofile="/home/path/to/iso/file/antergos-2015.10.18-x86_64.iso"
          loopback loop (hd0,1)$isofile
          linux (loop)/arch/boot/vmlinuz archisobasedir=arch archisolabel=ANTERGOS findiso=$isofile
          initrd (loop)/arch/boot/archiso.img
  • hi @lots-0-logs

    Thanks for your response. I think almost.

    waiting 30 seconds for deice /dev/disk/by-label/ANTERGOS
    ERROR:/dev/disk/by-label/ANTERGOS device did not show up after 30 seconds
    falling back to interactive prompt
    You can try to fix the problem normally, log out when you are finished
    sh: cant' access tty: job control turned off
    [rootfs /] #
  • Hmm okay then, try this:

    menuentry "Antergos Live" {
        set isofile='/home/path/to/iso/file/antergos-2015.10.18-x86_64.iso'
    	loopback loop $isofile
    	linux (loop)/arch/boot/vmlinuz archisodevice=/dev/loop0 img_dev=$imgdevpath img_loop=$isofile
    	initrd (loop)/arch/boot/archiso.img
  • Same as above except
    ERROR: /dev/loop0 device did not show up after 30 seconds preceeded the above message already posted.
    Question: I am curious to why leaving out the (hd0, 1) in this instance? Am asking because doesn’t Grub look for the ISO when you have the (hd0, X) inserted in the 40_custom file?

    By the way, the 40_custom file that I posted earlier is the same one that is used to place GParted Live ISO into Grub. Seems to work with that one but for some reason not with an OS Live ISO.

  • This post is deleted!
  • I have had a look around on bbs.archlinux via Google and I don’t think this is do-able with Arch/Antergos ISO. There seems to be a bug, where(for instance) if using the Arch ISO, the bug, if preferred to have it labelled this way, does not mount iso in loopback mode. Other distros can do this but it does not seem do-able with this ARch based distribution. Kind of too bad though. So I am giving up on trying to see if this is possible.

  • Sorry this is not about GRUB2 but here’s how I run an Antergos live ISO using syslinux:

    LABEL Antergos Live [DOIN , from GRUB2 exemple]
       MENU LABEL Antergos Live
       INITRD /path/to/memdisk
       LINUX  /path/to/antergos-2015.10.18-x86_64.iso
       APPEND iso

    As you can see, both Gfx menu and options are done by the distro’s own bootloader, which frankly kiss my ass 👌

Posts 8Views 2571
Log in to reply
Bloom Email Optin Plugin

Looks like your connection to Antergos Community Forum was lost, please wait while we try to reconnect.