• \[SOLVED\] flash player freezes


    Installed Antergos with cinnamon. Playing youtube in firefox freezes the whole system. I don’t know what logs to look at. Both flashplugins x86-x64 are installed, hardware acceleration is disabled. I’ve tried repo-ck and had less freezes.

    kernel 3.11.6
    nvidia driver 325

    specs:
    ssd 64gb - btrfs /root
    i7-3930k - mobo rampage iv gene
    16gb ram
    gtx 660ti

    I need firefox with flash working. I don’t want chromium or pepper for that matter. I don’t want any substitues for flashplugin cause other sites with flash content do not support them.

  • Installed Antergos with cinnamon. Playing youtube in firefox freezes the whole system. I don’t know what logs to look at. Both flashplugins x86-x64 are installed, hardware acceleration is disabled. I’ve tried repo-ck and had less freezes.

    kernel 3.11.6
    nvidia driver 325

    specs:
    ssd 64gb - btrfs /root
    i7-3930k - mobo rampage iv gene
    16gb ram
    gtx 660ti

    I need firefox with flash working. I don’t want chromium or pepper for that matter. I don’t want any substitues for flashplugin cause other sites with flash content do not support them.

  • Hi,

    The pepper-flash plugin for Chrome/Chromium is not a substitute in the same way something like openjdk is for java. The pepper-flash plugin is actually developed and maintained by Adobe to include with Chrome. The original flash-plugin package that’s no longer developed but still available has been frozen at version 11.2 and will only get security related updates (no improvements or new features). The current flash version is now 11.9 so you may actually see better performance using pepper-flash. Check out this page for a possible solution: [https://wiki.archlinux.org/index.php/VDPAU][0]">[https://wiki.archlinux.org/index.php/VDPAU][1] Good luck!

    Regards,

    [0]: <a href=
    [1]: https://wiki.archlinux.org/index.php/VDPAU

  • flash pepper doesn’t work with firefox. no freezes on ubuntu with 11.2 flash. chromium has no “limit cache” option at least I dont see it here, cause I’ve got an ssd drive I need that option.

    update: installed flash pepper tried it on chromium. chromium frozed.

  • Did you disable the legacy flash in Chrome after installing pepper-flash? Input “chrome://plugins” into the address bar and hit enter. Expand the details (link on top right). You will see two files listed under flash. Disable the NPAPI version and restart chromium.

    I also have an ssd and use chromium. I have it keep its cache in /tmp so it never writes to my ssd and actually provides better performance. You can read more about that here: [https://wiki.archlinux.org/index.php/Chromium_Tips_and_Tweaks#Cache_in_tmpfs][0]">[https://wiki.archlinux.org/index.php/Ch][1] … e_in_tmpfs

    Also, you can try disabling hardware acceleration for flash by editing line in /etc/adobe/mms.cfg to “EnableLinuxHWVideoDecode=0” then restart your system.

    Links that may be useful:
    [https://wiki.archlinux.org/index.php/Browser_Plugins][0]">[https://wiki.archlinux.org/index.php/Browser_Plugins][2]
    [https://wiki.archlinux.org/index.php/Chromium_Tips_and_Tweaks][0]">[https://wiki.archlinux.org/index.php/Ch][1] … and_Tweaks
    [https://wiki.archlinux.org/index.php/VDPAU][0]">[https://wiki.archlinux.org/index.php/VDPAU][3]
    [https://wiki.archlinux.org/index.php/VA-API][0]">[https://wiki.archlinux.org/index.php/VA-API][4]
    [https://wiki.archlinux.org/index.php/NVIDIA#Full_system_freeze_using_Flash][0]">[https://wiki.archlinux.org/index.php/NV][5] … sing_Flash

    Regards,

    [0]: <a href=
    [1]: https://wiki.archlinux.org/index.php/Ch
    [2]: https://wiki.archlinux.org/index.php/Browser_Plugins
    [3]: https://wiki.archlinux.org/index.php/VDPAU
    [4]: https://wiki.archlinux.org/index.php/VA-API
    [5]: https://wiki.archlinux.org/index.php/NV

  • Well nothing helped. so I installed repo-ck sandybridge kernel and so far less issues again. Anyways, I was gonna ask you if there are any specific packages that needed to be installed after Antegros installation.

  • That’s actually up to you

    [Life Hacker’s Best of the Best: Linux Apps[/url:r4f1fgyo]
    [Life Hacker’s Linux App Directory[/url:r4f1fgyo]
    [Makeuseof Best Linux Apps[/url:r4f1fgyo]

    Have fun…and btw Welcome to Antergos!]2]1]0

  • Im not a Linux pro but Here’s the list of what I’ve been using ubuntu-> mint -> snow linux -> antergos. previously used red hat back, fedora, solaris, freebsd in 2003. Trying to figure Antergos out now, also tried manjaro. I’ve like cinnarch before at became Antergos cause I like cinnamon. It would be good to have if possible something like manjaro does a pdf of howtos.

  • Hi,

    It would be good to have if possible something like manjaro does a pdf of howtos.

    Bear in mind that Manjaro and Antergos are based on Arch, so they share a lot.

    Also, if you have used Ubuntu and Mint, you can look here to learn how pacman works:

    [url:qzbmnxln]https://wiki.archlinux.org/index.php/Pacman_Rosetta[/url:qzbmnxln]

    And by all means, do not hesitate to ask here in the forums. We’re always glad to help.

  • Snowlinux would show read benchamark of an ssd 209.2 MB/s and Antergos would show 188 MB/s so its always about 20-30MB/s lower in Antergos Why is Antergos disk benchmark slower?

    It could be because of the kernel version I suppose. Maybe some regression within our kernel version. I can’t imagine anything else involved with it

  • @“rusty”:2hv712kp said:

    It would be good to have if possible something like manjaro does a pdf of howtos.[/quote:2hv712kp]

    This is something that is certainly in our plans. As we are a small group of developers, we welcome any help with documentation from our ever-growing community of users. In the meantime we rely heavily on the excellant information available in the Arch Wiki.

    @“rusty”:2hv712kp said:

    one is a disk benchmark of the same disk but different Linux. Snowlinux would show read benchamark of an ssd 209.2 MB/s and Antergos would show 188 MB/s so its always about 20-30MB/s lower in Antergos Why is Antergos disk benchmark slower? [/quote:2hv712kp]

    Hmm…that is odd. I will look into it!

    @“rusty”:2hv712kp said:

    The other question, would you guys come to the Linux Action Show ?[/quote:2hv712kp]

    We’d love to. Actually, we planned to have two of our developers go on the show a few weeks ago but missed it due to a communication mishap

    Best Regards,

  • I think I’ve found what’s causing the flash player to hang my system. It is intel P-States that doesn’t scale the frequency all the way up making the system freeze.
    What I’ve tried so far:
    I’ve tried cpupower frequency-set -g performance and it brought my cpu frequency to 4.1ghz under the load. My system is overclocked I totally forgot to mention that, oc is tested to be stable. I’ve tried flash with performance governor and didn’t have any freezes, then I did this nano /etc/default/grub and edited:

    Add intel_pstate=disable to the GRUB_CMDLINE_LINUX_DEFAULT="quiet"
    e.g. mine looks like this: GRUB_CMDLINE_LINUX_DEFAULT="quiet intel_pstate=disable"
    then grub-mkconfig -o /boot/grub/grub.cfg

    So now I don’t have the P-States driver running but then the frequency stays close to 4.0ghz with performance governor it was scaling better. So my question is how to set performance governor as a default instead of disabling P-States.

  • You can do it at runtime with ‘cpupower’, although I don’t know if the election will be preserved between boots.

    The command would be something like:

    sudo cpupower frequency-set -g <governor\>
    

    More information at Arch Wiki: CPU frequency scaling[/url:3pciz9d4]

    "When you stare into the abyss the abyss stares back at you." (Friedrich Nietzsche)

  • Just create a file with that command inside and save the file in /etc/xdg/autostart so it will start no matter which user logs in. Don’t forget to put “#!/bin/bash” as the first line in the file

    Cheers!

  • trying it right now so far so good. will report if it freezes again. Thank You so much !!!

  • You are welcome!

    "When you stare into the abyss the abyss stares back at you." (Friedrich Nietzsche)

  • ok after a while my system did freeze a few times and I decided to disable p-states completely

  • I’m actually a little surprised that it’s giving you such a headache. I have 3 sandybridge systems in my household all running linux and while they aren’t perfect (what is, really…) I havent experienced anything so much to compel me to seek out a fix. (If that makes any sense) Does it occasionally freeze? Well of course. Pretty much I know if I am going to watch a flash video that’s longer than 30 minutes, my fan will be at full blast. While its a little annoying, it does what it is made to do as the cpu temp never reaches anywhere close to dangerous levels. I really don’t think disabling pstates is a good option as the chip, at its core, was designed around the use of pstates. I’m not sure if you have tried the lts kernel but I highly recommend you give it a look. It can be easily installed with linux-ltx-headers & linux-lts packages. I recommend installing the headers first, then seperately the kernel itself. (Especially if you use virtualbox kernel modules.) The lts is on the 3.10 kernel branch so its really not old and I have found it to provide a much more stable system. That’s just my 2-cents

    Cheers!

  • Well I’m getting very close to solve the issue. I think the problem here is my overclocking that pstates doesnt co-op with
    I’m trying a few things right now to see what’s the best solution. I’ll add more information as I progress.
    I was on snowlinux before and it has 3.8 kernel which is acpi-cpufreq anything after 3.8 is p-states therefore I think linux-lts would freeze as well.
    So far I figured that p-states + governor performance enabled will still freeze the system when watching flash videos like youtube but less than without a governor performance.
    With acpi-cpufreq driver it seems to be working fine but I need to enable performance governor by default cause I get ondemand instead.
    Long story short.

    p-states+ governor powersave = freezes
    p-states+ governor performance = less freezes
    acpi-cpufreq+ governor ondemand or performance = so far no freezes

  • Here’s what I did so far

    sudo leafpad /etc/default/grub
    GRUB_CMDLINE_LINUX_DEFAULT="intel_pstate=disable"
    sudo grub-mkconfig -o /boot/grub/grub.cfg
    sudo pacman -S cpupower
    systemctl enable cpupower.service
    sudo leafpad /etc/default/cpupower
    governor=‘performance’

    another trick or not

Posts 20Views 2552
Log in to reply