• \[SOLVED\] Can't install, all GUI elements White


    Hello, this is my first post to the forum.

    I post because I am having some trouble.

    I am trying to install Antergos from a USB drive, in UEFI mode.

    I am on an i5 4670k system, with dual HD radeon 7950 GPUs.

    The same USB stick I am using to try this install worked fine in “Bios” mode on my laptop.

    Whenever I boot into the drive, The GUI is displayed after the command line text.

    But the Installation script is /completely/ white.

    When I open anything else, ie, Chromium, or settings, They, too, are completely white. Even the terminal.

    I can still hover my mouse over where the “X” should be, and I can still close the programs. So I know that this is a graphical issue only.

    Is it that my GPU doesn’t have proper drivers yet, and thus, cant display? I do have integrated Intel video. Should I use that, maybe?

  • Hello, this is my first post to the forum.

    I post because I am having some trouble.

    I am trying to install Antergos from a USB drive, in UEFI mode.

    I am on an i5 4670k system, with dual HD radeon 7950 GPUs.

    The same USB stick I am using to try this install worked fine in “Bios” mode on my laptop.

    Whenever I boot into the drive, The GUI is displayed after the command line text.

    But the Installation script is /completely/ white.

    When I open anything else, ie, Chromium, or settings, They, too, are completely white. Even the terminal.

    I can still hover my mouse over where the “X” should be, and I can still close the programs. So I know that this is a graphical issue only.

    Is it that my GPU doesn’t have proper drivers yet, and thus, cant display? I do have integrated Intel video. Should I use that, maybe?

  • Hi,

    The first thing I would try is to install the hybrid graphics drivers since you have the dual intel/ati graphics. They can be installed with command “yaourt -S hybrid-video-ati-intel-systemd”. You may need to install the AUR helper yaourt first which you can do with “pacman -S yaourt”.

    Now I know you are probably wondering how you are suppose to install when you cannot see lol. No worries, when your boot manager appears you will need to add “systemd.unit=multi-user.target” to the end of the kernel command line. This is done by pressing “e” when using bios boot. I am not certain if it will be the same for you. If not, look at the bottom of the screen for the options.

    Here is so info on hybrid graphics: [https://wiki.archlinux.org/index.php/hybrid_graphics#ATI_Dynamic_Switchable_Graphics][0]">[https://wiki.archlinux.org/index.php/hy][1] … e_Graphics

    Please let me know if you get it working or not!

    Regards,

    [0]: <a href=
    [1]: https://wiki.archlinux.org/index.php/hy

  • No, I’m sorry. This did not help. After I installed yaourt, I installed the hybrid drivers (as well as base-devel which was needed to use makepkg).

    when I ran the antergos setup from the CLI, I got an error telling me that I could not start the X server.

    [EDIT]

    I got it working by simply switching to my Integrated Intel GPU for the installation, then switching back to my AMD cards afterward.

    Thank you for your help, though.

  • Yes, the ability to switch between the two cards is provided by the hybrid-video-ati-intel-systemd package. I should have made that more clear. Anyway, glad you got it figured out!

    Regards,

Posts 5Views 1187
Log in to reply
Bloom Email Optin Plugin

Looks like your connection to Antergos Community Forum was lost, please wait while we try to reconnect.