• Upgrading to systemd227


    Recently I noticed that I got an upgrade to systemd227 - still I notice that when I boot I get the indicator that systemd226 is still booting instead. Is there a way to get the system to use the upgraded systemd?

    forbajato

  • Check your package manager to see which version is being reported.

  • @Arup-Roy-Chowdhury Not sure which package you mean so I checked both systemd and pacman:

    systemd is 227-1
    pacman is 4.2.1-4

  • Thats strange, do a sudo grub-mkconfig -o /boot/grub/grub.cfg and reboot to see if it shows version 227

  • That had unexpected results. I first made a backup of the grub.cfg file and then entered the grub-mkconfig command. Now when I reboot the boot process hangs on my monitor, the last line says “Started Accounts Service”. I can’t change to a virtual terminal nor will anything proceed. Hoping this was just a really slow boot I let it sit for quite a while with no results.

    Interestingly I have discovered I can SSH into the box from another machine. I copied the original grub.cfg file back into place (/boot/grub/grub.cfg) hoping to at least get back to a usable system. No go, still hangs at the same spot in the boot sequence.

  • Sorry about that but something apparently wrong in the system configuration and thats the reason systemd wasn’t upgraded in the first place.

  • I am not sure how to pursue the diagnosis at this point - any pointers are appreciated!

  • accounts-service hang is the DM issue, try removing your DM and then see if system boots.

  • From reading I assumed “the DM issue” was the problem with LightDM. Since I was using GDM I was surprised it could bite me. Even more unexpected was turning off the gdm.service and enabling lightdm.service and having the system boot to a workable GUI (though with LightDM rather than GDM).

    Now if I could only fix the original problem - the indication that I am using systemd 226 when systemd227 is installed.

  • @forbajato said:

    Now if I could only fix the original problem - the indication that I am using systemd 226 when systemd227 is installed.

    It seems I am having the same issue. Any suggestions will be greatly appreciated.

  • In terminal:
    sudo mkinitcpio -p linux

  • Excuse my noobness, but the above command, what does it do? nevermind, I man(ed) it!

  • @Noctem Tell us how it goes!

  • Just rebooted, all worked like a charm! Thank you @gaim!

  • You gave me courage - worked exactly as billed. Thanks @gaim!

upgrades3 systemd23 Posts 16Views 1405
Log in to reply