• Dual boot with Windows 10... can't boot into Windows [Solved]


    Hi, I just recently installed Antegros along my Windows 10 installation. I followed this guide: http://itsfoss.com/dual-boot-antergos-windows-uefi/ . I have everything all set up and done… but when I restarted my computer, the regular grub came up (it looks like Antegros customized it a lot) and there is only one option: to boot into Antegros. No option to boot into Windows. I went to “advanced” (under the Antegros selection) and again, no Windows. Can anyone please help me recover Windows… thanks. I use a Toshiba laptop (2015) with UEFI. Secure boot is disabled.

  • To keep Antergos and grub (A):
    From within Antergos, run the grub install and grub update commands. “sudo grub-install /dev/sd*” then “update-grub”. Follow the output carefully and you should see something like “Win* bootloader found in /dev/sda” or something like that. If not, then is a grub issue.

    To repair Window$ and discard grub (B):
    Download SuperGRUBDisk2, is only 15Mb size .iso. Then write it to a USB with “dd” command. Then you will be able to boot into Windows from SuperGrub live session.
    Now, If you have the windows installer, you can repair the boot within Windows live CD.

    You can do (B) and then restore grub from Antergos live environment by changin root to the installation you have and reinstalling grub as described in (A), but, if grub fails to detect Win, you shouldn’t. :)

  • After running the grub-install commands, I get “grub-install: error: efibootmgr: not found.” Do I have to be more specific and install on the specific efi partition (below; sda1?)

    Here is what I get after running fdisk -l: (a portion of it)
    /dev/sda1 2048 534527 532480 260M EFI System

    And thanks again for helping, this is my first time dual booting with Windows 10 (and with all of the hassles of uefi)…

  • Wow… I have found a silly workaround. (I haven’t done what you said yet- still stuck with my last question) but at startup, I press F12 and then I go to the computer boot options and select my hard drive. It then boots into Windows!! I have tried this multiple times and it just works for some reason. But then when I don’t press the F12 key when my computer starts up it goes–like before–directly into gub then into Antergos. A workaround, but it at least works.

    Quick question: if I ever wanted to install a new linux flavor (or reinstall Antergos) can I just follow the link to the guide that I mentioned above? While using the exact same partitions as now? Or will installing (or reinstalling) another grub with the new linux mess up the EFI partition where the glitchy grub currently is (and mess up Windows)? Thanks.

  • Oh, I see the problem you have. You should try to boot then into Antergos and re-install grub and uupdating, making sure it detects your Windows bootloader.

    Most probably, is that grub was not installed correctly, beacuse EFI is complicated and Micro$oft doesn’t make it any easier.

    Good luck.

  • The re-installation of grub fixed my issue. Thanks for your help!!

  • Screenshot from 2015-10-20 16-45-39.png

    And how do I mark this question as solved? Even under topic tools, I don’t get any “mark as solved” checkmark…

  • In this case, just edit your thread’s title —> [Solved]

    Download " antergos-wallpapers-extra " and enjoy community sponsored wallpapers.

    Use the "Linux Beginner Search Engine"

    https://cse.google.com/cse/home?cx=017607476515012185699:b_owgx6xyi0

  • @elvisn In cases where the topic failed to post as a question you can simply choose “Ask As Question” and then you will see the option to “Mark As Solved” :wink:

    Cheers!

  • My bad… Now it is a question and is “solved”. Thanks again for help on an awesome forum with friendly volunteers (and an amazing noob friendly arch distro! ;-D)

  • You are welcome. Enjoy the Linux experience (I am sure you will).

    :)

Posts 11Views 2823
Log in to reply