• Like 0

    The Login screen for Antergos is incredibly slow


    This is my 2nd day of using Antergos and i have found the Login Manager to be incredibly slow, when i was installing it on a usb it was fine but the Full install is incredibly Laggy/slow. Could you guys help me out here? i’m kinda a noob when it comes to Linux in general.

  • Like 1

    If you’re using Gnome, a quick workaround can be to stop using our fancy theme with lightdm and try gdm instead:

    Press CTRL+ALT+F2 to switch to another console and login there. Type this commands to install GDM and use it:

    sudo pacman -Syu
    sudo pacman -S gdm
    sudo systemctl disable lightdm
    sudo systemctl enable gdm
    sudo systemctl stop lightdm
    sudo systemctl start gdm
    

    Hope this helps.

    Cheers!

    P.S. If you want to use lightdm no matter what, you should post here your logs.

  • Like 0

    @karasu said:

    P.S. If you want to use lightdm no matter what, you should post here your logs.

    Where would lightdm logs be kept?

  • Like 0

    I assume your system is up to date… if not, update it:
    sudo pacman -Syu

    I see a GTK Warning which is no good:
    (lightdm-webkit2-greeter:583): Gtk-WARNING **: drawing failure for widget 'WebKitWebView': invalid value for an input Visual*

    And this could be a problem, too:
    (WebKitWebProcess:24746): Gdk-WARNING **: WebKitWebProcess: Fatal IO error 11 (Resource temporarily unavailable) on X server :1.

    Please, issue this command:
    sudo pacman -S lightdm-webkit2-greeter lightdm-webkit-theme-antergos

    And restart lightdm:
    sudo systemctl restart lightdm

    Tell us if it helps or not.

  • Like 0

    @karasu It did not help I did the command and it reinstalled those 2 packages and i restarted it and it was still as slow/laggy as b4

  • Like 0

    I have the same problem. I’m using Cinnamon. I’ll try that you recommend. Thanks

  • Like 0

    @loopset if you figure out how to fix it do tell us.

  • Like 0

    I am here with the same problem. Antergos+Cinnamon. pacman up-to-date.

    UPDATE: switched to GDM. not looking back

  • Like 0

    Hi. I am having this same problem. I was able to solve it by changing the greeter theme of lightdm. To do this follow the steps below:

    yaourt lightdm-pantheon-greeter
    

    Open the lightdm configuration file with your favorite text editor, for example vim:

    sudo vim /etc/lightdm/lightdm.conf
    

    Change the line “greeter-session=lightdm-webkit2-greeter” to “greeter-session=lightdm-pantheon-greeter”. This lightdm theme has very good performance on my pc.

  • Like 0

    @micdoug said in The Login screen for Antergos is incredibly slow:

    Hi. I am having this same problem. I was able to solve it by changing the greeter theme of lightdm. To do this follow the steps below:

    yaourt lightdm-pantheon-greeter
    

    Open the lightdm configuration file with your favorite text editor, for example vim:

    sudo vim /etc/lightdm/lightdm.conf
    

    Change the line “greeter-session=lightdm-webkit2-greeter” to “greeter-session=lightdm-pantheon-greeter”. This lightdm theme has very good performance on my pc.

    I use the XFCE desktop, and this made a great improvement for me. No more slow log in screen, and after logging in, the desktop seems to start up much faster too. Thank you very much.

  • Like 0

    Make sure you actually have lightdm-pantheon on your comp or else your webkit2 will crash on start. I had to boot antergos live install in order to repair that line in the .conf file…

    karasu’s solution fixed my problem. However, when I disabled lightdm I couldn’t enable gdm because everything went blank. I just tapped the power button to bring up the menu, then hit the enter key and figured the system would shut itself down. After startup gdm automatically booted :) debating on whether or not I should remove webkit2/lightdm… Don’t wanna break anything lol.
    Update: removed it and everything is fine.

  • Like 0

    I am quite sure it’s the greeter problem. Any other lightdm greeter will work. You don’t have to use the pantheon one. Linux is about choice, and arch has a whole lot of them.

  • Like 0

    Had similar issues with the lightdm greeter being slow on xfce install. Disabled the login for now as I haven’t had time to decide which greeter to switch to. Still feel that cnchi should allow for the user to choose their login manager on install. Set the antergos greeter as default by all means, but still give the option. Just my opinion though.

  • Like 0

    @karasu said in The Login screen for Antergos is incredibly slow:

    If you’re using Gnome, a quick workaround can be to stop using our fancy theme with lightdm and try gdm instead:

    Press CTRL+ALT+F2 to switch to another console and login there. Type this commands to install GDM and use it:

    sudo pacman -Syu
    sudo pacman -S gdm
    sudo systemctl disable lightdm
    sudo systemctl enable gdm
    sudo systemctl stop lightdm
    sudo systemctl start gdm
    

    Hope this helps.

    Cheers!

    P.S. If you want to use lightdm no matter what, you should post here your logs.

    when i enter sudo systemctl stop lightdm, it jumped to a blank screen and i cant boot into it anymore.
    any solution?

  • Like 0

    I’m using KDE, my solution was to install sddm and use sddm instead which looks a whole lot better and no lag

  • Like 0

    @VolcaNoz you can just
    sudo systemctl disable lightdm
    sudo systemctl enable gdm
    reboot

    Antergos (default OS) - WIN10 (abandoned)
    I3wm - Mate desktop
    AMD - A4 7300 Radeon graphics
    16 GB ram
    HD 1 TB
    Linux newbie since 06/2016

  • Like 0

    @fernandomaroto i think i broke something here is the screen i get when i boot

  • Like 0

    @VolcaNoz Did you managed to install gdm before?
    i mean
    sudo pacman -S gdm

    I never saw this bug…Perhaps it’s because you stopped the service before,
    try again to open terminal and:

    sudo pacman -S gdm
    sudo systemctl disable lightdm
    sudo systemctl enable gdm
    sudo systemctl start gdm

    Antergos (default OS) - WIN10 (abandoned)
    I3wm - Mate desktop
    AMD - A4 7300 Radeon graphics
    16 GB ram
    HD 1 TB
    Linux newbie since 06/2016

  • Like 0

    @fernandomaroto yes i did follow the steps and installed gdm, sorry i am new to linux but how to open terminal when i cant boot into the system.

  • Like 1

    kernel is unable to find his initramfs. Wrong grub config file?

    @VolcaNoz you should boot with the livecd iso (as if you wanted to reinstall) and chroot from there to your installation:
    https://wiki.archlinux.org/index.php/change_root

login manager10 Posts 27Views 6164
Log in to reply